cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


860
Views
0
Helpful
35
Replies
VIP Advisor

Re: Problem with DHCP

So you confirmed all working as expected ? i did not get last post - is this measn your issue is solved ?

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Problem with DHCP

Hello good day,
sorry for my English.
I have SG350X-24, and I also have Vlan 1 with internet connection, but the other vlan 2,3,10, (etc)
they do not have internet connection ..
I'm following the thread because I have the same problem.
Thank you

Enthusiast

Re: Problem with DHCP

can you share switch routing details and switch running mode (l2 or l3)?
Beginner

Re: Problem with DHCP

this is the configuration that I followed
My IP router 172.22.0.1
and that of the IP switch 172.22.0.2

 

Switch-Cisco-01#configure terminal
Switch-Cisco-01(config)#interface vlan 1
Switch-Cisco-01(config-if)#ip address 172.28.0.1 255.255.0.0
Switch-Cisco-01(config-if)#no shutdown
Switch-Cisco-01(config-if)#exit
Switch-Cisco-01(config)#interface vlan 10
13-Dec-2018 20:52:42 %LINK-I-Up: Vlan 10
Switch-Cisco-01(config-if)#ip address 172.19.0.1 255.255.0.0
Switch-Cisco-01(config-if)#no shutdown
Switch-Cisco-01(config-if)#
Switch-Cisco-01(config-if)#exit
Switch-Cisco-01(config)#interface vlan 20
13-Dec-2018 20:53:25 %LINK-I-Up: Vlan 20
Switch-Cisco-01(config-if)#ip address 172.20.0.1 255.255.0.0
Switch-Cisco-01(config-if)#no shutdown
Switch-Cisco-01(config-if)#exit
Switch-Cisco-01(config)#interface vlan 30
13-Dec-2018 20:54:09 %LINK-I-Up: Vlan 30
Switch-Cisco-01(config-if)#ip address 172.30.0.1 255.255.0.0
Switch-Cisco-01(config-if)#no shutdown
Switch-Cisco-01(config-if)#exit
Switch-Cisco-01(config)#13-Dec-2018 20:55:06 %AAA-I-CONNECT: New http connection for user cisco, source 172.28.0.10 destination 172.28.0.1 ACCEPTED
13-Dec-2018 20:56:53 %LINK-W-Down: te1/0/2
13-Dec-2018 20:57:00 %LINK-I-Up: te1/0/2
13-Dec-2018 20:57:04 %STP-W-PORTSTATUS: te1/0/2: STP status Forwarding
Switch-Cisco-01(config)#interface te1/0/2
Switch-Cisco-01(config-if)#no switchport
Switch-Cisco-01(config-if)#ip address 172.22.0.2 255.255.0.0
Switch-Cisco-01(config-if)#no shutdown
Switch-Cisco-01(config-if)#exit
Switch-Cisco-01(config)#ip route 0.0.0.0 0.0.0.0 172.22.0.1
Switch-Cisco-01(config)#end
Switch-Cisco-01#copy running-config startup-config
Overwrite file [startup-config].... (Y/N)[N] ?Y
13-Dec-2018 21:02:38 %COPY-I-FILECPY: Files Copy - source URL running-config destination URL flash://system/configuration/startup-config
13-Dec-2018 21:02:40 %COPY-N-TRAP: The copy operation was completed successfully
Copy succeeded
Switch-Cisco-01#

Enthusiast

Re: Problem with DHCP

what is the switch mode configured? also have you added incoming routed from your router to inside switch?
Highlighted
Beginner

Re: Problem with DHCP

Problem solved, it was necessary to put back the mask of the Modem ADSL with 255.255.255.0 thanks for everyone cordially