cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


2778
Views
0
Helpful
4
Replies
IainMcManus
Beginner

Problem with SG-200 and access point on VLAN

I'm having some difficulties with the VLAN setup on the SG-200 and the WiFi access point. The access point (a TP-Link WA801N) is only able to access the internet when it is plugged into a port that is on the default VLAN (PVID 1). If I plug it into one of the other VLANs then any clients connected to the WiFi lose access to the internet and cannot access devices on the VLAN. I have previously used this setup with a first generation Cisco WAP4410N.

I'm unsure if it's a case of something wrong with how I've configured the switch or an issue with the access point.

The setup I have is:

ADSL Modem/Router (Billion 7800N)

                       |

-------------------Port 1--------------------

|                                               |

|               SG-200 08                |

|                                               |

----------Port 3-----------Port 8----------

             |                    |

   Access Point           |

(TP-Link WA801N)       |

                                 |

                           SF-100D

The port setups are

Port   Mode      PVID   Membership

1       General   1         1U, 7U, 666U

2       General   1         1U, 7U, 666U

3       General   7         1U, 7U

4       General   7         1U, 7U

5       General   7         1U, 7U

6       General   7         1U, 7U

7       General   666      1U, 666U

8       General   666      1U, 666U

1 ACCEPTED SOLUTION

Accepted Solutions

Iain,

Do you have the vlans set up on your router? What subnets are you using on each vlan? Will the router give DHCP for each vlan?

The SG200 is not a fully managed layer 3 switch, it is just a "smart switch" so you may not actually be able to do it on just the switch alone. A sg300 in layer 3 mode would be able to do this as it is a fully managed switch.

If the router is set up with the vlans, vlan 1 untagged, the remainder tagged, the port from the router -> SG200 is trunked, and the others as access ports on their respective vlan. Once the router is configured, this video from top forum contributor and Cisco employee David Hornstein is very helpful with properly configuring the switch.

Best,

David

Please rate helpful posts.

View solution in original post

4 REPLIES 4
Davidwagman1
Rising star

Hi Iain,

A few questions to try and help get this resolved for you.

1) What is the default vlan on the AP?

2) What is the reasoning behind using general rather than trunk ports?

3) what is the purpose of the vlans? What traffic are you trying to segregate? Wireless from the wired network off the SF100?

Best,

David

Hi David,

1) What is the default vlan on the AP?

  - I've looked at the settings on the AP and I can't find any for configuring the VLAN

2) What is the reasoning behind using general rather than trunk ports?

  - I'm pretty new to configuring VLANs and general seemed like it covered everything. Should I be using trunk for the ports that are connected to the AP?

3) what is the purpose of the vlans? What traffic are you trying to segregate? Wireless from the wired network off the SF100?

  - That's correct, I'm trying to isolate the wireless network from the internal wired network. Both need internet access but wireless and wired clients should never be able to see each other.

Regards

Iain

Iain,

Do you have the vlans set up on your router? What subnets are you using on each vlan? Will the router give DHCP for each vlan?

The SG200 is not a fully managed layer 3 switch, it is just a "smart switch" so you may not actually be able to do it on just the switch alone. A sg300 in layer 3 mode would be able to do this as it is a fully managed switch.

If the router is set up with the vlans, vlan 1 untagged, the remainder tagged, the port from the router -> SG200 is trunked, and the others as access ports on their respective vlan. Once the router is configured, this video from top forum contributor and Cisco employee David Hornstein is very helpful with properly configuring the switch.

Best,

David

Please rate helpful posts.

View solution in original post

Hi David,

Switching over the appropriate ports to be trunked and setting up the tagging sorted out the issue. The setup is working perfectly. Thanks for your help!

Iain