cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2046
Views
0
Helpful
5
Replies

PXE boot SG500-28 with LACP configured

kionysus
Level 1
Level 1

I've got a SG500-28 that I'm trying to create a dynamic LACP bundle but still have it be able to PXE boot on a primary interface without manual intervention. I've discovered that the following configuration works, as long as I physically disconnect the second (1/20) interface so that the primary(1/8) is the only one with link during the PXE process. The biggest issue from what I can tell is there is no way to tell the second (1/20) interface to be passive. This is covered on pages 192-193 of this guide https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/Sx500/administration_guide/Cisco_500Sx_v1_4_AG.pdf but it doesn't appear to work as designed or I'm completely missing something.

 

 

interface gigabitethernet1/8
 flowcontrol auto
 negotiation preferred master
 description "Port 1"
 lacp timeout short
 spanning-tree portfast
 channel-group 8 mode auto
 no macro auto smartport
!
interface gigabitethernet1/20
 flowcontrol auto
 description "Port 2"
 lacp timeout short
 no spanning-tree portfast
 channel-group 8 mode auto
 no macro auto smartport
!
interface Port-channel8
 flowcontrol auto
 description "Port-Channel"
 spanning-tree portfast
 switchport trunk allowed vlan add 732
 switchport trunk native vlan 70
!

 

5 Replies 5

Sujoy Paria
Cisco Employee
Cisco Employee

Hi,

Please change the LACP port priority to 2 for the second interface (1/20) and check the status once (the default priority is 1). I think you want to achieve the below mentioned output (please check the partner section output for the port gi1/1/20)…

 

switchc6f8a9#show lacp parameters gi1/1/8

gi1/1/8 LACP parameters:

      Actor

              system priority:       1

              system mac addr:       00:8e:73:c6:f8:a9

              port Admin key:        1000

              port Oper key:         1000

              port Oper number:      56

              port Admin priority:   1

              port Oper priority:    1

              port Admin timeout:    LONG

              port Oper timeout:     LONG

              LACP Activity:         ACTIVE

              Aggregation:           AGGREGATABLE

              synchronization:       TRUE

              collecting:            TRUE

              distributing:          TRUE

              expired:               FALSE

      Partner

              system priority:       1

              system mac addr:       20:37:06:33:ee:6f

              port Admin key:        0

              port Oper key:         1000

              port Oper number:      56

              port Admin priority:   0

              port Oper priority:    1

              port Oper timeout:     LONG

              LACP Activity:         ACTIVE

              Aggregation:           AGGREGATABLE

              synchronization:       TRUE

              collecting:            TRUE

              distributing:          TRUE

              expired:               FALSE

switchc6f8a9#show lacp parameters gi1/1/20

gi1/1/20 LACP parameters:

      Actor

              system priority:       1

              system mac addr:       00:8e:73:c6:f8:a9

              port Admin key:        1000

              port Oper key:         1000

              port Oper number:      68

              port Admin priority:   2

              port Oper priority:    2

              port Admin timeout:    LONG

              port Oper timeout:     LONG

              LACP Activity:         ACTIVE

              Aggregation:           AGGREGATABLE

              synchronization:       FALSE

              collecting:            FALSE

              distributing:          FALSE

              expired:               FALSE

      Partner

              system priority:       0

              system mac addr:       00:00:00:00:00:00

              port Admin key:        0

              port Oper key:         0

              port Oper number:      0

              port Admin priority:   0

              port Oper priority:    0

              port Oper timeout:     LONG

              LACP Activity:         PASSIVE

              Aggregation:           AGGREGATABLE

              synchronization:       FALSE

              collecting:            FALSE

              distributing:          FALSE

              expired:               FALSE

switchc6f8a9#

And make sure the switch firmware is latest 1.4.10.6.

switchc6f8a9#show version

 

       Unit             SW version         Boot version         HW version

------------------- ------------------- ------------------- -------------------

         1               1.4.10.6            1.4.0.02               V03

 

switchc6f8a9#show system

 

Unit          Type

---- ----------------------

 1        SG500-28MPP

 

Unit   FAN

       Status

----   ---------

 1        OK

 

Unit   Temperature (Celsius)   Temperature Sensor Status

---- ------------------------- -------------------------

 1              28                        OK

 

 

Unit     Up time

---- ---------------

 1     00,00:31:23

 

switchc6f8a9#s

 

Note: Please take a configuration back-up (working condition) from the mentioned switches before changing any configuration on the switch.

Please check the attached snapshot as well.

 

Sorry for the late reply. That didn't seem to do the trick. It appears to still be creating the PortChannel on the switch side and PXE never gets an offer from the DHCP server for the NIC attached to 1/8. If I unplug port 1/20's cable it works. Does my spanning-tree mismatch have anything to do with this?

 

#show running-config interface gigabitethernet1/8
interface gigabitethernet1/8
flowcontrol auto
negotiation preferred master
description "Port 1"
lacp timeout short
spanning-tree portfast
channel-group 8 mode auto
no macro auto smartport
!
#show running-config interface gigabitethernet1/20
interface gigabitethernet1/20
flowcontrol auto
description "Port 2"
lacp timeout short
lacp port-priority 2
no spanning-tree portfast
channel-group 8 mode auto
no macro auto smartport
!
#show running-config int Port-Channel8
interface Port-channel8
flowcontrol auto
description "Port-Channel"
spanning-tree portfast
switchport trunk allowed vlan add 732
switchport trunk native vlan 70
!

The following is seen in the buffer on the switch during the PXE boot process:

 

03-Nov-2019 15:30:44 %STP-W-PORTSTATUS: Po8: STP status Forwarding, aggregated (1)
03-Nov-2019 15:30:44 %LINK-I-Up: Po8, aggregated (1)
03-Nov-2019 15:32:46 %TRUNK-W-PORTREMOVED: Port gi1/8 removed from Po8
03-Nov-2019 15:32:46 %TRUNK-W-PORTREMOVED: Port gi1/20 removed from Po8
03-Nov-2019 15:32:47 %LINK-W-Down: Po8
03-Nov-2019 15:32:47 %LINK-W-Down: gi1/8
03-Nov-2019 15:32:47 %LINK-W-Down: gi1/20
03-Nov-2019 15:32:51 %LINK-I-Up: gi1/20
03-Nov-2019 15:32:51 %LINK-I-Up: gi1/8

03-Nov-2019 15:32:54 %LINK-W-Down: gi1/20, aggregated (1)
03-Nov-2019 15:32:54 %LINK-W-Down: gi1/8, aggregated (1)
03-Nov-2019 15:32:57 %LINK-I-Up: gi1/20, aggregated (1)
03-Nov-2019 15:32:57 %LINK-I-Up: gi1/8, aggregated (1)
03-Nov-2019 15:33:02 %TRUNK-I-PORTADDED: Port gi1/8 added to Po8
03-Nov-2019 15:33:02 %STP-W-PORTSTATUS: Po8: STP status Forwarding
03-Nov-2019 15:33:02 %LINK-I-Up: Po8
03-Nov-2019 15:33:18 %TRUNK-W-PORTREMOVED: Port gi1/8 removed from Po8
03-Nov-2019 15:33:18 %LINK-W-Down: gi1/20, aggregated (1)
03-Nov-2019 15:33:20 %LINK-I-Up: gi1/8, aggregated (1)
03-Nov-2019 15:33:20 %LINK-I-Up: gi1/20, aggregated (1)
03-Nov-2019 15:33:25 %TRUNK-I-PORTADDED: Port gi1/8 added to Po8, aggregated (1)
03-Nov-2019 15:33:25 %STP-W-PORTSTATUS: Po8: STP status Forwarding, aggregated (1)
03-Nov-2019 15:33:25 %LINK-I-Up: Po8, aggregated (1)
03-Nov-2019 15:33:45 %TRUNK-W-PORTREMOVED: Port gi1/8 removed from Po8, aggregated (1)
03-Nov-2019 15:33:45 %LINK-W-Down: gi1/8, aggregated (2)
03-Nov-2019 15:33:45 %LINK-W-Down: Po8, aggregated (2)
03-Nov-2019 15:33:47 %TRUNK-I-PORTADDED: Port gi1/20 added to Po8
03-Nov-2019 15:33:47 %STP-W-PORTSTATUS: Po8: STP status Forwarding, aggregated (1)
03-Nov-2019 15:33:47 %LINK-I-Up: Po8, aggregated (1)
03-Nov-2019 15:33:47 %LINK-I-Up: gi1/8, aggregated (1)
03-Nov-2019 15:34:22 %TRUNK-W-PORTREMOVED: Port gi1/20 removed from Po8
03-Nov-2019 15:34:22 %LINK-W-Down: gi1/20

#show lacp parameters gi1/1/8
gi1/8 LACP parameters:
Actor
system priority: 1
system mac addr: 00:8e:73:c2:f2:b4
port Admin key: 1007
port Oper key: 1007
port Oper number: 56
port Admin priority: 1
port Oper priority: 1
port Admin timeout: SHORT
port Oper timeout: SHORT
LACP Activity: ACTIVE
Aggregation: AGGREGATABLE
synchronization: TRUE
collecting: TRUE
distributing: TRUE
expired: FALSE
Partner
system priority: 65535
system mac addr: a0:36:9f:85:65:b4
port Admin key: 0
port Oper key: 9
port Oper number: 1
port Admin priority: 0
port Oper priority: 255
port Oper timeout: LONG
LACP Activity: ACTIVE
Aggregation: AGGREGATABLE
synchronization: TRUE
collecting: TRUE
distributing: TRUE
expired: FALSE

 

#show lacp parameters gi1/1/20
gi1/20 LACP parameters:
Actor
system priority: 1
system mac addr: 00:8e:73:c2:f2:b4
port Admin key: 1007
port Oper key: 1007
port Oper number: 68
port Admin priority: 2
port Oper priority: 2
port Admin timeout: SHORT
port Oper timeout: SHORT
LACP Activity: ACTIVE
Aggregation: AGGREGATABLE
synchronization: TRUE
collecting: TRUE
distributing: TRUE
expired: FALSE
Partner
system priority: 65535
system mac addr: a0:36:9f:85:65:b4
port Admin key: 0
port Oper key: 9
port Oper number: 2
port Admin priority: 0
port Oper priority: 255
port Oper timeout: LONG
LACP Activity: ACTIVE
Aggregation: AGGREGATABLE
synchronization: TRUE
collecting: TRUE
distributing: TRUE
expired: FALSE

Hi,

Please use 'LACP Timeout' parameter as 'Long' instead of 'Short' on port 8 and 20, it seems that is creating the problem.

This never worked. I ended up buying a SG350X-24 and am running into the exact same issue. Can someone paste into here a vanilla config that shows how I can setup an LACP port channel that allows me to pxe boot off of the first interface in the LACP bundle? The ONLY way I can make this work is by physically disconnecting port 2...mind you admin down the second interface doesn't work.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Switch products supported in this community
Cisco Business Product Family
  • CBS110
  • CBS220
  • CBS250
  • CBS350
Cisco Switching Product Family
  • 110
  • 200
  • 220
  • 250
  • 300
  • 350
  • 350X
  • 550X