cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Questions on Cisco SF300-24P

tony08695
Beginner
Beginner

Hello there,

We are trying to config vlan 10 for data and vlan 20 for voice on the same port - port 1 of swtich SF300-24P to run both data and voice on different vlans.

How can we achieve this?

Do I have to add vlan 10 as an untagged vlan to port 1 and add vlan 20 as an tagged vlan to port 1?

If I do not want to assign the native vlan 1 to port 1, how can I remove it ? The GUI page - assign VLAN to port does not allow to remove it.

Aslo, what mode shall I set up on port 1? General, trunk or access ?

Appreciate your reply and helps.

Thanks,

Tony

21 REPLIES 21

Actually the end of sale date on the 7961 phones was January 19 2010.

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6788/phones/ps379/end_of_life_notice_c51-520685.html

More specifically what I was referrring to was being able to use 802dot1Q encapsulation so these switches could work together with 2800 and 2900 switches for multiple vlans per interface. For that matter they wont even work with an ASA5505 in a trunked environment.

7960 and 7940 which is what was discussed in this post was EOL'd back in 2002:

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6788/phones/ps379/prod_end-of-life_notice09186a0080088a2c.html

802.1Q encapsulation works with all standards-based products, including the ones you've mentioned. Make sure that you set the encapsulation to "dot1q" on the router side:

switchport trunk encapsulation dot1q

Contact the Support org and they will help you through getting this to work.

BTW, the reason why you're not seeing the phone as an LLDP Neighbor is because those older phones do not support LLDP-MED. You have to set the voice VLAN on the phone manually.

This is an old thread, but for the benefit of anyone searching, a firmware release has been made that allows the 200 and 300 series Small Business switches to support Cisco Inline Power, aka pre-standard POE.

https://supportforums.cisco.com/docs/DOC-18337

This means that those switches will indeed power the CP-7940/CP-7960 and the CP-7940G/CP7960G, even though they do not support the 802.3af standard. A number of older third-party switches also support CIP, but there is no list that I have found that specifies which ones do and do not. The CP-7941/CP-7961 that tahequivoice referred to are different phones (though they look nearly identical) that do support 802.3af out of the box.

Please note, however, that the updated firmware has not been released for all 200 and 300 series switches. As the comments at that link mention, the firmware has yet to be released for the SG200-08P, among others.

As for throwing these phones out because they are "kinda old"? That makes no sense and would be extremely wasteful. The Panoptic adapters mentioned seem to be available for $27.00 each, which really might be the best long-term solution, as it makes them 802.3af compliant (though I have never used one).

All 300 series switches and all 200 series switches support Cisco Inline power except for SG200-08P and the 200E models.These models use a different chipset and software and do not support this capability.

Thanks,

Ivor

The issue I think has nothing to do with the model of phone am using cp3905 and still cannot get what I want. It will pick the untagged vlan ip and give the system same. What I want is that the phone pick its voice vlan and give the pc connected to it data vlan. I have tried all the suggestions and still cannot get it working as I want. Not that the phone does not work with the data vlan but I want it to take its own vlan.

Hello,

Im sorry you haven't been able to resolve this issue in so long. 

Mid you are already using the port as trunk with VLAN 10 untagged and 20 tagged then the issue is not on the port but somewhere else on the configuration. 

The first step is probably gathering all the network topology showing the voice devices, phones, pbx and such. It will be important to show the ports evetythibG is conneCted to showing the Vlans and port configuration. 

I hope this helps. 

here is my layer 2 switch configuration.

I can connect the phone now and it will get voice vlan but the PC connected to the phone or the port cannot get data vlan.

Is there anything that I did wrong or did not do

sh run

config-file-header
RACKCSW3
v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0
set system mode switch

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
default-vlan vlan 500
exit
vlan database
vlan 1,11,14,110,113
exit
voice vlan id 113
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
port-channel load-balance src-dst-mac-ip
gvrp enable
no lldp med network-policy voice auto
lldp med network-policy 1 voice vlan 113 vlan-type tagged
qos trust cos-dscp
qos dscp-mutation
wrr-queue cos-map 2 0
wrr-queue cos-map 3 2
wrr-queue cos-map 3 6
wrr-queue cos-map 3 7
qos wrr-queue wrtd
ip access-list extended VVlan-Voice
exit
priority-queue out num-of-queues 0
hostname RACKCSW3
no logging console
aaa authentication enable telnet enable
enable password level 15 encrypted 6ac17a623746f239d2a26bb455570baa07ded8e4
no passwords complexity enable

ip ssh server
snmp-server location "RACK C"
snmp-server community default
no ip http server
clock timezone " " 1
no ip domain lookup
!
interface vlan 1
 no ip address dhcp
!
interface vlan 11
 name data

!
interface vlan 113
 name voice
!
interface vlan 500
 name management
 ip address 172.23.0.11 255.255.255.0
!
interface fastethernet1
 switchport trunk allowed vlan add 113
 switchport trunk native vlan 11
 no lldp transmit
 lldp med disable
 macro description "switch | ip_phone_desktop"
 switchport default-vlan tagged
!
interface fastethernet2
 storm-control broadcast enable
 storm-control broadcast level 10
 storm-control include-multicast
 port security max 10
 port security mode max-addresses
 port security discard trap 60
 spanning-tree portfast
 switchport trunk allowed vlan add 113
 switchport trunk native vlan 11
 no lldp transmit
 lldp optional-tlv sys-cap
 lldp med enable network-policy location
 lldp med network-policy add 1

!
interface fastethernet3
 switchport trunk allowed vlan add 113
 switchport trunk native vlan 11
 no lldp transmit
 lldp med disable
 macro description "switch | ip_phone_desktop"
 switchport default-vlan tagged

 

interface gigabitethernet3
 description UPLINK-FROM-CORESWITCH
 spanning-tree link-type point-to-point
 channel-group 2 mode auto
 macro description switch
!
interface gigabitethernet4
 channel-group 2 mode auto
!
interface Port-channel2
 description "uplink redundancy coreswitch"
 spanning-tree link-type point-to-point
 switchport trunk allowed vlan add 1,14,110,113
 switchport trunk native vlan 11
 macro description switch
 switchport default-vlan tagged
 !next command is internal.
 macro auto smartport dynamic_type switch
!
exit
macro auto processing type host enabled
macro auto processing type router enabled
macro auto built-in parameters desktop $max_hosts 10 $native_vlan 11
macro auto built-in parameters server $max_hosts 10 $native_vlan 11
macro auto built-in parameters host $max_hosts 10 $native_vlan 11
macro auto built-in parameters ip_phone $max_hosts 10 $native_vlan 113
macro auto built-in parameters ip_phone_desktop $max_hosts 10 $native_vlan 11
macro auto built-in parameters switch $native_vlan 11
macro auto built-in parameters router $native_vlan 11
macro auto built-in parameters ap $native_vlan 11

Actually have been able to resolve the issue by the global command no lldp run and interface lldp med disable command.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: