cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


320
Views
0
Helpful
2
Replies
Highlighted
Beginner

Routing in SG500-52

Hi all,

 

I want to permit several VLAN reach internet but can't with the setup (maybe poorly!) I designed. Here goes...

I have 3 VLANs to do InterVLAN routing in a switch Layer 3 and for reach the internet with gateway. My problem is the L3 switch that don't route to a gateway and do it to another. Here are some o the configs (try to minimize not to give you all much trouble!):

 

SWITCH L3

set system mode router queues-mode 4 
...

interface vlan 100
name FORMACAO
ip address 192.168.100.50 255.255.255.0
ip dhcp relay enable
!
interface vlan 110
name OPERACOES
ip address 192.168.110.50 255.255.255.0
ip dhcp relay enable
!
interface vlan 120
name SERVIDORES
ip address 192.168.200.50 255.255.255.0

...
interface gigabitethernet1/1/18
description "GW UBIQUITI"
switchport trunk allowed vlan add 100,110,120,400,500
...
interface gigabitethernet1/1/48
description IPBRICK
ip source-guard
switchport mode access
switchport access vlan 120
...
ip default-gateway 172.30.1.254

 

The default gateway 172.30.1.254 is on "gigabitethernet1/1/18" and if I change to "ip default-gateway 192.168.200.254" all works fine (port "gigabitethernet1/1/48" ).

Some more info within switch:

 

SW-RT-Servidores#sh ip route
Maximum Parallel Paths: 1 (1 after reset)
IP Forwarding: enabled
Codes: > - best, C - connected, S - static
S 0.0.0.0/0 [1/1] via 172.30.1.254, 00:01:21, vlan 400
S 10.0.0.0/8 [1/1] via 192.168.200.254, 195:30:49, vlan 120
C 172.16.0.0/16 is directly connected, vlan 500
C 172.30.1.252/30 is directly connected, vlan 400
C 192.168.1.0/24 is directly connected, vlan 1
C 192.168.100.0/24 is directly connected, vlan 100
C 192.168.110.0/24 is directly connected, vlan 110
C 192.168.200.0/24 is directly connected, vlan 120

 

SW-RT-Servidores#traceroute ip 8.8.8.8
Tracing the route to google-public-dns-a.google.com (8.8.8.8) from , 30 hops max, 18 byte packets
Type Esc to abort.
1 172.30.1.254 (172.30.1.254) <20 ms <80 ms <20 ms
2 192.168.254.250 (192.168.254.250) <20 ms <20 ms <20 ms
3 xxxx-79-85-21.static.net.xxxx.pt (xxx.79.85.21) <20 ms <20 ms <20 ms
4 10.255.48.82 (10.255.48.82) <20 ms <20 ms
Trace aborted.

 

Here are more configs from different equipments. From a PC with gw to the switch:

tracert 8.8.8.8

1 2 ms 3 ms 4 ms 192.168.100.50
2 * * * O pedido excedeu o tempo.
3 * * * O pedido excedeu o tempo.

 

but if I change to "ip default-gateway 192.168.200.254" all works fine!

tracert 8.8.8.8

1 1 ms 4 ms 4 ms 192.168.100.50
2 1 ms <1 ms <1 ms proxy.cinel.ufp [192.168.200.254]
3 1 ms <1 ms <1 ms 192.168.254.250
4 2 ms 2 ms 2 ms xxxx-79-85-21.static.net.xxxx.pt [xxx.79.85.21]
5 7 ms 6 ms 6 ms 10.255.48.82
6 6 ms 6 ms 6 ms xx.14.xx.210

 

the ip routing table from the default gateway 172.30.1.254:

 

admin@GATEWAY:~$ show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

S>* 0.0.0.0/0 [1/0] via 192.168.254.250, eth2
C>* 127.0.0.0/8 is directly connected, lo
C>* 172.16.0.0/16 is directly connected, eth0.500
C>* 172.30.1.252/30 is directly connected, eth0.400
C>* 192.168.1.0/24 is directly connected, eth0
C>* 192.168.100.0/24 is directly connected, eth0.100
C>* 192.168.110.0/24 is directly connected, eth0.110
C>* 192.168.200.0/24 is directly connected, eth0.120
C>* 192.168.254.0/24 is directly connected, eth2

 

To my knowledge all should worked but...

Can you guys please put me in the right path?

 

Thanks and if you need more configs tell me please!

 

 

 

 

 

 

 

 

 

 

Everyone's tags (2)
2 REPLIES 2
Cisco Employee

Re: Routing in SG500-52

Hello Verdura,

Try to assign the IP to VLAN 400 from 172.30.1.252/30 network.

What happens?

Cheers,

Mike

Beginner

Re: Routing in SG500-52

I already have done it:

 

 

interface vlan 100
name FORMACAO
ip address 192.168.100.50 255.255.255.0
ip dhcp relay enable
!
interface vlan 110
name OPERACOES
ip address 192.168.110.50 255.255.255.0
ip dhcp relay enable
!
interface vlan 120
name SERVIDORES
ip address 192.168.200.50 255.255.255.0
!
interface vlan 400
name SW-GW
ip address 172.30.1.253 255.255.255.252
!