cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


10535
Views
15
Helpful
14
Replies
Highlighted
Beginner

Series 300 switches - MAC Address Tables

Are the MAC Address Tables managed per VLAN? We need to have the VLAN work with a MAC address that is also on a different VLAN.

We are testing a device that has 4 ethernet ports, each having a different IP Address, but they all share the same MAC address. so i would like to be able to have 4 individual VLANS in the switch for testing.

So the need is a switch that manages the MAC address's per VLAN not globally by the switch. Does the Series 300 do this or is there another recommendation for a switch.

Regards,

Dave

Everyone's tags (6)
14 REPLIES 14
Highlighted
Cisco Employee

Series 300 switches - MAC Address Tables

Hello Dave,

As you probably noticed small business switches 300 series or even 500 series do not support MAC address table per VLAN.

This is possible on IOS switches only, such as Catalyst 6500: http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00801c9b4e.shtml

Regards,

Aleksandra Dargiel

Highlighted
Rising star

Series 300 switches - MAC Address Tables

Good morning

Hi dave, thanks for using our forum, my name is Johnnatan and I am part of the Small business Support community. To add to aleksandra´s post, the SMB switches doesn´t have that features, the only models that supports MAC address table per VLAN are the enterprise series that have IOS

I hope you find this answer useful,

“Please rate useful posts so other users can benefit from it”

Greetings,

Johnnatan Rodriguez Miranda.

Cisco Network Support Engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.
Highlighted
Cisco Employee

Series 300 switches - MAC Address Tables

Hi Dave:

Series 300 does support IVL, you can see mac address table below from switch console:

switch8c5fa6#
switch8c5fa6#
switch8c5fa6#show mac address-table dy
Aging time is 300 sec

  Vlan        Mac Address         Port       Type   
-------- --------------------- ---------- ----------
   1       00:26:0a:4c:d2:04     gi1/13    dynamic  
   1       00:50:56:95:41:81     gi1/13    dynamic  
   1       e4:1f:13:77:9f:07     gi1/13    dynamic  
   1       f4:ea:67:8c:b2:b6     gi1/13    dynamic  
  101      00:11:11:11:11:11     gi1/21    dynamic  
  102      00:11:11:11:11:11     gi1/22    dynamic  
  103      00:11:11:11:11:11     gi1/23    dynamic  
  104      00:11:11:11:11:11     gi1/24    dynamic  

You can see different vlans (101-104) learned same MAC address which matches your posted request.

Highlighted
Advocate

Re: Series 300 switches - MAC Address Tables

The switch supports mac address table per vlan.. it doesn't support pipe or inc/exc/beg toggles, etc.

switchce82d3#show mac address-table vlan 1

Aging time is 300 sec

  Vlan        Mac Address         Port       Type

-------- --------------------- ---------- ----------

   1       00:22:58:97:80:76      fa5      dynamic

   1       00:26:f2:ad:59:f2      fa5      dynamic

   1       10:8c:cf:ce:82:d3       0         self

   1       18:87:96:b6:9c:52      fa5      dynamic

   1       58:6d:8f:46:46:f6      fa5      dynamic

   1       64:31:50:1c:50:d3      fa8      dynamic

   1       88:53:2e:57:a3:f5      fa5      dynamic

   1       a8:26:d9:57:7e:96      fa5      dynamic

switchce82d3#show mac address-table vlan 2

Aging time is 300 sec

  Vlan        Mac Address         Port       Type

-------- --------------------- ---------- ----------

   2       00:26:0b:0d:82:11      fa2      dynamic

switchce82d3#show mac address-table

Aging time is 300 sec

  Vlan        Mac Address         Port       Type

-------- --------------------- ---------- ----------

   1       00:22:58:97:80:76      fa5      dynamic

   1       10:8c:cf:ce:82:d3       0         self

   1       18:87:96:b6:9c:52      fa5      dynamic

   1       58:6d:8f:46:46:f6      fa5      dynamic

   1       64:31:50:1c:50:d3      fa8      dynamic

   1       88:53:2e:57:a3:f5      fa5      dynamic

   1       a8:26:d9:57:7e:96      fa5      dynamic

   2       00:26:0b:0d:82:11      fa2      dynamic

switchce82d3#show mac address-table ?

  count                MAC addresses count

  dynamic              dynamic addresses

  secure               Show secure addresses

  static               Show static addresses

  vlan                 Specific VLAN

  interface            Specify an interface ID. The interface ID can be one

                       of the following types: Ethernet port or Port-channel

  address              Specific MAC address

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted
Beginner

Re: Series 300 switches - MAC Address Tables

Hi,

I have similar requirements for the switch. Since now 2 different opinions have been posted. Hmm... which is more convincing?

I thought all modern manageable switches performs full isolation of VLANs - they behave like separate physical switches (so assumption about separate lookup tables) - having the same MAC address on different VLANs at the same time does not confuse them.

Best regards,

Lukasz

Highlighted
Beginner

Series 300 switches - MAC Address Tables

The first 2 posts are saying the switch itself has only one mac.

Highlighted
Cisco Employee

Series 300 switches - MAC Address Tables

Hi Lukasz,

Following the whole confusion on this post I have done the following test which was successful. Please let me know if this is not what you are trying to do.

2 PC with the same MAC address but 2 different IP

connected to 2 different ports in 2 different VLANs:

switch0d810b#show arp

Total number of entries: 3

VLAN   Interface     IP address       HW address         status

--------------------- --------------- ------------------- ---------------

vlan 1     gi1       192.168.1.100   00:1e:33:56:b5:a9   dynamic

vlan 2     gi2       192.168.2.100   00:1e:33:56:b5:a9   dynamic

vlan 3     gi3       192.168.3.100   00:22:64:c1:14:9a   dynamic

switch0d810b#show mac address-table

Aging time is 300 sec

Vlan       Mac Address         Port       Type

-------- --------------------- ---------- ----------

   1      00:1e:33:56:b5:a9     gi1     dynamic

   1       00:26:0b:0d:81:0b       0         self

   2       00:1e:33:56:b5:a9     gi2     dynamic

   3       00:22:64:c1:14:9a     gi3     dynamic

tested with ping between those 2 PC as well as from the 3rd one (port gi3) and switch itself work as expected

for your reference switch configuration in layer 3 was as simple as below:

switch0d810b#

interface vlan 1

ip address 192.168.1.254 255.255.255.0

no ip address dhcp

!

interface vlan 2

ip address 192.168.2.254 255.255.255.0

!

interface vlan 3

ip address 192.168.3.254 255.255.255.0

!

interface gigabitethernet1

switchport mode access

!

interface gigabitethernet2

switchport mode access

switchport access vlan 2

!

interface gigabitethernet3

switchport mode access

switchport access vlan 3

!

exit

Regards,

Aleksandra

Highlighted
Beginner

Series 300 switches - MAC Address Tables

Hi Aleksandra,

The example you provided demonstrate very well what I'm trying to do. My team is working on device (I'm embedded SW/HW engineer with some CCNA / IT administration background in the beginnings on my carieer :-)), with few Ethernet interfaces with the same MAC (in fact those interfaces will be made by some tuned Ethernet switch chip - it's why MAC addresses will be duplicated).

I'd like to buy a switch which will let me test those devices. It seems Cisco SG300-28 fulfills my requirements - I'm going to buy it.

Thank you very much!

Highlighted
Beginner

Series 300 switches - MAC Address Tables

jialbert wrote:

The first 2 posts are saying the switch itself has only one mac.


In other words - it is not possible to assign different MAC address for the switch on each VLAN. Did I understand well?

Highlighted
Advocate

Series 300 switches - MAC Address Tables

Hi Lukasz, the switch should only display 1 system MAC address regardless of VLAN. Each port does have a MAC address however those should not be ARP or be included in a bridge table.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted
Beginner

Series 300 switches - MAC Address Tables

Hi Lukasz,

Tom's explaination is correct. and let me explain more:

Vlan by itself is virtual, and has no MAC as identification.

VLAN interface with IP address has MAC, which is the system MAC that Tom mentioned.

System MAC is used as destination MAC for the switch when you ping the switch or use switch as IP gateway.

Each physical port has its MAC. SMB switch cannot change these port MAC.

You can see these MAC as source MAC by capturing Spanning Tree BPDU packet coming out from each port.

Highlighted
Beginner

Series 300 switches - MAC Address Tables

Hi All,

i have the same query:

can i have two PC has the same mac-address and different IP address from the same subnet.

if yes without issue, does switch 2950 or higher support this feaure or do i need specific configuration on the switch?

thanks in advanced.

Highlighted
Beginner

Series 300 switches - MAC Address Tables

if the 2 PC are in same vlan , no,

because switch need to bind MAC to fixed port+vlan to send the packet.

same MAC makes confusion and packet will get lost.

if the 2 PC are in difference vlan, yes

Highlighted
Beginner

Series 300 switches - MAC Address Tables

Hello jialbert,

Thanks alot fot this information.