cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


4190
Views
0
Helpful
1
Replies
Highlighted
Beginner

SF 300-24 Switch and IP Phones

I didn't know whether to place this in here or in the IP telephony section. Anyway, we recently had some lightning damage a switch. It's in a little used building (four computers, two phones) so instead of replacing it with the same switch (Catalyst 29xx series), I did a little research and found the SF-300-24 should be able to do the same thing for much cheaper.

Anyway, I was a little surprised when I got the switch and couldn't do much from the command line. Here's a snippet of my config from the old router...

interface FastEthernet 0/1

  switchport access vlan 2

  switchport trunk encapsulation dot1q

  switchport mode trunk

  switchport voice vlan 2

(other ports same)

interface vlan1

  ip address 100.234.10.4 255.255.252.0

  no ip directed-broadcast

  no ip-route cache

Anyway, I am trying to get the new switch to work and I'm having trouble getting the ip phones to work. I've given all ports access to VLAN 1 (default) and VLAN 2 which is the vlan our core router uses for the ip phone network. Using a Cisco 7940 phone (along with Cisco Unified CM version 7.1.3.21901-1). When I plug a computer into the new switch (which I've programmed to use the same ip as the old switch), I'm able to browse internet, access network, etc. However, when I plug a phone in, it constantly says "Configuring IP" - it's not grabbing any of the correct settings (ip address is in the 100.234.8.x and not in the 100.234.5.x that phones should be getting). TFTP server is blank (should be 100.234.7.250) and default router shows the gateway and not what other phones are grabbing (100.234.5.50).

Any ideas?

Thanks,

Brent

Everyone's tags (3)
1 REPLY 1
Rising star

Re: SF 300-24 Switch and IP Phones

Hi Brent,

Don't really want to underestimate the value of catalyst switches with their extensive command line flexability, debugging etc..

But to answer your question, here  is my factory defaulted switch  configuration below which is using version 1.1 of the firmware.

What is presented below is the  configuration that the SG300 switch put together as a result of advertising in my UC500 what the voice VLAN is via CDP.

The only thing I manually configured onto my switch are the commands in red. G1, G2 and G5 have IP phones connected to them

User Name:cisco

Password:*****

switch0fdcfd#sh run

interface range gi1-2,gi5

storm-control broadcast enable

exit

interface gigabitethernet1

storm-control broadcast level 10

exit

interface gigabitethernet1

storm-control include-multicast

exit

interface gigabitethernet2

storm-control broadcast level 10

exit

interface gigabitethernet2

storm-control include-multicast

exit

interface gigabitethernet5

storm-control broadcast level 10

exit

interface gigabitethernet5

storm-control include-multicast

exit

interface range gi1-2,gi5

spanning-tree portfast

exit

interface  gi10

spanning-tree link-type point-to-point

exit

interface range gi1-2,gi5

port security mode max-addresses

exit

interface range gi1-2,gi5

port security max 10

exit

interface range gi1-2,gi5

port security discard trap 60

exit

vlan database

vlan 100

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

hostname switch0fdcfd

no passwords complexity enable

ip telnet server

interface gigabitethernet1

macro description ip_phone_desktop

exit

interface gigabitethernet2

macro description "ip_phone_desktop | no_ip_phone_desktop | ip_phone_desktop"

exit

interface gigabitethernet5

macro description ip_phone_desktop

exit

interface gigabitethernet10

macro description "switch | no_switch | switch"

exit

interface gigabitethernet1

!next command is internal.

macro auto smartport dynamic_type ip_phone_desktop

switchport trunk allowed vlan add 100

exit

interface gigabitethernet2

!next command is internal.

macro auto smartport dynamic_type ip_phone_desktop

switchport trunk allowed vlan add 100

exit

interface gigabitethernet5

!next command is internal.

macro auto smartport dynamic_type ip_phone_desktop

switchport trunk allowed vlan add 100

exit

interface gigabitethernet10

!next command is internal.

macro auto smartport dynamic_type switch

switchport trunk allowed vlan add 100

exit

switch0fdcfd#

  I had used CCA  to configure that option, you could probably use Cisco Configuration Professional (CCP) if you are not using a UC500  .

UC500 expansion port tio my switch


interface FastEthernet0/1/8 --- connected to SRW2008P-K9-NA (SG300-10P)

switchport mode trunk

switchport voice vlan 100

macro description cisco-switch

!

have fun

regards Dave