cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


3776
Views
0
Helpful
10
Replies
Michael Couture
Beginner

SF 300 Serires switch not participating in spanning tree?

I just purchased an SF300-24 managed switch and I am running it in layer3 mode. I am testing it out right now and have it connected to two 2950 switches. The SF300 is connected to each 2950 with a four port etherchannel running LACP. When looking at spanning tree all three switches are configured the same when it comes to hello, forward, max age and all three are in RSTP mode. I adjusted the priorities so that the SF300 would be the root but that is not happening.

I only have one VLAN as of right now set up and connectivity between the three switches is fine. The only problem seems to be that the two 2950 switches are the only two switches involved in the determination of the root bridge. Additionally it was the same way before I configured the etherchannel and had the switches connected over single trunk lines.

I would appreciate if someone can expain to me why this is?

Thanks in advance.

10 REPLIES 10
nimusell
Beginner

Hello Michael,

Thank you for using the Cisco Small Business Support Forum. My name is Nico Muselle from Cisco Sofia S-TAC.

Could you verify whether root guard is not enabled on the Catalyst Switches ? Even though you configured the SF300 switch so that it could be elected as root, this option on the Catalyst switches could prevent it from being elected.

You could also monitor STP traffic by doing packet capture of your etherchannel (or LAG on the SF switch). Best way to do this is using port mirroring and use Wireshark so you can analyze what STP packets are exchanged between the SF300 and the catalyst switches.

If you would need any help troubleshooting this issue, please do not hesitate to contact your local Small Business Support center :

https://supportforums.cisco.com/community/netpro/small-business/sbcountrysupport


Best regards,

Nico Muselle
Sr. Network Engineer - CCNA

badge number: C274698

I enabled port mirroring on one of the 2950 switches and on the SF300. When I am monitoring VLAN traffic on the SF300 switch I see no STP packets via wire shark. Even if I change the Priorities on the 2950's to generate traffic. If I monitor the interfaces and not the VLAN it is the same result. When I am monitoring the other end of the Ether-channel on the 2950 side I See the STP packets form the SF300, but never see any sent from the 2950, even when I change the priorities to generate traffic. When I change the Monitoring on the 2950 to monitor VlAN instead of the Ether-channel I see the STP traffic from the 2950 but now do not see any from the SF300. I assume there is a misconfiguration somewhere but I have hit a wall as where to look next.

SF300 Switch:

Spanning tree state: enabled, mode: RSTP, BPDU handling Flooding, Path cost: Long. Prority: 0, Hello Time: 2, Max Age:10, Forward Delay:8,

RSTP Interface Setting:

LAG Point-to-Point enabled, port role Designated, fastlink enabled, port status forwarding

Switch 2950 1

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 2-100 priority 4096

spanning-tree vlan 2-100 forward-time 8

spanning-tree vlan 2-100 max-age 10

interface Port-channel2

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

switchport nonegotiate

flowcontrol send off

spanning-tree bpdufilter disable

spanning-tree bpduguard disable

spanning-tree guard none

interface FastEthernet0/45

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

switchport nonegotiate

channel-group 2 mode passive

spanning-tree guard none

lacp port-priority 1

!

interface FastEthernet0/46

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

switchport nonegotiate

channel-group 2 mode passive

spanning-tree guard none

lacp port-priority 1

!

interface FastEthernet0/47

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

switchport nonegotiate

channel-group 2 mode passive

spanning-tree guard none

lacp port-priority 1

!

interface FastEthernet0/48

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

switchport nonegotiate

channel-group 2 mode passive

spanning-tree guard none

lacp port-priority 1

Switch 2950 2

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 2-100 priority 20480

spanning-tree vlan 100 forward-time 8

spanning-tree vlan 100 max-age 10

interface Port-channel1

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

flowcontrol send off

spanning-tree guard none

interface FastEthernet0/45

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

channel-group 1 mode passive

spanning-tree guard none

lacp port-priority 1

!

interface FastEthernet0/46

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

channel-group 1 mode passive

spanning-tree guard none

lacp port-priority 1

!

interface FastEthernet0/47

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

channel-group 1 mode passive

spanning-tree guard none

lacp port-priority 1

!

interface FastEthernet0/48

switchport trunk native vlan 100

switchport trunk allowed vlan 2-100

switchport mode trunk

channel-group 1 mode passive

spanning-tree guard none

lacp port-priority 1

Do you have the Trunking information for the SF 300 switch.

What is the Native VLAN?

Is everything else working?

Everything else is working, I can ping from one 2950 to the other one through the SF300 and can ping all Vlans. The two 2950’s are talking STP between the two of them through the SF 300 but the SF300 just appears to forward it and ignore it.

SF 300 LAG settings:

Type: eth100M, status: UP, Auto Negotiation: enabled, Speed: 100M, Flow control: off, Protection State: Unprotected

LAG Management

LACP: Enabled, Link State: Link UP, Active Member: e21,e22,e23,e24 , Standby Member: none

The other LAG is the same except, Active member:e1,e2,e3,e4

These Settings are the same on both LAGs.

The Native VLAN is 100

I think I might have figured out the problem, please correct me if I am wrong.

The default RSTP on the 2950 is per-VLAN RSTP but

it would appear that the SF300 does not support PER-VLAN RSTP

and I have to use MSTP. Does that sound correct?

Indeed, that was my next question. the Sx300 series switches does not support PVST, it only supports STP, RSTP and MSTP, so that is your issue here. The only way to work around and let the SG300 participate in the STP election is to reconfigure the Catalyst switches to use one of the 3 forms of STP that are supported by the SG300 switch.

Best regards,

Nico Muselle

Thanks for your help but know I still cannot get the three devices to talk MST either,it is getting frustrating. If i add a redundant link and directly connect the two 2950's they immediately talk and configure MST. But when I remove that link no info is passed and both 2950's think they are the root even though the SF 300 priority is 0 on all three MST instances. On the SF300 I have the following settings:

Spanning tree: enabled

STP Operation Mode: Multiple STP

BPDU Handling: Flooding

Path Cost: Long

Region name: test

Revision: 1

Max Hops: 20

Max-age: 20

Hello Time: 2

Forward Delay: 15

MST instance 1 Vlan 100

Bridge Priority 0

Designated Root Bridge: Self

Root port: 0

Root path cost: 0

MST instance 2 Vlan 2-5

Bridge Priority 0

Designated Root Bridge: Self

Root port: 0

Root path cost: 0

MST instance 0 all vlans not in instance 1 and 2

Bridge Priority 0

Designated Root Bridge: Self

Root port: 0

Root path cost: 0

For MST interface Settings (both LAGs/instances are thesame)

Int Priority: 128

Path Cost: 20000

Port State: Boundary

Mode: RSTP

Type: Boundary

Designated port ID: 128

Designated Cost: 0

Remain Hops: 20

Forward Transitions: 1

The 2950 switches: (The only difference on the other switch is that the priority is 8192, and the MACs of course)

MST00 is executing the mstp compatible Spanning Treeprotocol

  Bridge Identifierhas priority 4096, sysid 0, address 000b.460e.e040

  Configured hello time 2, max age 20, forward delay 15

  Current root haspriority 0, address 6c50.4dcb.334b

  Root port is 65 (Port-channel1), cost of root path is 50000

  Topology change flag not set, detected flag not set

  Number of topology changes 7 last change occurred 00:18:54 ago

          from Port-channel1

  Times:  hold 1, topology change 35, notification 2

          hello 2, max age 20, forward delay 15

  Timers: hello 0, topology change 0, notification 0

Port 65 (Port-channel1) of MST00 is root forwarding

   Port path cost 50000, Port priority 128, Port Identifier 128.65.

   Designated roothas priority 0, address 6c50.4dcb.334b

   Designatedbridge has priority 0, address 6c50.4dcb.334b

   Designated port id is 128.1000, designated path cost 0

   Timers: message age 4, forward delay 0, hold 0

   Number of transitions to forwarding state: 1

   Link type ispoint-to-point by default, Boundary RSTP

   BPDU: sent 571,received 568

MST01 is executingthe mstp compatible Spanning Tree protocol

  Bridge Identifierhas priority 4096, sysid 1, address 000b.460e.e040

  Configured hello time 2, max age 20, forward delay 15

  We are the root of the spanning tree

  Topology change flag not set, detected flag not set

  Number of topology changes 9 last change occurred 00:18:55 ago

          from Port-channel1

  Times:  hold 1, topology change 35, notification 2

          hello 2, max age 20, forward delay 15

  Timers: hello 0, topology change 0, notification 0

Port 65 (Port-channel1) of MST01 is boundary forwarding

   Port path cost 50000, Port priority 128, Port Identifier 128.65.

   Designated root has priority 4097, address 000b.460e.e040

   Designated bridge has priority 4097, address 000b.460e.e040

   Designated port id is 128.65, designated path cost 0

   Timers: message age 0, forward delay 0, hold 0

   Number of transitions to forwarding state: 1

   Link type ispoint-to-point by default, Boundary RSTP

   BPDU: sent 598,received 0

MST02 is executingthe mstp compatible Spanning Tree protocol

  Bridge Identifierhas priority 4096, sysid 2, address 000b.460e.e040

  Configured hello time 2, max age 20, forward delay 15

  We are the root of the spanning tree

  Topology change flag not set, detected flag not set

  Number of topology changes 9 last change occurred 00:19:50 ago

          from Port-channel1

  Times:  hold 1, topology change 35, notification 2

          hello 2, max age 20, forward delay 15

  Timers: hello 0, topology change 0, notification 0

Port 65 (Port-channel1) of MST02 is boundary forwarding

   Port path cost 50000, Port priority 128, Port Identifier 128.65.

   Designated root has priority 4098, address 000b.460e.e040

   Designated bridge has priority 4098, address 000b.460e.e040

   Designated port id is 128.65, designated path cost 0

   Timers: message age 0, forward delay 0, hold 0

   Number of transitions to forwarding state: 1

   Link type ispoint-to-point by default, Boundary RSTP

   BPDU: sent 611,received 0

I notice that on MST01 and 02 they are not receiving BPDU’s,but I am not sure why or if that is the problem. It appears that the SF 300 is not sending BPDU packets for MST01 and 02, but is sending them for MST00. I also attached a capture. I captured the VLAN info for VLAN 100 which is in MST1. on the SF300, it appears that the SF 300 is recieving STP traffic but not generating any.

Mr. Couture,


Can you try this.  Manually set the bridge priorities on the root switch or the switch you want root and lower the priority to 0 or 4096 and see if that fixes the issue.


This will eliminate the election process and the sf300 switches should submit to the main switch being the root.

Thanks for the input but I have already returned the switch. I was not not happy with the lack of a CLI on the Small Business switches and the limited functionality. Even though I generally prefer the CLI over a GUI, this GUI was just too limited for there not to be a CLI. I figured I would try to save a buck but it was not worth it. I ordered a new 3560, which is what I should have done in the first place.

Thanks again.

No problem.



Thanks for the update.