cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


8440
Views
5
Helpful
4
Replies
Enthusiast

SF/SG 300 DHCP server

Hi,

is it possible for SF/SG300 switches to be used as DHCP server for non-management VLAN-s.

The switch has VLAN1 as management VLAN - has IP address assigned.

The switch has additional VLAN - VLAN200 and I'd like SG300 to act as DHCP server for clients on this VLAN.

Is this possible at all?

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Re: SF/SG 300 DHCP server

Hi Jernej, the switch must operate in layer 3 mode. You can enable dhcp server per vlan.

To qualify to make a DHCP pool for a layer 3 vlan, none of the vlan interface can have an IP address issued via DHCP, so you vlan 1 and 200 must have a static ip address assigned.  The vlan 1 does not require dhcp server configured for vlan 200 to have one.

Here is a sample configuration

config t

vlan database

vlan 200

exit

interface vlan 1

ip address 192.168.100.137 255.255.255.0

no ip address dhcp

exit

interface vlan 200

ip address 192.168.99.1 255.255.255.0

exit

ip dhcp server

ip dhcp pool network test

address low 192.168.99.1 high 192.168.99.254 255.255.255.0

default-router 192.168.99.1

dns-server 8.8.8.8

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
4 REPLIES 4
Beginner

Re: SF/SG 300 DHCP server

Hello Jernej,

Yes. The SG300 has DHCP server capabilities. On the web configuration utility (GUI), go to IP Configuration > IPv4 Management and Interfaces > DHCP Server > Properties to enable it.

Go to Administration > Management Interface > IPv4 Interface to assign the IP address network to the respective VLAN.

Hope this helps,

Thanks,

Vijay

Please rate useful posts.

Sent from Cisco Technical Support iPad App

Enthusiast

Re: SF/SG 300 DHCP server

Hi Vijay,

thanks for suggestion, but I don't want to change management IP and vlan ID from 1 to vlan 200 (guest vlan).

Is there any other way to solve the problem?

Advocate

Re: SF/SG 300 DHCP server

Hi Jernej, the switch must operate in layer 3 mode. You can enable dhcp server per vlan.

To qualify to make a DHCP pool for a layer 3 vlan, none of the vlan interface can have an IP address issued via DHCP, so you vlan 1 and 200 must have a static ip address assigned.  The vlan 1 does not require dhcp server configured for vlan 200 to have one.

Here is a sample configuration

config t

vlan database

vlan 200

exit

interface vlan 1

ip address 192.168.100.137 255.255.255.0

no ip address dhcp

exit

interface vlan 200

ip address 192.168.99.1 255.255.255.0

exit

ip dhcp server

ip dhcp pool network test

address low 192.168.99.1 high 192.168.99.254 255.255.255.0

default-router 192.168.99.1

dns-server 8.8.8.8

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Enthusiast

Re: SF/SG 300 DHCP server

Tom, thank you very much for your help - enabling L3 mode solved the problem.