cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1213
Views
0
Helpful
5
Replies

SG 300-10P with 6911 phones

I want to connect a 6911 IP Phone to a SG 300 switch. This is my scenario:

vlan 3 data, vlan 9 voice, vlan 10 admin.

I have a trunk on port 10 of the SG 300 (vlan 1 untagged, vlan 3,9,10 tagged) and it is connected to a switch 3560, this switch has all the L3 configuration of the vlans and the SG 300 switch has an IP on the admin vlan (10).

On ports 1 to 8 i have this configuration:

trunk

vlan 3 untagged

Also i added the OUI of my IP phones an created an LLDP Policy. Right now I have a 7941 IP Phone working but 6911 is not working. Iam using the new version 1.1.0.73 that supports CDP.

Also I noticed that even when my PC and IP phone receive IP address they can not ping each other nor the SG 300. They only can ping the default gateway or IP addresses in diferent vlans but connected on 3560 switch.

I hope someone can help me.

Regards,

Daniel

5 REPLIES 5

nimusell
Beginner
Beginner

Hello Daniel,

Thank you for participating in the Small Business support community. My name is Nico Muselle from Cisco Sofia SBSC.

For the configuration of the switch ports, I suggest to disable the LLDP policy on the ports (you can even remove the LLDP policy completely, as both your phones and the switch support CDP with the 1.1.0.73 firmware)

Then set the smartport settings for the ports 1 through 8 to IP phone desktop. If you are not sure on how to do that, there's a pretty good description in the administration guide on pages 136 and following. Port 10 can be set to "Switch".

As far as the ping results are concerned. I'm supposing here that the default gateway for your vlans are not residing on the SG 300-10MP switch but are connected to the 3560, is that correct ?

If that is the case, and inter-vlan routing is not enabled on the default gateway, that explains why the PC cannot ping the phone or reach the switch. As the traffic is not intended for it's own subnet, it will be sent to the default gateway, the routing to the other VLAN is done there.

You would have other results if the switch was the default gateway for the different VLANs but I'm supposing this is not the case in your topology.

Hope this was helpful.

Best regards,

Nico Muselle

Sr. Network Engineer - CCNA

Hello Nimusell,

I deleted the LLDP policy and disabled from the ports. Also I configured the smartports as desktop + ip phone but the ip phone is taking the IP address of the vlan 3 (data), my voice vlan is 9. In the macro i can see that the configuration for the voice vlan is 1 and i can not change that to my vlan 9:

Even when I configured voice vlan 9:

Anyway I configured a DHCP pool on vlan 1 hoping to receive an IP address on my 6911 but is the same problem, the IP phone takes a data IP address. With a 7941 IP phone is diferent, i dont even receive an IP address in this case.

The IP phones are correctly identified on the CDP Neighbors table of the switch but something is wrong.

Any other idea?

Tkank you very much for your help,

Best Regards,

Daniel Villanueva

Daniel,

Do you have the voice vlan tagged on the phone?  It seems like the phone is overriding the auto voice vlan and assuming the untagged vlan.

The cdp is enabled on the phone right?

David,

the 6911 is an IP phone without screen also my customer that has this switch doesn't have experience in Networks, so I rather to try something automatic.

CDP is enabled, the switch perfectly identifies the ip phone