cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1360
Views
0
Helpful
3
Replies
Highlighted
Beginner

SG 300-28 Possible Disconnect Problem

My client purchased a SG 300-28 and  a SF 300-24P three months ago.  The SF 300-24P is awaiting IP phones and has only one computer connected.  The SG 300-28 is full.  No VLAN's are setup yet, but that will happen later when the phones are installed.  The configuration is basic/default.  The firmware is 1.0.0.27, but that will be upgraded to the latest firmware tonight. 

The primary application on the network is a telnet session to an older (over 5 years old) Dell server running the Solaris OS.  The Solaris server is running at 100 Mbps duplex.  All workstations (Windows XP Pro) are running 100 Mbps duplex.  Other traffic on the network is Exchange email, Quick Books, printer traffic, and file serving.

Here is the issue.  The Cisco switches replaced a 10 year old 3 Com unmanaged switch.  They never had a problem  with the switch and never got disconnected.  Today, several heavy users are getting disconnected once or twice per week.  The problem with that happening is the poorly written application that they use telnet to access will not recover.  The server must be restarted.  That means everyone in the office and three remote sites must all exit the application so the server can be restarted.

So, is there some issue with these switches of which I should be aware?  Anyone else have this problem?  Any insights into how this issue can be addressed?  The logs really don't show significant errors.  The server switch port shows 32 errors over ninety days and millions of packets sent.

Tony Lombardi

3 REPLIES 3
Rising star

Re: SG 300-28 Possible Disconnect Problem

Hi Tony,

Yep , I can understand and have seen why a sophisticated managed switches like the Catalyst range and Small Business switches can offer issues compared to a unmanaged switch especially with older NICs and networks.

But I have also seen with managed switches,  better opportunities to control the network and monitor the network. Hence I can understand your decision to move forward with a managed switch.  Thank you for your purchase.

First thing that hit my tiny brain was when you said all worked ok on the old 3com unmanaged switch.

I think of duplex mismatches and autonegotiation issues, pause frames when i think of older hardware. Standards were pretty loose in terms of interpretation by differing NIC and switch manufacturers and had heaps of issues with connectivity in the good olde days


You mentioned "Solaris server is running at 100 Mbps duplex.  All workstations (Windows XP Pro) are running 100 Mbps duplex"

I wonder what are the duplex settings,  half or full for the solaris and a couple of the problematic XP machines ? .

Maybe the following link may help as well for the solaris, but the switch Port management Tab  would  indiacte negotiated speed and duplex.;

http://www.brandonhutchinson.com/Solaris_NIC_speed_and_duplex_settings.html

Here is a screen capturing below showing where i can see port status.

Could you insert a image of the screen capture showing speed and duplexes.

2. There is a log within the Sg300-28 that does / may indicate some the issues you are experiencing.  It could be very useful to see screen capture of the log or access the log via a console session and then capture the log with the command "show log"

More will follow when you send back results,  But it may be quicker to just ring the SBSC and see if they can quickly identify the issue.

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

regards Dave

Beginner

Re: SG 300-28 Possible Disconnect Problem

Thank you for the response to my client's connection problem.  After writing the original post, I updated the firmware and ran diagnostics on a few ports.  The diagnostics found a short in a cable and a couple of open cables, which was really interesting.  The cables are old and who knows if the original installer knew what he was doing.  I am going to correct these issue to see if that fixes the problem.

The logs were clear of any indication of problems and the ports reported no errors on the status screen, which I thought was interesting in light of the fact that there is an obvious cable problem.

Thanks for your help.  I will be back if this doesn't correct the disconnect issues.

Tony Lombardi

Rising star

Re: SG 300-28 Possible Disconnect Problem

Hi Tony,

That's great, i should have thought of checking cabling plant especially in old cable plant running at GbE speeds, sorry.

I guess with management comes more advanced features.

Yep,  built in  time domain reflectometry diagnostics (cable check) can be handy for determining poor cable runs.

cool stuff.

regards Dave