cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


343
Views
5
Helpful
2
Replies
Highlighted
Beginner

SG 300-28 switch bricked?

Greetings,

I have a CISCO SG 300-28 switch, and I was upgrading it's quite old firmware today, first using older major versions of firmwares and boot images and then stpe-by-step using newer major versions.

When I've reached the latest firmware version (1.4.11.02) and had a successful reboot, I've initiated a reboot with restore factory defaults option via the web interface.

 

Now it seems switch is bricked, system led is blinking, and I can't access switch on it's old or default ip-address (192.168.1.254).

Any ideas how to start recovering from here? Should I get a 9-ping serial cable to access CLI?

Everyone's tags (3)
2 REPLIES 2
Highlighted
VIP Mentor

Re: SG 300-28 switch bricked?

Do the factory reset, connect the console and see what process going on or stuck anywhere ( post the booting logs to understand what is wrong here )

 

http://www.thetechfactors.com/reset-cisco-sg300-switch-factory-default/

https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/sf30x_sg30x/quick_start/78-19252-01.pdf

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: SG 300-28 switch bricked?

Thank you for your advice!

The hardest part was to find a proper serial (straightforward and not null-modem) cable, because this model has the older 9-pin serial port.

After successful serial connection I have not spent much time with diagnosing the issue, I just activated the previous boot image and rebooted the device. With the older image it started without issues.

Then I continued upgrading image files with smaller version steps and finally I could reach the latest version with this method.

Just for get the knowledge: how to see the booting logs via serial connection? When the device starts it sends only strange characters to serial console.