cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


466
Views
0
Helpful
3
Replies
Highlighted
Beginner

SG 300 - Can Resolve DNS but no internet from VLAN 110

Hello 

 

Looking for some help. VMs on vLAN 110 can resolve for example google.com but can't ping

Attached is a diagram of my home setup which i changed recently. 

 

For now i m using my home NETGEAR WIFI Router X6 R8000 that doesn't support vLANs until i get my new Cisco RV340 Router which supports VLANS

Machines connected on SG-200-08 on vLAN 1 can resolve and access the internet with no issues

Machine connected on SG-300-20 on vLAN 110 can resolve but can't access the intenet.

 

What am i missing ? is it a VLAN issue ?

 

Appreciate any help on this.

2018-11-27_14-51-27.png

 

 

2018-11-27_14-56-48.png

2018-11-27_15-00-21.png

2018-11-27_14-57-53.png

 

2018-11-27_14-58-37.png

 

Everyone's tags (3)
3 REPLIES 3
VIP Advisor

Re: SG 300 - Can Resolve DNS but no internet from VLAN 110

What does the NAT config on the WiFi router look like? Does it permit NAT for subnets other than 192.168.0.0/24 ?

 

The fact that internal DNS works for all subnet suggests that the routing table on the WiFi router is correctly setup.

 

Cheers,

Seb.

Beginner

Re: SG 300 - Can Resolve DNS but no internet from VLAN 110

Thank you Seb

 

There is no NAT config on the WIFI router to permit any other VLANs..
the current WIFI router is Netgrear X6 R8000 and i just found out that there is a VLAN/IPTV option that is currently disabled so i have not touched that option yet but it looks like i can create a vLAN rule for any VLAN on any of the LAN or WIFI ports BUT

if you look at the diagram, Currently the WIFI router is connected via port 1 to SG200 via port configured as Untagged default vLAN1 and the SG300 ( Where vLAN 110 is connected to ) is connected via GE19 to SG200 Port G5.

VIP Advisor

Re: SG 300 - Can Resolve DNS but no internet from VLAN 110

Hello again,

Sorry for the delay.

 

If you want to keep your existing topology, you need to complete two configuration items.

 

Since the SG-300 is providing the routing for VLANs 100,101 and 110 you need to configure the WiFi router routing table with entries to reach those subnets:

 

!
ip route 192.168.100.0 255.255.255.0 192.168.0.2
ip route 192.168.110.0 255.255.255.0 192.168.0.2
!

 

 

I have not included VLAN 101 as vMotion is always layer two, you won’t be routing those packets…unless they are being encapsulated; ie OTV, VxLAN.

 

 

Next as I previously mentioned is to ensure that VLANs 100 and 110 are permitted for NAT on the wifi router. My suspicion is that the only VLAN1 is allowed. Hopefully the wifi router will allow you to add additional subnets.

 

Make those changes and let us know the result.

 

Cheers,

Seb.