cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

SG-300 Odd Behavior on non-default VLAN

scott.pendleton
Beginner
Beginner

I have a SG-300 with version 1.4.2.4 and am experiencing an issue using VLANs. The switch is in layer-2 mode.  I have a FioS gateway router to which I want to put in VLAN 198 along with some other devices.  Whether I configure those ports as access, trunk, or general, The FiOS router won't give out DHCP addresses unless the PVID on the port is VLAN 1.  If workstation 1 and the FIOS router are on an access port in VLAN 1, everything works. If I configure those ports as trunks with native VLAN as 1, everything works. If I configure the native VLAN on those ports as 198, DHCP breaks.  If I configure them as access ports with Untagged VLAN as 198, DHCP breaks.  If I configure them as general ports with PVID as 198 (no filtering, admit all)  DHCP breaks.  This doens't make sense to me as if they are access ports the virtual connections are made on the backplane and the devices would be totally unaware they are on a VLAN. 

 

Update:  Upgraded to 1.4.10.6 and still have the same behavior

 

Update 2:  If I change the switch default VLAN to 198 via the default VLAN settings,  everything works when the ports are in access VLAN 198. I also verified via the FioS Router's log that the Router is not receiving DHCP requests when it is connected to a port who PVID is different than the switch default VLAN.  This is definitely a bug that the switch is doing something on the non-default VLANs that is breaking it.   I also tried setting a static IP when in the non-default VLAN and that does not work either.  However the issue is only with the FioS router.  Other Static IP'd devices can communicate. 

 

Now instead trying to punt and say this is a FioS Router issue, I argue it is not. Any device connected to an port in access mode should be completely unaware of anything on the switch as it should receive a standard IEEE non tagged frame. It should be no different from the devices perspective than if it were connected to an unmanaged switch

 

Update 3:   I configured another managed switch in the same manner with two access ports in VLAN 198 and it works flawlessly.  This issue is most definitely an issue with the SG300. 

 

Update 4: just for grins I connected the FioS router in VLAN 198 as an access port on the other managed switch and then trunked all VLAN over to the SG300.  I connected the workstation to an access port in 198 on the SG300.  This worked. However if I reverse it and plug the FioS router into the SG300 and the workstation on the other switch, its broken.  The only other thing I could do to troubleshoot is if I had and inline sniffer to capture an analyze the frames between the Router and SG300. A SPAN port I don't think would work since that's a copy and not the actual frame leaving the switch. That is only definitive proof that I provide that the SG300 is mangling something in the frame that the FioS router won't accept. However all other evidence points in that direction.

 

I'd leave them as VLAN 1 except I have an Access Point where the FioS network SSID is trunked as VLAN 198, so I have to have it working on somthing other than VLAN 1

**Mark all helpful posts and solutions**
15 REPLIES 15

thrtnastrx1
Beginner
Beginner

It sounds like you tested everything properly.  Why don't you try configuring the FIOS router VLAN198 as a tagged subinterface and configuring the SG port as trunk native VLAN1?

The FiOS router doesn't support tagging VLANs.
**Mark all helpful posts and solutions**

I use DHCP on a SG300-28 layer 3 switch.  It works great and supports tagged VLANs.

 

You could switch your switch to layer 3 and use DHCP on the switch.  Define all the VLANs on the switch.  Use the SG300 switch for all local routing.  Let the router handle just the internet traffic.  I have posted how to do this on other threads here about SG300 switches.

I'm not sure changing it to layer-3 would make a difference as my updates seem to indicate it goes beyond DHCP. Even if I static IP clients the FiOS router seems to drop frames unless it is in the Default VLAN defined on the SG300.  Unless you think that the frame exiting a non-tagged port would be different in layer-3 mode. It would still be layer 2 from the client to the router.

 

 

The next thing I am going to try is putting an unmanaged switch in between the router and the access mode port to see if it somehow 'corrects' the frame going to the FiOS router. 

**Mark all helpful posts and solutions**

You could use the default VLAN to route all the layer 3 switch networks to the FIOS router.  It probably would not be my choice, when I first setup my SG300 layer 3 switch I had it running that way.  Connect the FIOS router to an access port in the default VLAN.  Turn on layer 3 switching on the SG300 switch.  Setup DHCP on the SG300 layer 3 switch.

You need 2 more things to make this work.  You the default gateway for the layer 3 switch to point to the FIOS router and you need the static maps on the FIOS router pointing to the layer 3 switch IP access port.