Showing results for 
Search instead for 
Did you mean: 


Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.

Frequent Contributor

SG 300 with Cisco 2901 router


I have a weird problem with a Cisco 2901 connected toi a SG300-28 switch.

Every 24 hours the router loses connection with the switch, meaning you can not ping the router anymore.

You can ping any other device in the network (PC's, servers, other cisco routers)            .

The weird thing is that on the switch I can see the router (CDP neighbors) and the timer is refreshed.

The other weird thing is that when I try to ping the 2901 router an arp entry is created on the PC's or server.

So also ARP resolution works, but not IP.

I have changed the cable, tried 3 ports on the SG300 switch and changed the port on the 2901 (was gig0/0 now gig0/1)

But the problem stays the same.

I am not that familiar with the SG300 switch (more familiar with the IOS switches) but all the ports are in default configuration.

I also tried to change the default port settings (lower speed, different template) nothing works.

Has anyone seen this problem with SG300 switches and Cisco routers?




Hello Mr. huizinga,

Thank you for your question.

However, the Small Business Support Community is limited to Cisco Small Business Products and the 2911 router is an Enterprise level product.

You might consider to ask this question at Enterprise forum to get a better response.

Best regards,

Diego Rodriguez

Cisco Small Business Community Engineer

Frequent Contributor

Well , apparently there are more devices that have this problem.

We saw now that PC's and servers that have randomly no access anymore, and only a reboot of the switch solves the problem.

Seems to me that the switch is not good.

I have upgraded to the latest firmware, but problem remains.

Maybe we have to send the switch back


Hi Jan,

The switch should not have any interop issues with the 2901. Can you provide some LAN details?

  • Is your network flat? Or, if the segment the switch is connecting to does not involve any vlans or dot1q interfaces?
  • Is this issue exactly every 24 hours or varied, such as sometimes 4 hours, sometimes 10 hours, sometimes 48 hours, etc?
  • When the connectivity on the router goes down, are you able to have a computer communicate to another computer on the same vlan connected to the switch (your original post mentions you can)?
  • Do you lose all communications in every aspect (aside from your layer 2 mentions)?
  • Is the switch running in layer 3 or layer 2 mode (by default it is layer 2)?

Could you also provide some general details about the switch communication with the router and connected devices?

  • Is the router running rapid spanning tree?
  • Does the 2901 or switch have any log entries, such as port security violation, bpdu received or any fatal error warnings?
  • Since you see CDP advertisements, can you verify the smart port macro for the uplink has negotiatied "router"?
  • When the communication to the router goes down, do you have any access to the switch via console or GUI?
  • You have noted computers and servers randomly lose access, does this mean zero connectivity (dhcp, etc)?
  • Does the connectivity resolve on its own at any point?
  • Are you using any kind of expansion modules on the 2901 for the connection to the switch?

Please rate helpful posts

-Tom Please mark answered for helpful posts
Frequent Contributor

Hello Tom,

About your questions:

  • Flat network
  • Around 24 hours, sometimes  little earlier sometime a little later. Seems to be happening when there is not much traffic in the network
  • Yes, but I am not sure because I am testing the 2901 router (voice router) and I do a reload before the people are in the office
  • The router can not be pinged, but on the switch I can see cdp neighbor activity (timer refresh) and also ARP requests are working, just not IP
  • Default layer 2
  • It runs in default, so I assume like IOS switches that spanning tree is working
  • This drives me crazy, I check the log files from the 2901 and the SG300, and I see nothing, just nothing, just the messages after a reboot of the switch.
  • The smartport type is "Default" and the smartport application method is "Auto Smartport"
  • I am remotely (early morning) I am not in the customers office. But after a reload of the switch I have access to the 2901 and I can see from the uptime that nothing happened (crash or reboot)
  • No IP connectivity, from a router that I have access to (ADSL) I can see CDP neighbors (switch) , but I can't ping the rest of the network, including the IP from the SG300. The last time, customer told me that some PC's had Internet access, others not. After reboot switch all is OK again
  • No, reboot required
  • No, strait cable.

Most of the problem is related to the connectivity with the 2901, but sometimes also PC's, or servers or out Cisco routers. And one time I had seen that I don't have access to the IP of the switch itself, so no reboot. Customer did a power off / power on

Since this is a big problem now, we are going to replace the switch on Monday with a catalyst 3560 switch (temporary) to see if soemthing changes. I am sure problem will be solved, because the 3560 switch is for sure 100% OK

Thanks you very much for your help,


Frequent Contributor


How can I open an RMA for this switch?

I want to replace it.

After we power cycle the switch it works for 1 or 2 days (longer then a simple reboot)

This morning I lost again 2 routers, could not ping, but saw them with cdp neighbors.

After reload of switch the routers were accesible again.

The RMA procedure is the same as for IOS switches?



Frequent Contributor


The problem was that the internal CUE module from the 2901 had the same address with a wirless (non-cisco) access router.

Only when we replaced the SG-300 with a 3560 switch did we see the syslog messages (%SW_MATM-4-MACFLAP_NOTIF) that pointed us to this problem.

On the SG-300 we didn't see any indication about this problem.

Anyway, solved,