cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3557
Views
10
Helpful
4
Replies

SG-350 Voice and Data Vlan Setup questions

WaddyAUS
Beginner
Beginner

Hello,

I am hoping someone can help point me in the right direction here, I am looking for quite a basic setup. We have just purchased 6 x SG-350 and I am having trouble working out if my config is right.

 

I am used to Catalyst IOS and these switches have all this auto configuration/macros and do not support the IOS commands which I am familiar with. 

 

I am seeing two different Configs: GUI vs SSH which concerns me. Port Vlan Membership in GUI shows me 200 untagged?

 

I have yealink IP phones with a switch port so the PC and Phone Share same cable. 

 

End result I am trying to achieve.

Vlan 1 - Data - Untagged

Vlan 200 - Voice - Tagged

Gig 1 - Trunk Port connected to Cisco Router - allowing Vlan 1 and 200 access.

All other Switch Ports ports allow Vlan 1 &  Vlan 200.

QOS/Cos to prioritize Voice.

 

Current Config:

vlan database
vlan 200
exit
voice vlan id 200

voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________

bonjour interface range vlan 1

!
interface vlan 1
ip address 192.168.1.250 255.255.255.0
no ip address dhcp
!
interface vlan 200
name Voice
ip address 192.168.201.250 255.255.255.0
!
interface GigabitEthernet3
spanning-tree link-type point-to-point
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet4
switchport general allowed vlan add 200 tagged
switchport general allowed vlan add 1 untagged
switchport access vlan 200
!

Questions:

1. Does my config look ok?

2. Do I use enable Auto Voice Vlan if I don't have any supported phones?

3. Can I remove all these voice vlan oui-table add lines ?

 

GUI Screesnhots:

 

1.PNG2.PNG3.PNG4.PNG5.PNG6.PNG

 

4 REPLIES 4

mlail04
Beginner
Beginner

I was able to achieve this by using the switchport mode "general" commands.

 

Voice vlan ID 200

voice vlan state auto-enabled

 

Interface GigabitEthernet1

switchport mode general
switchport general allowed vlan add 200 tagged
switchport general allowed vlan add 1 untagged
switchport general pvid 1

I setup 19 Polycom IP phones on a Cisco SG500X-25 switch.  I used the GUI marco but I had to add another oui for the Polycom IP phones I was using.  The one in the switch did not match. Plus I used CDP and turned it on in the Polycom IP phones.

Hi Lee

I am trying to setup the ports on SG350-10P and SG350-28P the same way described above to have the phone and desktop connected to the same port. 

 

My vlans are 100 - Data and 150 - Voice

 

Configuration below:

vlan database
vlan 100,150
exit
voice vlan id 150
voice vlan state auto-enabled
voice vlan oui-table add 0001e3 Siemens_AG_phone       
voice vlan oui-table add 00036b Cisco_phone            
voice vlan oui-table add 00096e Avaya
voice vlan oui-table add 000fe2 H3C_Aolynk
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone
voice vlan oui-table add 00e075 Polycom/Veritel_phone
voice vlan oui-table add 00e0bb 3Com_phone
bonjour interface range vlan 1
hostname switche290ae
username admin password encrypted a1345dba3231cf4c1adc795ffea106768e99590e privilege 15
!
interface vlan 100
name Data
ip address 10.1.100.15 255.255.254.0
!
interface vlan 150
name Voice
!
interface GigabitEthernet1
switchport mode general
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100                           
!
interface GigabitEthernet2
switchport mode general
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
!

interface GigabitEthernet3
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport mode trunk
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
switchport trunk allowed vlan 1,150
macro description ip_phone_desktop
!next command is internal.                            
macro auto smartport dynamic_type ip_phone_desktop
!
interface GigabitEthernet4
switchport mode general
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
!
interface GigabitEthernet5
switchport mode general
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
!
interface GigabitEthernet6
switchport mode general
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
!

interface GigabitEthernet7
switchport mode general                               
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
!
interface GigabitEthernet8
switchport mode general
switchport general allowed vlan add 150 tagged
switchport general allowed vlan add 100 untagged
switchport general pvid 100
!
interface GigabitEthernet10
spanning-tree link-type point-to-point
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
exit

 

As you can see, on the third port, the configuration has changed. This happened after I connect the phone (Yealink IP Phone) to that port. All ports except the trunk ports are setup as 100P,100U,150T (Administrative VLANs)

 

Issues are:

1. The port changes to 1U,150T (Administrative VLANs) once a phone is connected to that port. Result, the desktop cannot be connected to that port any more.

2. The desktop not receiving any IP when connected to the port back of the phone.

Is there any solution to this situation? Is this kind of bug in the OS or am I missing something?

KR, FKM

 

disable the macros on the port by issuing the command "no macro auto smartport". This will prevent automatic configuration when a switchport detects an ip phone was plugged in. do not disable this feature on the global configuration during production. it will bring down your entire network.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: