cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


874
Views
0
Helpful
11
Replies
Highlighted
Beginner

SG-500x-24 Switch Problems

I am trying to setup a layer 3 switch at my daughter's real estate business.  I cannot seem to setup a static route on my SG500X-24 switch.  I am getting an error message "Only a directly connected router can be defined as the gateway"  which is what I am trying to do.  I have created a 1 port VLAN with a 30 bit mask.  I have included my settings.  I am trying to add a Cisco RV320 router with a 30 bit mask.  The port for the router is an access port physically port number 2 as denoted in the capture below.   This works on my SG300-28 switch.  The L3 mode seems to be set automatically now with the latest firmware.  I am using firmware 14106 with a factory reset.

 

What am I missing?  Is this a software bug?

11 REPLIES 11
Highlighted
Beginner

I realized I should have added the default route for the router VLAN.  My problem now seems that the IP section will not work any more.  If I try to assign a IP address to a VLAN now the browser comes back with the switch IP not responding.  The same thing now happens if I try to add a DHCP scope to VLAN1.  So I am thinking the IP part of this switch now does not work any more.  I have tried falling back to 2 older firmware's and the same thing happens.   A factory reset allows me to access the switch but as soon as I try assign anything in the IP section the switch breaks.

 

How do I fix my switch?

Highlighted

Here are the web site commands issued when trying to add an IP address to a VLAN. I am trying to add 192.168.2.254/255.255.255.0 to vlan2.

 

http://192.168.1.254/cs596ob264/ipaddr/system_ipconfig_ipInterface_a.htm

 

http://192.168.1.254/cs596ob264/kubrick/closeDialog.html

 

Does this help?

 

Highlighted

Links you have posted are only available from your internal network.

Do you have an ssh/telnet connection to the switch? Or serial console cable?

 

Highlighted

Hi,

Is it normal that on your Capture 3, destination network and gateway are in the same subnet?

Highlighted

That is my error.  I should have entered the default route   0.0.0.0 0.0.0.0 with the next hop 192.168.10.1 which is the RV320 router IP

 

But now I can't enter anything under IP config.  My switch seems broken now.

Highlighted

Reset...

Highlighted

Reset does not fix the IP stuff.  It is still broken after the reset.  I can change firmware and IP still does not work.  Is there something greater than reset?

Highlighted

I made a little progress.  I plugged the SG500x-24 switch into my SG300-28 layer 3 switch and let it DHCP an IP address.  The SG500x switch setup default routing to my layer 3 switch as denoted in the captions below.  What I want to do now is change the SG500x switch to match my SG300 layer 3 switch by using 192.168.0.254 instead of 192.168.0.92 which was set by DHCP. The SG500x switch is going to my daughter's work so it will not be in the same location as my SG300-28 switch but I would like them setup the same way.  I have the option to change the IP from DHCP to static which I hope I can assign the new IP 192.168.0.254.  The possible issue is I already use that IP on my SG300-28 layer 3 switch.  The other thing I need to do is delete the default route and plug in 0.0.0.0 0.0.0.0 forward to 192.168.10.1/30 which is my router.  Do you think this will work?  Or am I going to need to telnet to fix this.  The good, using DHCP made the IP section start working again.

 

What I don't know is using 192.168.0.0 network instead of 192.168.1.0 is helping.  It could just be using DHCP.

Highlighted

OK, here is the telnet version of my config.  I was thinking I could modify it using telnet.  I don't see the route statements.  This is the same config as shown above in the screen captures.  Can I add route statements?

 

switchd254bb# show run
config-file-header
switchd254bb
v1.4.10.6 / R800_NIK_1_4_214_020
CLI v1.0
set system queues-mode 4

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 2,10
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname switchd254bb
username user password password
ip telnet server
!
interface vlan 1
no snmp trap link-status
!
interface vlan 2
name "vlan2"
ip address 192.168.2.254 255.255.255.0
no snmp trap link-status
!
interface vlan 10
name "vlan10"
ip address 192.168.10.2 255.255.255.252
no snmp trap link-status
!
interface gigabitethernet1/1
switchport mode access
!
interface gigabitethernet1/2
switchport mode access
switchport access vlan 10
!
interface gigabitethernet1/3
switchport mode access
switchport access vlan 2
!
exit

Highlighted

Something like this? 1.2.3.4 is the gateway for the default route...

 

cisco(config)#ip route 0.0.0.0 0.0.0.0 1.2.3.4

Highlighted

Can you apply "show ip route" at the cli ?