cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


19968
Views
100
Helpful
106
Replies
Beginner

SG200-08 firmware issue

Hi,

I have upgraded my SG200-08 switches from firmware version 1.0.5.1 to version 1.0.6.2. Since that new firmware is active, the network-printing from my Macbooks and iMacs is not working anymore. They all have TCP/IP connected network printers (not based on Bonjour connections) and they cannot print anymore; timeout communicating to printer. Windows workstations on the same network are still able to print to the network printers, only the Mac's do have this problem.

I am still able to view printer-information via the Mac's, so communicating is still possible. Also surfing to the admin-page of these printers is still working, only sending the actual print-job is failing.

I have reset the SG200-08 switches to factory defaults, but still no printing.

Finallly I did a downgrade, back to firmware version 1.0.5.1 and now printing from the Mac's is working again.

Any ideas, perhaps a firmware bug?

I have seen the new firmware version 1.2.9.44, but there are only language files available for the SG200-08, no firmware file...

So I don't know if this new version perhaps solves this problem.

Kind regards,

Rene.

106 REPLIES 106
Beginner

SG200-08 firmware issue

Is There Any Answers On Firmware 1.2.9.44

Beginner

SG200-08 firmware issue

I did not get any response so far...

Beginner

Re: SG200-08 firmware issue

I noticed the same printing problem with 1.0.6.2 on my Mac network & also found that reverting to 1.0.5.1 cured the problem.

I wouldn't be surprised if the language files for firmware 1.2.9.44 have appeared by mistake on the SG200-08 download section!

Sent from Cisco Technical Support iPhone App

Beginner

Re: SG200-08 firmware issue

You are quite right, only the language files seem to be listed on the SG200-08 version which is surely an oversight. This Switch is the odd one out together with the SG200E of the rest of the 200/300 and 500 series.

As to the problems with printing there could possibly be an issue if it is found to be working with previous firmware versions. Was this also working with the previous versions

It may be helpful to use wireshark to capture the traffic and see if that helps us further to investigate the issue. If you require help in setting up port mirroring to do so please call in to open a support ticket.

Kindest regards

Highlighted
Beginner

Re: SG200-08 firmware issue

Are you sure about that?

The 8-port switches appear to have their own specific firmware, e.g. SG200-08x_FW_1.0.6.2.stk,

as opposed to sx200_fw-12944.ros for the larger switches.

Beginner

Re: SG200-08 firmware issue

Hi Gunter,

With the previuos firmware versions the printing is working fine as I mentioned in my initial post.

After upgrading to 1.0.6.2 the printing did not work anymore for the Mac's, the Windows machine were still able to print.

I did a downgrade to 1.0.5.1 to get the printing for the Mac's working again.

Kind regards,

Rene.

Beginner

Re: SG200-08 firmware issue

Yes, there are 2 odd members in this group that are different from the entire series and I have corrected my reply to reflect this.

Beginner

Re: SG200-08 firmware issue

Hi!

When I upgraded to firmware 1.0.6.2, my mediaplayer Dune BD Prime 3.0 isn't able to access my Qnap TS-639 NAS with NFS through TCP. Both attached to SG200-08. NFS through UDP works, but is very slow. After a downgrade to version 1.0.5.1, it's back to normal. Faster access NFS-TCP than NFS-UDP.

Seems to me like a problem with the firmware.

Thanks Ingar

Beginner

Re: SG200-08 firmware issue

For both issues we really need to do an in depth analysis of the traffic and as I suggested above a wireshark trace would be a minimum requirement to get us started. I really can not speculate if the firmware is at fault or not nor would this be very appropriate at this stage. Please call in to open a support ticket providing you are entitlet to support as part of your warranty or contract entitlement.

Thank you

Beginner

SG200-08 firmware issue

Hello Cisco,

I can confirm that I have the exact same issue. Have a Esxi Server connecting to Qnap TS 809 pro for NFS shares.

Took me about 8 hours!!! to discover that the Switch is causing the troubles!!! IT's not the first thing to think that a switch could be causing such troubles!

After creating to Ubuntu virtual machines on our Esxi server and the could connect to each other using NFS but not connect to my Qnap (using the switch...) I got a suspicion that the Switch was causing the troubles!!!

going to downgrade the switch and hope it will be fixed!!!

Beginner

SG200-08 firmware issue

It would be nice if someone from Cisco could fix this problem.

Several people have now confirmed this firmware issue.

Cisco Employee

SG200-08 firmware issue

Hello Rene,

Can you try hard setting the MTU on the servers to 1492 and see if that helps?

Thanks,

Nagaraja

Beginner

SG200-08 firmware issue

Hi Nagaraja,

I have replaced my SG200-08 switches for SG300-10 switches, so I cannot test this anymore.

Kind regards,

Rene.

Beginner

Re: SG200-08 firmware issue

Confirmed with an SG 200-08

3 proxmox (linux kvm) heads with a Qnap TS-412 as nas for the disks by nfs went down after the upgrade to 1.0.6.2

The nas is pingable but no NFS connection can be made.

Since I didn't suspect the cisco at first I tested, reconfigured and rebooted all devices. Eventually replacing the SG 200-08 with an unmanaged SG 100D-08 did the trick.

The only firmware for download is the new "broken" 1.0.6.2.

Since I bought the switches today I didn't think it useful to back up the original firmware of the switch.

Where can I find the previous firmware to switch back the switches to their intended places?

Regards,

Christiaan