cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


939
Views
0
Helpful
2
Replies
Highlighted
Beginner
Beginner

SG220-26 switch intermittently drops LACP groups

Hi - was wondering if anyone else has seen this problem - recently installed two SG220-26 switches; 4 separate LACP port channel groups were configured - 

#1 - 2 port LACP port channel group to a second SG220-26

#2 - 4 port LACP port channel group to a Windows 2012 R2 Hyper-V Server virtual switch

#3 - 2 port LACP port channel group to a Windows 2008 R2 server (backup server)

#4 - 2 port LACP port channel group to a Windows 2008 file server

The switch firmware is up to date (1.0.0.19), as are all of the NIC firmware and drivers.


Periodically, all of the Port-Channel groups go down and I see the following logged -

Notice  Port-Channel1 link down

Notice  Port-Channel1 STP port state is set to Disabled

This is repeated for the other three Port channel groups.  Around 20 minutes later, they all come up again -

Notice - Port-Channel1 link up

Notice - Port-Channel1 STP port state is set to Blocking

Notice - Port-Channel1 STP port state is set to Learning

Notice - Port-Channel1 STP port state is set to Forwarding

Again, this is repeated for the other three Port channel groups.  

This happened last night 4/21 at around 10:30 PM, and before that, on 4/17 at 10:10 AM for about 20 minutes

All of the other ports on the switch appear to be okay and working fine when this happens, it's just the port channel groups that are exhibiting this behavior.  There are no other errors in the logs indicating what's going on.  We've been fortunate so far in that this is happening off hours or on weekends, but it's very annoying because these 2 SG220-26 switches were replacements for a single SG220-50 purchased in December 2015 that was very unstable and Cisco was never able to figure out what was going on.  I also checked to see if this was a possible load issue (e.g. backups running) but that hasn't been the case - this has happened during times of minimal network activity.

Any thoughts?

2 REPLIES 2
Highlighted
Participant

Same problem for me. It doesn

Same problem for me. It doesn't matter what is connected, I have 4 LAGs, 1 for switch to switch and the other 3 to 3 different servers. All 4 go down at the same time.

5 Mar 13 2017 13:55:26 info Port-Channel1 STP port state is set to Forwarding
6 Mar 13 2017 13:55:11 info Port-Channel1 STP port state is set to Learning
7 Mar 13 2017 13:55:00 info Port-Channel4 STP port state is set to Forwarding
8 Mar 13 2017 13:55:00 info Port-Channel2 STP port state is set to Forwarding
9 Mar 13 2017 13:54:59 info Port-Channel3 STP port state is set to Forwarding
10 Mar 13 2017 13:54:58 info Port-Channel4 STP port state is set to Learning
11 Mar 13 2017 13:54:58 info Port-Channel2 STP port state is set to Learning
12 Mar 13 2017 13:54:57 info Port-Channel3 STP port state is set to Learning
13 Mar 13 2017 13:54:56 info Port-Channel1 STP port state is set to Blocking
14 Mar 13 2017 13:54:39 info Port-Channel1 STP port state is set to Forwarding
15 Mar 13 2017 13:54:39 info Port-Channel4 STP port state is set to Blocking
16 Mar 13 2017 13:54:39 info Port-Channel2 STP port state is set to Blocking
17 Mar 13 2017 13:54:39 info Port-Channel1 STP port state is set to Blocking
18 Mar 13 2017 13:54:39 notice Port-Channel1 link up
19 Mar 13 2017 13:54:39 notice Port-Channel4 link up
20 Mar 13 2017 13:54:39 notice Port-Channel2 link up
21 Mar 13 2017 13:54:37 info Port-Channel3 STP port state is set to Blocking
22 Mar 13 2017 13:54:37 notice Port-Channel3 link up
23 Mar 13 2017 13:34:19 info Port-Channel3 STP port state is set to Disabled
24 Mar 13 2017 13:34:18 info Port-Channel2 STP port state is set to Disabled
25 Mar 13 2017 13:34:18 info Port-Channel1 STP port state is set to Disabled
26 Mar 13 2017 13:34:18 notice Port-Channel1 link down
27 Mar 13 2017 13:34:18 notice Port-Channel3 link down
28 Mar 13 2017 13:34:18 notice Port-Channel2 link down
29 Mar 13 2017 13:34:17 info Port-Channel4 STP port state is set to Disabled
30 Mar 13 2017 13:34:17 notice Port-Channel4 link down
Highlighted
Participant

Re: Same problem for me. It doesn

The fix is to update the firmware. The firmware update fixed this issue even though not specifically listed as a fix in the release notes.