cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


319
Views
25
Helpful
6
Replies
gioscud
Beginner

SG250X secure web interface not reachable

Hello,

I have a couple of SG250X -24 port wit firmware 2.5.7.85, after a while the web interface is not more reachable through https protocol, I need to enable the http server via cli.

I upgraded the firmware from 2.4.0.94 version to try to resolve this problem, did any else resolve the same problem?

Thank you

BR

Giovanni

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

If you configure through cli then make sure you enable the secure web server by issuing ip http secure-server. When this command is used you must generate certificate using crypto certificate generate, otherwise this command has no effect. See “Web Server Commands”, chapter 57 of the CLI guide: https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/250_/2_4_5/cli_guide/cli_sx250_2_4_5.pdf

And don’t forget to save the config.

Thanks

View solution in original post

6 REPLIES 6
balaji.bandi
VIP Master

Looks like another bug,

 

when you issue https://deviceip/  ( Press F12 see what wrong ?)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

A lot of "Failed to load resource: net::ERR_EMPTY_REPONSE" and "Uncaught TypeError: Cannot read properties of undefined (reading 'setTokenWithError')" ... nice

 

BR

Giovanni

Can you post screenshot to look, also  I would suggest to open a SMB tac case to investigate for you.

 

If you still looking to resolve by your own.

 

take the config backup from the device.

reset the device to factory

upgrade to latest firmware (in case required, )

restore the config and testit.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hi,

If you configure through cli then make sure you enable the secure web server by issuing ip http secure-server. When this command is used you must generate certificate using crypto certificate generate, otherwise this command has no effect. See “Web Server Commands”, chapter 57 of the CLI guide: https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/250_/2_4_5/cli_guide/cli_sx250_2_4_5.pdf

And don’t forget to save the config.

Thanks

View solution in original post

Hello,

thank you Martin, it's necessary to enable the secure web server from CLI and not from web interface, followed your suggestion the problem was resolved. 

Thank you

BR

Giovanni

I am glad you make it!