cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


2990
Views
0
Helpful
3
Replies
insaf
Beginner

SG300-10 Ethernet connected, but no IP-connectivity

Hello,

I have a strange problem with a SG300-10 (our first SG300) working as a desktop switch.

When a PC that is connected to the switch is powered off and is later (a few minutes or next day) switched on, the PC has a ethernet-connection to the switch, but no IP-connectivity.

The PC-statistics shows that ethernet is connected and it sends packets, but the PC does not receive any packets.

At the same time the SG300 statistics for the port says, that the ethernet is connected (same paramaters as the PC) an that the switch is sending IP-packets (broadcast and unicast) to the port, but does not receive any packets. The switch shows follwing entries in the ram log for the port:

09:11:35Warning    %STP-W-PORTSTATUS: gi3: STP status Forwarding, aggregated (1)       
09:11:31Informational    %LINK-I-Up:  gi3, aggregated (1)       
09:11:28Warning    %LINK-W-Down:  gi3       
09:11:24Warning    %STP-W-PORTSTATUS: gi3: STP status Forwarding       
09:11:19       Informational    %LINK-I-Up:  gi3   

With the older firmware 1.2.9.44 the IP-connectivity worked after waiting 5-10 minutes.

With the new firmware 1.3.0.59 I can wait even 15 minutes, there is no change and nothing happens.

But when I change some "unimportant" parameters of the port (i.e. change port speed from autonegation to fixed 1000M, or vice versa) and then save the running configuration to the startup-config, around 5-10 Seconds after the configuration is saved, the port gets full IP connectivity and after that works fine (until the PC is switched OFF and ON the next time).

This is a very strange behaviour. As "PC" I have tested this with HP-workstations, Lenovo Thinkpad and a MAC Mini. The switch "reacts" to all the same.

Following I have attached the config of the switch.

It would be very appreciated if someone could give me some hints on how to solve or debug this issue further.

Thanks very much

Andreas

--------------------------------------------------------------------------------------------------------

config-file-header

sw3

v1.3.0.59 / R750_NIK_1_3_647_260

CLI v1.0

set system mode switch

file SSD indicator plaintext

@

no cdp log mismatch native

no cdp log mismatch voip

no cdp appliance-tlv enable

port jumbo-frame

vlan database

vlan 2,4-5,10

exit

voice vlan state disabled

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

green-ethernet short-reach

no bonjour enable

hostname sw3

line console

no autobaud

exit

line console

speed 19200

exit

logging buffered debugging

no passwords complexity enable

username cisco password encrypted xxxxxxxxxxxx 7 privilege 15

ip ssh server

snmp-server server

clock timezone " " 1

clock summer-time web recurring eu

clock source sntp

sntp unicast client enable

sntp unicast client poll

sntp server 192.168.112.7

ip domain name abc.de

ip name-server  192.168.112.7

!

interface vlan 1

no ip address dhcp

!

interface vlan 2

name 2

!

interface vlan 4

name 4

!

interface vlan 5

name 5

ip address 192.168.112.15 255.255.255.0

ipv6 address 2001:abc:100b:25::15/64

!

interface vlan 10

name 10

!

interface gigabitethernet1

switchport mode access

switchport access vlan 5

!

interface gigabitethernet2

switchport mode access

switchport access vlan 5

!

interface gigabitethernet3

switchport mode access

switchport access vlan 5

!

interface gigabitethernet4

switchport mode access

switchport access vlan 5

!

interface gigabitethernet5

switchport mode access

switchport access vlan 5

!

interface gigabitethernet6

switchport mode access

switchport access vlan 5

!

interface gigabitethernet7

no eee enable

negotiation 1000f

switchport mode access

switchport access vlan 5

no eee lldp enable

no green-ethernet energy-detect

!

interface gigabitethernet8

no mdix

switchport mode access

switchport access vlan 5

!

interface gigabitethernet9

no eee enable

negotiation 100h 100f 1000f

switchport mode access

switchport access vlan 5

no eee lldp enable

no green-ethernet energy-detect

!

interface gigabitethernet10

no eee enable

no mdix

switchport mode general

switchport general allowed vlan add 2,4-5,10 tagged

switchport general ingress-filtering disable

switchport general pvid 5

no eee lldp enable

no green-ethernet energy-detect

switchport default-vlan tagged

!

exit

macro auto disabled

ip route 0.0.0.0 /0 192.168.112.1 metric 1

1 ACCEPTED SOLUTION

Accepted Solutions
Tom Watts
Advocate

Hi Andreas, this is not usual. I would assume if you factory reset the switch it will work just fine.

I have 4 of these running right now on my desktop and none them behave like this.

It should take 2-5 minutes for fully connectivity after a boot up. And not more than 52 seconds (depending on spanning tree) for new connection without boot up.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

View solution in original post

3 REPLIES 3
Tom Watts
Advocate

Hi Andreas, this is not usual. I would assume if you factory reset the switch it will work just fine.

I have 4 of these running right now on my desktop and none them behave like this.

It should take 2-5 minutes for fully connectivity after a boot up. And not more than 52 seconds (depending on spanning tree) for new connection without boot up.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

View solution in original post

Hi Tom,

thanks for your reply,

it took me some time, but after a factory reset and a complete new configuration, which looks exactly like the old config in the text-editor, the switch now works without this problem.

So, could this problem happen again, if we upgrade to a newer firmware in the future?

In a production environment, we can not "reset to factory default" after we do a firmware upgrade, just "to make sure" nothing strange happens after the upgrade.

Thanks

Andreas

Hi Andreas, in a product environment you do not generally upgrade firmwares. If something works there is "no need to fix it" kind of mentality.

I work for a large ISP and more often than not a lot of our software images may be considered ancient even, for the simple fact there is no need to upgrade software. But at the same time we have a very comprehensive "approved software list" as well.

The one thing I've learned working for one of the top 10 largest ISP in the US is that every vendor with any software has potentially adverse affects simply because old coding does not support new features and the such. And sadly, when we transition from lets say an old ATM code to a new ETHERNET code, more often than not, we usually have to rebuild a lot of configurations from scratch. It seems to be just a fact of life.

The only problem I know for sure is that... the small business team doesn't like people using old software and generally you won't get support until you're on the most recent releases, but it is also with good reason as those newer releases usually fix a lot of old bugs - but - the downfall is the fact that it may have adverse impacts on configuration items.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/