cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
42417
Views
14
Helpful
90
Replies

SG300-28P - POE not correctly supported on all ports - possible firmware or hardware issue

Cinemaffect
Beginner
Beginner

So, I spent some time this weekend troubleshooting the issues I've had  with the new SG300-28P switch and POE to many of my devices in the  office.  As a recap, I cannot utilize all of the 24 POE ports on the switch  for POE purposes.  Really only every other port [with a few odd  combinations thrown in between]. In addition, the SG300-28P switch, on occasion, is sending POE to non-POE devices [e.g. my Ruckus Zone Director 1106].

Here are my POE devices [all 802.3 af-compliant]:

  • 3 Ruckus 7982 access points
  • 1 Pakedge access point
  • 2 home-automation controllers
  • 2 Polycom voip phones

I called Cisco support several times in regards to this problem, and they figured it was a hardware issue - a faulty switch.  So, Cisco sent me a replacement SG300-28P, which I  hooked up today.  The exact problem still occurs.  Default configuration  [fresh out of the box].  No way I can land, for example, the 3 Ruckus  7982 AP's on ports 1, 2, and 3 [or ports 1,13, and 2].  I have to put  them on ports 1, 3, and 5 in order for them to power up.  In addition, I  can't plug any other POE devices on the ports either between or below  them.   I had to skip another port bay.  This is very odd behavior!!   Two Cisco SG300-28P's in a row with the same problem.

However, I also had one of the new Cisco SG300-10P switches in my  possession for a recent project of ours.  I decided to hook up the same  POE devices to this switch.  ALL POE devices were recognized and  worked!  No need to skip a port.  And it didn't matter what device was  plugged in first or not.  I am now convinced that it is either a  hardware issue [bad power supply/transformer?] inside all of the  SG300-28P switches, or a firmware issue. 

Both of the SG300-28P switches were running firmware 1.1.2 [the  latest on Cisco's website].  So, I decided to install an older firmware  version on the SG300-28P switch that I'm returning [installed 1.1.1.8].   Here's what I found out.  I could then plug 2 POE devices [e.g. two  Ruckus AP's] in adjacent horizontal ports, but not three in a row.  In  addition, not all adjacent ports.  It's funky. For example, I could plug  an access point in ports 20 and 21, but not in 21 and 22.  No rhyme or  reason in how it worked.  And I still couldn't plug an access point in  adjacent vertical ports [e.g. ports 1 and 13].  BUT...

It's interesting that the same exact switch that would not initially  allow 2 horizontally-adjacent POE ports to be utilized WOULD allow 2  horizontally-adjacent POE ports to be utilized when running a different  firmware version.   It's also interesting to note that when plugged into  a "non-working" POE  port, the SG300-28P would actually make a small whining noise.  Very  subtle noise; I could hear it when approx. 1ft away from the switch.   The noise was not noticeable when ports were skipped [and POE actually  worked].  Therefore, I believe that Cisco has some SG300-28P firmware  bugs [at least in the last two versions of firmware] that is not truly  allowing all 24 ports to utilize POE correctly.  This problem does not  exist with the SG300-10P switch.

I'm really interested to hear what Cisco's reply and findings on this  matter would be.  And would welcome a reply from one of their senior  support team members/managers who could actually experiment with this,  too.   In addition, I'd like to know when they think a solution could be  created if it's firmware-related.  If hardware-related, I don't think  I'll be recommending any 28P switches in our projects.  Perhaps just the  regular SG300-28 with a separate SG300-10P.  It's a shame because the  SG300-28P is more of a bargain when compared to the two separate  components.

90 Replies 90

Maybe not.  I can confirm that it works with Ruckus Zoneflex 7982's, Ruckus Zoneflex 7372's and Ruckus Zoneflex 7782's.  We do this every day.  That's good enough for me.  Just trying to help.  Have a good evening.

It's been a while for me to post in this thread.  However, I just wanted to say that similar to lokibjensen, I have continued to use the SG300 switches with various Ruckus AP's.  Just be aware of some of the limitations and work-arounds with the non-MP versions [excluding the sg300-10P].  The pricepoint of the SG300 line is just so appealing.

If you have the budget in a project, then go MP and give yourself a little extra piece of mind.  Otherwise, keep in mind the power layout of the 28/52 port standard-power switches when using the bigger Ruckus AP's.  I use them successfully all the time.

My suggestion is play with a few of the switches in-house for a bit when dealing with the 7982's.  You'll know what works and what doesn't.  I dont find issues with the 7363 and 7372's.

Also wanted to add that I do primarily resi install of Cisco/Ruckus, so most of my AP head-counts are under 6 in order to cover the home.  Most of the time, I try to dedicate a small MP switch for the wireless stuff, if possible.  The 7363/72 APs, however, make up the majority of our Ruckus AP installs for homes.  For jobs where I forsee the use of 7982's, I try to spec in MP models across the board, or at least a small one dedicated for AP use, if everything's centrally wired.

Sure, there are some work-arounds with the SG300 line and Ruckus (which I hope one day will get resolved by one or both manufacturers), but it's tough to beat the price of the SG300's for a decent managed switch.

fturner124
Beginner
Beginner

This is a Ruckus AP issue.  Below is the response I received from Ruckus Support.

"...I just want to update you that hardware rework has gone into the 7982/7372/7352 platforms to eliminate the earlier PoE issues we'd encountered, and all product should be compatible/immune at this time. If you do still have any APs that appear to reboot frequently, Not powering up, we will do RMAs on those few individual units."

From what I have been told it is NOT a Ruckus AP issue but rather an 802.3at compatibility issue with the Cisco switches as ANY 802.3at compatible device has issues with these switches, not just Ruckus.  Ruckus was going out of their way to make changes to their own devices so that they would work with these Cisco switches because they were getting too many support calls about it.  It was only the 300 series and 500 series switches that had this issue and all other Cisco switches did not.