cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


4941
Views
10
Helpful
11
Replies
asolochek
Beginner

SG300 getting duplicate IP address errors

I have an SG300-10P that is connected to a 3560G switch via port 10. The log from SG300 is full of these duplicate IP messages:

Nov  4 11:05:03: 10.1.1.49 NOTICE    %IPADTBL-N-IPDUPLICATE: Duplicate IP address 10.1.1.49 from MAC c8:f9:f9:da:e2:81 was detected on VLAN 1, port gi10, aggregated (6) 

Nov  4 11:05:59: 10.1.1.49 NOTICE    %IPADTBL-N-IPDUPLICATE: Duplicate IP address 10.1.1.49 from MAC c8:f9:f9:da:e2:81 was detected on VLAN 1, port gi10 

Nov  4 11:10:59: 10.1.1.49 NOTICE    %IPADTBL-N-IPDUPLICATE: Duplicate IP address 10.1.1.49 from MAC c8:f9:f9:da:e2:81 was detected on VLAN 1, port gi10, aggregated (6) 

Nov  4 11:11:22: 10.1.1.49 NOTICE    %IPADTBL-N-IPDUPLICATE: Duplicate IP address 10.1.1.49 from MAC c8:f9:f9:da:e2:81 was detected on VLAN 1, port gi10 

The SG300 has the IP 10.1.1.49. I have tried changing that IP, but this error follows.

I cannot see that MAC in the dynamic address table on the 3560, or anywhere else on the network, so it seems like something internal to the SG300. What could be causing this error? Is it just a bug in the firmware?

Thank you.

11 REPLIES 11
Brandon Svec
Rising star

Hi Aaron, The MAC is a Cisco MAC so probably one associated to your SG300.  Try show system to see main MAC of your switch.

Are you just assigning the admin IP with switch in L2 mode or do you have switch in L3 mode? show system mode

What version firmware is the switch running?  show ver

Would you like to share your config and output of show mac address-table ?


-- please remember to rate helpful posts --

-- please remember to rate and mark answered helpful posts --

#show system mode

Feature                 State

-------------------     ---------

Mode:                   Switch

#show ver

SW version    1.3.0.62 ( date  02-May-2013 time  14:55:01 )

Boot version    1.0.0.4 ( date  08-Apr-2010 time  16:37:57 )

HW version    V01

#show mac address-table

Aging time is 300 sec

  Vlan        Mac Address         Port       Type   

-------- --------------------- ---------- ----------

   1       00:04:20:06:a0:82      gi4      dynamic  

   1       00:04:f2:ef:69:f3      gi10     dynamic  

   1       00:0c:29:98:3d:22      gi10     dynamic  

   1       00:0c:29:9e:0d:0d      gi10     dynamic  

   1       00:0c:29:c6:5f:13      gi10     dynamic  

   1       00:0d:a2:01:0c:72      gi10     dynamic  

   1       00:18:0a:11:86:f8      gi10     dynamic  

   1       00:18:ba:d5:d7:16      gi10     dynamic  

   1       00:18:ba:d5:d7:40      gi10     dynamic  

   1       00:1b:d3:90:33:27      gi10     dynamic  

   1       00:1f:33:ea:fa:51      gi10     dynamic  

   1       00:a0:de:90:70:88      gi10     dynamic  

   1       00:c0:b7:97:61:92      gi5      dynamic  

   1       00:c0:b7:98:c1:f8      gi10     dynamic  

   1       00:c6:10:12:18:3e      gi10     dynamic  

   1       08:00:37:ba:ba:88      gi10     dynamic  

   1       0c:30:21:0f:41:35      gi10     dynamic  

   1       10:1c:0c:b6:c4:f3      gi10     dynamic  

   1       10:dd:b1:a4:8c:28      gi10     dynamic  

   1       10:dd:b1:ab:8e:26      gi8      dynamic  

   1       10:dd:b1:d2:2c:9e      gi10     dynamic  

   1       14:10:9f:d2:64:89      gi10     dynamic  

   1       14:99:e2:c0:95:fe      gi10     dynamic   

   1       18:20:32:d3:a8:5a      gi10     dynamic  

   1       28:cf:e9:17:f2:89      gi10     dynamic  

   1       28:cf:e9:4b:bc:1d      gi10     dynamic  

   1       30:f7:0d:8c:e8:84      gi10     dynamic  

   1       30:f7:0d:92:5c:a7      gi10     dynamic  

   1       30:f7:0d:e6:43:b2      gi10     dynamic  

   1       40:6c:8f:23:c6:da      gi10     dynamic  

   1       44:e4:d9:cd:ac:62       0         self   

   1       4c:8d:79:17:b7:19      gi10     dynamic  

   1       50:57:a8:4e:6f:ca      gi10     dynamic  

   1       5c:26:0a:75:cc:33      gi7      dynamic  

   1       60:fa:cd:a4:72:56      gi10     dynamic  

   1       68:5b:35:92:70:b5      gi10     dynamic  

   1       68:a8:6d:cc:87:a9      gi10     dynamic  

   1       6c:20:56:b8:da:e0      gi10     dynamic  

   1       6c:20:56:b8:da:e4      gi10     dynamic  

   1       70:73:cb:ac:c5:b4      gi10     dynamic  

   1       78:a3:e4:0d:7d:dc      gi10     dynamic  

   1       7c:d1:c3:03:3e:3a      gi10     dynamic  

   1       84:38:35:44:01:26      gi10     dynamic  

   1       88:1f:a1:d6:31:36      gi10     dynamic  

   1       88:1f:a1:d7:0f:d3      gi10     dynamic   

   1       8c:2d:aa:31:f7:0f      gi10     dynamic  

   1       8c:2d:aa:6c:1a:ef      gi10     dynamic  

   1       8c:2d:aa:82:a1:9b      gi10     dynamic  

   1       8c:2d:aa:a4:0b:d5      gi10     dynamic  

   1       98:fe:94:20:1a:c9      gi10     dynamic  

   1       a4:67:06:67:68:08      gi10     dynamic  

   1       a4:93:4c:fe:4e:a6      gi10     dynamic  

   1       a4:93:4c:fe:4e:ec      gi10     dynamic  

   1       a4:93:4c:fe:4e:f3      gi10     dynamic  

   1       a8:20:66:34:eb:be      gi10     dynamic  

   1       ac:3c:0b:1d:0a:f6      gi10     dynamic  

   1       ac:3c:0b:b8:76:33      gi10     dynamic  

   1       b0:9f:ba:1a:ef:70      gi10     dynamic  

   1       b0:fa:eb:30:19:44      gi3      dynamic  

   1       b0:fa:eb:30:19:4a      gi10     dynamic  

   1       b8:78:2e:90:b6:56      gi10     dynamic  

   1       b8:ca:3a:a2:be:27      gi6      dynamic  

   1       b8:e8:56:18:66:6e      gi10     dynamic  

   1       b8:e8:56:1a:cd:d6      gi10     dynamic  

   1       b8:e8:56:30:d7:7a      gi10     dynamic  

   1       b8:e8:56:3a:17:5e      gi10     dynamic  

   1       bc:3b:af:1f:54:f6      gi10     dynamic   

   1       bc:3b:af:3d:19:98      gi10     dynamic  

   1       bc:67:78:3b:b0:a1      gi10     dynamic  

   1       c0:63:94:31:76:f0      gi10     dynamic  

   1       c0:63:94:90:e4:bf      gi10     dynamic  

   1       c8:b5:b7:67:e5:34      gi10     dynamic  

   1       c8:b5:b7:69:bb:b6      gi10     dynamic  

   1       c8:e0:eb:41:af:d3      gi10     dynamic  

   1       c8:f9:f9:da:e2:81      gi10     dynamic  

   1       c8:f9:f9:da:e2:c0      gi10     dynamic  

   1       e0:db:55:02:75:b4      gi10     dynamic  

   1       e4:25:e7:b3:fe:69      gi10     dynamic  

   1       e4:98:d6:0d:65:e0      gi10     dynamic  

   1       e4:98:d6:14:eb:4a      gi10     dynamic  

   1       e8:8d:28:0f:3b:fb      gi10     dynamic  

   1       ec:35:86:4f:e4:36      gi10     dynamic  

   1       f0:f7:55:75:e5:1a      gi10     dynamic  

   1       f0:f7:55:79:4e:c1      gi10     dynamic  

   1       f4:f9:51:c6:68:34      gi10     dynamic  

   1       f4:f9:51:cc:ac:de      gi10     dynamic  

   2       00:18:ba:d5:d7:16      gi10     dynamic  

   10      00:0c:29:c6:5f:1d      gi10     dynamic  

   10      00:18:0a:11:86:f9      gi10     dynamic   

   10      00:18:0a:11:86:fa      gi10     dynamic  

   10      00:18:ba:d5:d7:16      gi10     dynamic  

   10      02:6e:81:55:e5:00      gi10     dynamic  

   10      40:6c:8f:55:9f:95      gi10     dynamic  

   10      64:00:f1:84:18:d4      gi10     dynamic  

  250      00:18:ba:d5:d7:16      gi10     dynamic  

#show running-config

config-file-header

aarons-switch

v1.3.0.62 / R750_NIK_1_3_647_260

CLI v1.0

set system mode switch

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0

!

cdp source-interface gigabitethernet10

cdp mandatory-tlvs validation

port jumbo-frame

vlan database

vlan 2,10,250

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

gvrp enable

ip dhcp relay address 10.1.1.2

ip dhcp relay address 10.1.1.3

ip dhcp relay address 10.1.1.4

ip dhcp relay enable

ip dhcp information option

ip dhcp tftp-server file ogden-switch2.config

boot host auto-config tftp

ip dhcp tftp-server ip address 10.1.1.3

rate-limit 2 1000 30000

hostname aarons-switch

line console

exec-timeout 30

exit

line ssh

exec-timeout 30

exit

line console                                         

speed 9600

exit

logging host 10.1.1.3 facility local1 severity notifications

logging buffered warnings

logging file informational

no passwords complexity enable

username cisco password encrypted XXX privilege 15

ip ssh server

ip ssh pubkey-auth

crypto key pubkey-chain ssh

exit

exit

snmp-server server

snmp-server engineID local 800000090344e4d9cdac62    

snmp-server location "aarons office"

snmp-server contact aarons@romotive.com

snmp-server community public ro view Default

snmp-server host 10.1.1.3 version 3 priv admin

snmp-server host 10.1.1.3 traps version 2c public

snmp-server group admin v3 auth read DefaultSuper write DefaultSuper

snmp-server group admin v3 priv read DefaultSuper write DefaultSuper

snmp-server group monitor v2 read DefaultSuper

snmp-server group monitor3 v3 auth read DefaultSuper

snmp-server group monitor3 v3 priv read DefaultSuper

ip http timeout-policy 0

clock timezone " " -8

clock summer-time web recurring usa

clock source sntp

sntp unicast client enable

sntp unicast client poll

sntp server 10.1.1.2 poll

sntp server 10.1.1.3 poll

sntp server 10.1.1.4 poll

clock dhcp timezone

ip domain name XXX   

ip name-server  10.1.1.3 10.1.1.2 8.8.8.8

ip domain polling-interval 18

ip telnet server

!

interface vlan 1

ip address 10.1.1.49 255.255.0.0

no ip address dhcp

ip dhcp relay enable

!

interface vlan 2

name guest

!

interface vlan 10

name external

!                                                    

interface vlan 250

name voip

!

interface gigabitethernet1

gvrp enable

switchport trunk allowed vlan add 2,250

switchport trunk native vlan 10

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet2

description scope

gvrp enable

switchport trunk allowed vlan add 2,250

switchport trunk native vlan 10

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet3

description speck

gvrp enable

storm-control broadcast enable

storm-control broadcast level 10

storm-control include-multicast

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

macro description ip_phone_desktop

!next command is internal.

macro auto smartport dynamic_type ip_phone_desktop

!

interface gigabitethernet4                           

description squeezebox

gvrp enable

switchport trunk allowed vlan add 2,250

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet5

description aarons-ups

gvrp enable

switchport trunk allowed vlan add 2,250

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet6

description winbot

gvrp enable                                         

switchport trunk allowed vlan add 2,250

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet7

description pork

gvrp enable

switchport trunk allowed vlan add 2,250

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet8

description rio

gvrp enable

switchport trunk allowed vlan add 2,250

lldp notifications enable                           

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet9

gvrp enable

switchport trunk allowed vlan add 2,250

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

!

interface gigabitethernet10

description switch-0

gvrp enable

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 2,10,250

lldp notifications enable

lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size

lldp med notifications topology-change enable       

lldp med enable network-policy location poe-pse inventory

lldp management-address automatic

macro description switch

!next command is internal.

macro auto smartport dynamic_type switch

!

exit

macro auto enabled

macro auto processing type host enabled

macro auto processing type router enabled

ip default-gateway 10.1.1.1

Well, the MAC address does show up as connected to port 10:

   1       c8:f9:f9:da:e2:81      gi10     dynamic 

and your SG300 MAC is

   1       44:e4:d9:cd:ac:62       0         self  

It is a Cisco MAC address so that should be a clue. 

http://www.coffer.com/mac_find/?string=c8%3Af9%3Af9%3Ada%3Ae2%3A81

Are you in a position to disconnect the switch for 15 minutes to see if the error repeats?

From the config I see you made VLAN 10 native for many ports but you do know that native VLAN for port 10 is VLAN 1 since it is default, right? 

-- please remember to rate helpful posts --

-- please remember to rate and mark answered helpful posts --

Yeah, I can disconnect the switch for a bit to see what happens.

Also thanks for pointing out the vlan config -- that is actually leftover config from when the switch was serving a different purpose. I'll fix that, although I'd be surprised if that is related to the problem.

Ok, well the error does go away when port 10 is disconnected. So I guess something is misconfigured on the switch on the other end...

This is the config for that switch, which I know isn't a small business product, but maybe someone will spot something so I won't have to open a ticket with cisco support.  The SG300 is on port 22 of the 3560.

!

! Last configuration change at 14:33:56 UTC Fri Nov 1 2013

! NVRAM config last updated at 14:58:01 UTC Fri Nov 1 2013

!

version 15.0

no service pad

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

service sequence-numbers

!

hostname switch-0

!

boot-start-marker

boot-end-marker

!

enable secret XXX

enable password XXX

!

username aarons privilege 15 secret XXX

username admin privilege 15 secret XXX

no aaa new-model

clock timezone UTC -8 0

clock summer-time UTC recurring

system mtu routing 1500

vtp mode transparent

ip domain-name XXX

ip name-server 10.1.1.2

ip name-server 10.1.1.4

ip name-server 10.1.1.3

!

!

no ip igmp snooping

!

mls qos map policed-dscp  24 26 46 to 0

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2 1

mls qos srr-queue input cos-map queue 1 threshold 3 0

mls qos srr-queue input cos-map queue 2 threshold 1 2

mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3 3 5

mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3 32

mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

!

crypto pki trustpoint TP-self-signed-3134576384

...

!

!

crypto pki certificate chain

...

      quit

!

!

!

!

!

errdisable recovery cause udld

errdisable recovery cause bpduguard

errdisable recovery cause security-violation

errdisable recovery cause channel-misconfig (STP)

errdisable recovery cause pagp-flap

errdisable recovery cause dtp-flap

errdisable recovery cause link-flap

errdisable recovery cause sfp-config-mismatch

errdisable recovery cause gbic-invalid

errdisable recovery cause l2ptguard

errdisable recovery cause psecure-violation

errdisable recovery cause port-mode-failure

errdisable recovery cause dhcp-rate-limit

errdisable recovery cause pppoe-ia-rate-limit

errdisable recovery cause mac-limit

errdisable recovery cause vmps

errdisable recovery cause storm-control

errdisable recovery cause inline-power

errdisable recovery cause arp-inspection

errdisable recovery cause loopback

errdisable recovery cause small-frame

errdisable recovery cause psp

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 2

name guest

!

vlan 10

name external

!

vlan 200

name tenant

!

vlan 250

name voip

!

!

class-map match-all AutoQoS-VoIP-RTP-Trust

  match ip dscp ef

class-map match-all AutoQoS-VoIP-Control-Trust

  match ip dscp cs3  af31

!

policy-map AutoQoS-Police-CiscoPhone

class AutoQoS-VoIP-RTP-Trust

   set dscp ef

  police 320000 8000 exceed-action policed-dscp-transmit

class AutoQoS-VoIP-Control-Trust

   set dscp cs3

  police 32000 8000 exceed-action policed-dscp-transmit

!

!

!

!

interface GigabitEthernet0/1

description switch-1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/2

description comcast

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/3

description ap-controller

switchport trunk encapsulation dot1q

switchport mode trunk

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/4

description monkeybrains

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/5

description macau internal

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

switchport voice vlan 1

switchport port-security maximum 6144

switchport port-security violation restrict

switchport port-security aging type inactivity

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/6

description router external 1

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/7

description vegas

switchport trunk encapsulation dot1q

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/8

description router external 2

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/9

description atlantic-city int

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

switchport port-security aging type inactivity

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/10

description macau external

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/11

description router internal

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

switchport voice vlan 1

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/12

description atlantic-city ext

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface GigabitEthernet0/13

description reno

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/14

description macau-mgmt

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/15

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/16

description water cooler

switchport trunk encapsulation dot1q

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/17

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/18

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/19

description reception desk

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/20

description HR Desk

switchport trunk encapsulation dot1q

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/21

description W conf

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,250

switchport mode access

switchport voice vlan 1

switchport port-security maximum 6144

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust dscp

auto qos voip cisco-phone

macro description cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

service-policy input AutoQoS-Police-CiscoPhone

!

interface GigabitEthernet0/22

description aarons office 1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 1

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust dscp

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/23

description ME desk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,250

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/24

description rack-ups

switchport mode access

switchport port-security maximum 6144

switchport port-security violation restrict

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

ip address 10.1.1.250 255.255.0.0

!

ip default-gateway 10.1.1.1

ip http server

ip http secure-server

!

!

snmp-server group admin v3 auth write v1default

snmp-server group monitor v3 noauth

snmp-server community public RO

snmp-server community private RW

snmp-server location server rack

snmp-server contact aarons@XXX

!

!

line con 0

line vty 0 4

no login

length 0

line vty 5 15

no login

!

ntp server 10.1.1.2 prefer

end

I do wonder about this:

interface GigabitEthernet0/22

description aarons office 1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 1

When you have switches disconnected can you ping 10.1.1.49 on the 3560?  Since it is a Cisco MAC it seems like it could be a Cisco Phone..


-- please remember to rate helpful posts --

-- please remember to rate and mark answered helpful posts --

Dear Brandon ,

                           I'm Facing the same problem and made my Management Vlan as native vlan on trunks but still im receiving the logs of Duplicate IP on my management vlan . I would appreciate any kinda help.

 

Note : Same was tested on SG-300 placed at end of my network

show mac address-table

it should help as you will find what port the duplicate IP is connected to.

-- please remember to rate and mark answered helpful posts --

Its showing on trunk port , the strange behavior is that im seeing this Message only on Small business switch , even if it has uplink from a catalyst 2960X which is further provided uplink from cisco 3850 L3 whose mac is showing in the log

 "Duplicate IP address 172.21.24.143 from MAC c4:14:3c:53:5b:8e was detected on VLAN 130, port gi1, aggregated (1) "

where c4:14:3c:53:5b:8e is MAC of cisco L3  and gi 1 is trunk port uplink source and vlan130 is management VLAN and . A image has been attached for the clarity .

Note : I tried Loopguard as well on Cisco 2960X

 

please respond brandon . i'll appreciate any help

mt1576980
Beginner

Hi, i dont know if you have already solved your problem, but today i was looking for an answer for this issue, i have been having this issue for about a year and for others reasons i left it, now when im having problems with a fiber, i'm seeing the error again in the logging of the sw and i decided to resolve it once for all. My problem was solved by upgrading the firmware, i was running the 1.3.5.06 and now im running the 1.4.5.05 and it's working. I hope to help somebody with this post. best regards!