cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


120
Views
0
Helpful
1
Replies
Highlighted
Beginner

SG300 Windows DHCP Server and VLANS

 

I have the following 

Asus RTN16 Router ( WIth Tomato Shibby Firmware) 

  TWO VLANS  (Plus Default )deployed on router  , #3. #4 

  TWO  Gateway Interfaces for each VLAN  ( 10.10.3.1 & 10.10.4.1) 

 

SG300 Smart Switch ( In Layer 3 Mode ) 

VLAN Trunk tagged  Default , VLAN #3, VLAN #4 

Access Ports  for VLAN #3 and VLAN #4 , some default 

VLAN config is shown : 

 

vlan members.PNG

 

 

Diagram is below 

network 1.6i.PNG

 

I can get full network access from the server logged in locally ( internet access and can ping the different VLAN gateways ) 

 

However  the Client PCS on the access ports VID3 and VID4 are not getting any IP address from the server .  

 

 

I have enabled DHCP relay , and added the DHCP server address to the switch , as shown below 

dhcp relay config1.PNGdhcp relay 2.PNG

 

IS there something I am missing here? 

1 REPLY 1
Beginner

Re: SG300 Windows DHCP Server and VLANS

 

 I have had more challenges since doing this : 


The DHCP servers both stopped working on the server and from the router 

 

I tried plugging the server and a client  into a dumb ethernet switch and it does not give any IP address 

 

The router stopped giving IP addresses for the workgroup ( 10.10.0.X/25)  on VLAN 1 

 

I have since deleted all additional VLANS and gone back to a workgroup . I really cant understand what I am doing wrong here . Any help appreciated