cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1190
Views
0
Helpful
2
Replies
Highlighted
Beginner

SG300G-28P Auto Voice Vlan configuration

Quick overview of my setup:

4 Buildings all interconnected by Fiber in 1 LAN.  4 Vlans - Data (Default Vlan), Voice 1, Voice 2, and Guest.  The vendor doing phones reccomended 2 Voice Gateways for their installation thus requiring 2 seperate Voice Vlans.

Building A and B are on Voice 1

Building C and D are on Voice 2

Building A has Gateway 1 which runs on Voice 1 (Vlan 52)

Building C has Gateway 2 which runs on Voice 2 (Vlan 53)

Building A/B/C are all working great.  The switches in Building D for some reason keep wanting to use Vlan 52 (Voice for Building A/B) in it's configuration even though I set the Voice Vlan to 53.  So If I disabled the Auto Voice Vlan the phones get no LLDP settings and do not work at all.

Is anyway I can configure the switch to use Vlan 53 as the primary voice vlan?  My other option is to configure my DHCP with all the options but since its working on 5 out of 7 switches I'd like to get these other 2 switches working also.

Or is there a way I can disable it but keep LLDP so I do not have to configure the DHCP settings?  If not I will just disable.

2 REPLIES 2
Advocate

Hi Gregory, it is possible

Hi Gregory, it is possible the uplink port at building D is receiving an advertisement to configure the voice VLAN as VLAN 52 either via CDP or LDP.

Try to disable the autosmart port macro for the uplink port and CDP/LDP for that particular link and see if it helps that situation.

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Beginner

Hi Gregory, As I can

Hi Gregory,

 

As I can understand you have 4 switches

switch A for 1st switch,  switch B for 2nd switch, switch C for 3rd switch, switch D for 4th switch.

first you need to loging to switch A  and do this following

config t

Switch A# config t

Switch A<config>

Switch A<config># spanning-tree priority 0

end

config t

Switch B# config t

Switch B<config>

Switch B<config># spanning-tree priority 4096

end

config t

Switch C# config t

Switch C<config>

Switch C<config># spanning-tree priority 8192

end

config t

Switch D# config t

Switch D<config>

Switch D<config># spanning-tree priority 12288

end

now we need to fix vlan issue

I will give you example and you need to try it in your switch

this switch support only 1 voice vlan work with smartport  so if you want config two voice vlans you need to use other vlan as this following

config t

Switch A# config t

Switch A<config>

Switch A<config># int range gi1-3

Switch A<config-if-range># switchport mode trunk

Switch A<config-if-range># switchport trunk allow vlan add 52

Switch A<config-if-range>#switchport trunk native vlan 1

Switch A<config># int range gi4-6

Switch A<config-if-range># switchport mode trunk

Switch A<config-if-range># switchport trunk allow vlan add 53

Switch A<config-if-range>#switchport trunk native vlan 1

end

wish my issue will help

 

Thanks,

Moh