cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1309
Views
0
Helpful
2
Replies
Highlighted
Beginner

SG350XG shuts down OOB interface

Hi,

 

I have recently got two SG350XG-2F10's which I set up as a vertical stack (A).

They are going to replace two Netgear switches which are also set up as vertical stack (B)

 

While I am migrating settings I wanted to connect the SG350's with the NG's to do a per change verification.

For that I have connected one of the Cisco ports to a port on the NG stack.

 

Now if I also connect one of the OOB ports of my Stack A to a regular switch port of the NG Stack B then the OOB port gets shut down by STP (Edit: or something else).

That would be perfectly fine behavior if that was a regular switch port, but I don't understand why the same would happen on the OOB port - that should be outside the regular switch plane of Stack A and as such not connected to the NG Stack.

 

I'd simply go ahead and deactivate STP on that particular port but its not listed on STP Interface settings.

 

Sorry if this is a stupid question but I am fairly new to Cisco switches.

The stack is on the lastest firmware as of yesterday  (2.3.5.639)

 

Thanks for looking,

regards

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Alright, it indeed was the Master selection process that prioritized the remote switch as master whenever connected stacking.

With no OOB connected there I didn't have access so it looked like the OOB was shut down.

 

After rebooting the remote switch to prioritize the local switch everything is working fine.

Now to find out how to 'force' the master with this series.

 

 

Edit: Setting the other switch to Node 3 sets it to slave mode and as such it does not participate in the master selection process.

View solution in original post

2 REPLIES 2
Highlighted
Beginner

Ok, 

found two other potential causes (besides STP):

 

-Stack Support

The OOB port name is always mapped to the physical OOB port of master unit. The physical OOB ports of slaves are not functional and will not establish a link when connected to a neighbor device or PC

 

Need to verify my master unit is indeed the one I want to use - I assume it should be the switch with ID 1  but need to doublecheck

 

Edit: Ok, I found the Master selection process :

The master unit is selected from the master-enabled units (1 or 2). The factors in selecting the
master unit are taken into account in the following priority:
1 System Up Time
2 Unit ID
3 MAC Address

 

Question - how can I force a specific switch to always be Master?

Can i simply assign the slave-to-be switch a Unit ID 3 if I don't have a unit 2?

 

 

 

-The out-of-band and the in-band ports share the same IP routing table, therefore you cannot use the same subnet on both in-band and out-of-band interfaces.

I have not assigned IPs to the in-band interfaces but maybe that is an issue nevertheless.

Will need to move current IP to inband or create a new management subnet. Annoying :/

Highlighted

Alright, it indeed was the Master selection process that prioritized the remote switch as master whenever connected stacking.

With no OOB connected there I didn't have access so it looked like the OOB was shut down.

 

After rebooting the remote switch to prioritize the local switch everything is working fine.

Now to find out how to 'force' the master with this series.

 

 

Edit: Setting the other switch to Node 3 sets it to slave mode and as such it does not participate in the master selection process.

View solution in original post