cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


539
Views
0
Helpful
1
Replies
Highlighted
Beginner

sg500 loosing command line

I have an SG500 small bussines switch. Ports where phones are configured as follows:

LAN-PUEBLA-CEDA#sh run int GigabitEthernet 1/1/9
interface gigabitethernet1/1/9
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
macro description ip_phone_desktop
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
voice vlan cos mode all
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop

Phones connected to port are Polycomm Models VVX300 & VVX400. Version of the switch is:

LAN-PUEBLA-CEDA#sh ver

Unit SW version Boot version HW version
------------------- ------------------- ------------------- -------------------
1 1.3.0.62          1.3.0.03             V06

Problem is as follows: PC's behind the phones lost DHCP access (which is being managed on external cisco router). No alarm is received since phones keep working as normal. Ports with only data vlan (VLAN 10) keep working without problem.

When access switch configuartion I've noticed configuration line  "switchport trunk native vlan 10" has disappeared from configuration file.

Once command is re-entered, PCs operation is recovered ... until problem is present again.

Any previous exprience with this?

1 REPLY 1
Highlighted
Beginner

If you issue the sh macro auto smart-macros ip_phone_desktop command it show you the variables's parameter where the $native_vlan variable is equal to 1.

 

switch#sh macro auto smart-macros ip_phone_desktop

SmartPort type : ip-phone-desktop
Parameters : $max_hosts=10 $native_vlan=1 $voice_vlan=20
SmartPort Macro: ip_phone_desktop (Built-In)

 

You must set this value with this command: macro auto built-in parameters ip_phone_desktop $native_vlan 10.

 

switch#sh macro auto smart-macros ip_phone_desktop

SmartPort type : ip-phone-desktop
Parameters : $max_hosts=10 $native_vlan=10 $voice_vlan=20
SmartPort Macro: ip_phone_desktop (Built-In)