cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


2278
Views
5
Helpful
10
Replies
Highlighted
Beginner

SG550 - SG300: LACP Portchannel Interfaces joining and leaving "constantly"

Hello,

I'm in the process of changing my core from two Cat4.5K to a two member stack of cisco SG550XG-24F and a two member stack of cisco SG350XG-24F. Both stacks running 2.4.0.94. The access Switches are a lot of SG300 (all running software version 1.4.9.4) with different port densities. I'm running in several problems regarding Port-Channels.

 

An example is the following setup. A rack consisting of two SG300s, each one is connected with the two 1G Fiber Ports (gi27 and gi28) with a 2 port LACP port channel (Po2) to two 10G SFP+ ports of the SG550 stack, one port of the portchannel on each stack member (e. g. te1/0/8 and te2/0/8). The network is running rstp and the two rack switches have a two port lacp portchannel crossconnect in between them as a backup with a high spanningtree priority (the plan is to get rid of the crosslinks and spanningtree in the future). Before (with the Cat4.5k) the setup was nearly the same, but each rack switch was beeing connected to one of the Cat4.5K with a port channel.

Now I got the problem, that interfaces are joining and leaving the port channel _very_ often. Here are some log excerpts from the switches (log verbosity is set to debugging (!)):

 

sg300-A:
26-Oct-2018 10:15:36 :%TRUNK-I-PORTADDED: Port gi28 added to Po2
26-Oct-2018 10:15:36 :%TRUNK-W-PORTREMOVED: Port gi28 removed from Po2
26-Oct-2018 10:10:05 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 10:10:05 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
26-Oct-2018 10:08:35 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 10:08:35 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
26-Oct-2018 10:04:05 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 10:04:05 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
SG300-B:
26-Oct-2018 11:26:17 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 11:26:17 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
26-Oct-2018 11:24:47 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 11:24:47 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
26-Oct-2018 11:10:17 :%STP-W-PORTSTATUS: Po2: STP status Forwarding
26-Oct-2018 11:10:17 :%STP-W-PORTSTATUS: Po1: STP status Blocking
26-Oct-2018 11:10:16 :%TRUNK-I-PORTADDED: Port gi28 added to Po2
26-Oct-2018 11:10:16 :%LINK-I-Up:  Po2
26-Oct-2018 11:10:16 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 11:10:16 :%LINK-W-Down:  Po2
26-Oct-2018 11:10:16 :%STP-W-PORTSTATUS: Po1: STP status Forwarding
26-Oct-2018 11:10:15 :%TRUNK-W-PORTREMOVED: Port gi28 removed from Po2
26-Oct-2018 11:10:15 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
26-Oct-2018 11:07:16 :%TRUNK-I-PORTADDED: Port gi28 added to Po2
26-Oct-2018 11:07:16 :%TRUNK-W-PORTREMOVED: Port gi28 removed from Po2
26-Oct-2018 11:07:15 :%TRUNK-I-PORTADDED: Port gi27 added to Po2
26-Oct-2018 11:07:15 :%TRUNK-W-PORTREMOVED: Port gi27 removed from Po2
SG550-Stack, same time window as above excerpts, Po24 is to SG300-B, Po14 to SG300-A:
26-Oct-2018 11:13:17 :%TRUNK-I-PORTADDED: Port te1/0/12 added to Po24
26-Oct-2018 11:13:16 :%TRUNK-W-PORTREMOVED: Port te1/0/12 removed from Po24
26-Oct-2018 10:44:15 :%TRUNK-I-PORTADDED: Port te2/0/3 added to Po2
26-Oct-2018 10:44:14 :%TRUNK-W-PORTREMOVED: Port te2/0/3 removed from Po2
26-Oct-2018 10:05:36 :%TRUNK-I-PORTADDED: Port te2/0/11 added to Po14
26-Oct-2018 10:05:35 :%TRUNK-W-PORTREMOVED: Port te2/0/11 removed from Po14

example configurations for the ports on the sg550:

interface TengigabitEthernet1/0/12
 storm-control broadcast level 1
 storm-control multicast level 5
 channel-group 24 mode auto
 switchport mode trunk

interface Port-Channel14
 negotiation 1000f
 description SW-R4-A:Po2
 switchport mode trunk
 no macro auto smartport

for the sg300:

interface gigabitethernet27
 ip arp inspection trust
 ip dhcp snooping trust
 storm-control broadcast level 10
 storm-control include-multicast unknown-unicast
 channel-group 2 mode auto

interface gigabitethernet27
 description "Uplink SW-BB-B:gi1/25"
 ip arp inspection trust
 ip dhcp snooping trust
 storm-control broadcast level 10
 storm-control include-multicast unknown-unicast
 channel-group 2 mode auto

Connected to the Cat4.5K using the same cables and the same SFP's (additionally using the "lacp timeout short" option on the sg300 interfaces) this setup was running smoothly for several years. I have this problems with all the racks migrated to the new SG550 core. The ones still beeing connected to the Cat4.5k _all_ are fine. I even have this problem with two SG300 beeing directly connected with 1.5m of CAT6 Cable and two RJ45 SFPs to the SG550.

 

On one Rack I set the port-channels to static on for testing. This one runs smoothly since then.

 

Actually it gets even more "interesting", as I also have the same problem now with the _untouched_ portchannels of the crossconnect on the rack switches, interfaces leaving and joining the portchannel over and over again.
The configs is the same as above, with only "spanning-tree cost 200000000" added. Again: this is only happening to the rack switches connected to the sg550 stack!

 

I couldn't find any information about the debug mode for smb's. I'd really like to debug the lacp traffic/connection.

Anyone knows how to do that on SMBs?

 

Any suggestions are more than appreciated! Thanks!

 

Apostille:

 This is also happening with a two member 2 x 10G LACP portchannel between the SG550 and the SG350 stacks! This portchannel is also distributed over the stack members.

Maybe I should have a look what happens if I don't use cross-stack portchannels...

10 REPLIES 10
Highlighted
Beginner

changeing the a port channel to non overarching stack members didn't change anything.

Right now the whole stack is unreachable due to the crosslinks to the Cat4.5K are just laving and joining all the Time:

 

cat4.5k A:

Oct 30 14:23:30.721: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:23:34.353: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:23:34.453: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:23:34.481: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:23:36.097: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:23:36.197: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:23:36.225: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:23:36.341: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:23:40.453: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:23:44.453: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:23:52.209: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:23:57.897: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:24:04.352: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:24:04.452: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:24:04.480: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:24:06.280: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:24:06.316: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:24:06.316: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:24:24.212: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:24:27.856: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:24:34.352: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:24:34.456: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:24:34.480: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:24:36.112: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:24:36.272: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:24:36.444: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:24:54.211: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:24:57.859: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:25:04.351: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:25:04.455: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:25:04.479: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:25:06.219: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:25:06.383: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:25:06.467: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:25:24.210: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:25:28.002: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:25:34.362: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:25:34.454: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:25:34.478: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:25:36.274: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:25:36.350: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:25:36.362: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:25:54.209: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:25:58.021: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:26:04.349: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:26:04.449: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:26:04.477: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:26:06.129: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:26:06.237: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:26:06.349: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:26:08.105: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:26:08.605: %DTP-5-NONTRUNKPORTON: Port Gi1/34 has become non-trunk
Oct 30 14:26:10.105: %LINK-3-UPDOWN: Interface GigabitEthernet1/34, changed state to down
Oct 30 14:26:13.449: %LINK-3-UPDOWN: Interface GigabitEthernet1/34, changed state to up
Oct 30 14:26:14.953: %DTP-5-TRUNKPORTON: Port Gi1/34 has become dot1q trunk
Oct 30 14:26:18.457: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:26:25.841: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:26:26.341: %DTP-5-NONTRUNKPORTON: Port Gi1/34 has become non-trunk
Oct 30 14:26:27.841: %LINK-3-UPDOWN: Interface GigabitEthernet1/34, changed state to down
Oct 30 14:26:30.449: %LINK-3-UPDOWN: Interface GigabitEthernet1/34, changed state to up
Oct 30 14:26:31.961: %DTP-5-TRUNKPORTON: Port Gi1/34 has become dot1q trunk
Oct 30 14:26:34.353: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:26:34.453: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:26:34.481: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:26:35.917: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:26:36.165: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:26:36.389: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:26:36.409: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:27:03.280: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:27:04.352: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:27:04.456: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:27:04.480: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:27:05.012: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:27:06.268: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:27:06.372: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:27:06.408: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:27:33.279: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:27:34.351: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:27:34.455: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:27:34.479: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:27:35.183: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:27:36.155: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:27:36.307: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:27:36.331: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:27:56.679: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:28:02.123: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:28:04.351: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:28:04.455: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:28:04.479: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:28:06.323: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:28:06.431: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:28:08.194: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42

cat 4.5k B:

Oct 30 14:22:26.742: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:22:26.958: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:22:34.626: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:22:34.782: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:22:36.386: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:22:36.726: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:22:54.974: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:22:54.974: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:22:56.830: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:22:58.574: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:23:04.625: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:23:04.781: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:23:06.413: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:23:06.733: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:23:24.973: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:23:24.973: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:23:26.741: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:23:26.901: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:23:34.629: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:23:34.781: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:23:36.521: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:23:36.569: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:23:54.972: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:23:54.972: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:23:56.924: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:23:58.620: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:24:04.628: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:24:04.780: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:24:06.540: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:24:06.736: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:24:24.971: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:24:24.971: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:24:26.971: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:24:28.643: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:24:34.627: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:24:34.779: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:24:36.355: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:24:36.539: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:24:54.971: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:24:54.975: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:24:56.755: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:24:56.815: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:25:04.626: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:25:04.782: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:25:06.502: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:25:06.710: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:25:24.970: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:25:24.974: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:25:26.810: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:25:26.886: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:25:34.626: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:25:34.782: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:25:36.346: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:25:36.542: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:25:54.969: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:25:54.973: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:25:56.857: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:25:58.645: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:26:04.625: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:26:04.781: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:26:06.361: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:26:06.689: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:26:24.973: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:26:24.973: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:26:26.861: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:26:28.524: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:26:34.628: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:26:34.780: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:26:36.564: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:26:36.740: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:26:54.972: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:26:54.972: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:26:56.688: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:26:56.748: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:27:04.628: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:27:04.784: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:27:06.492: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:27:06.748: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:27:24.971: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:27:24.971: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:27:26.687: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:27:26.691: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:27:34.627: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:27:34.779: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:27:36.567: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:27:36.779: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:27:54.970: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:27:54.970: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:27:56.706: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:27:56.746: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:28:04.630: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:28:04.782: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:28:06.570: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:28:06.606: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:28:24.970: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Oct 30 14:28:24.970: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:28:26.822: %EC-5-BUNDLE: Interface Gi1/38 joined port-channel Po42
Oct 30 14:28:28.538: %EC-5-BUNDLE: Interface Gi1/34 joined port-channel Po42
Oct 30 14:28:34.637: %EC-5-UNBUNDLE: Interface Gi1/33 left the port-channel Po42
Oct 30 14:28:34.781: %EC-5-UNBUNDLE: Interface Gi1/37 left the port-channel Po42
Oct 30 14:28:36.537: %EC-5-BUNDLE: Interface Gi1/33 joined port-channel Po42
Oct 30 14:28:36.613: %EC-5-BUNDLE: Interface Gi1/37 joined port-channel Po42
Oct 30 14:28:49.541: %SSH-5-SSH2_SESSION: SSH2 Session request from 2003:E9:7F1B:BC00:78D1:EF8D:8480:9B2B (tty = 0) using crypto cipher 'aes256-cbc', hmac 'hmac-sha1' Succeeded
Oct 30 14:28:54.969: %EC-5-UNBUNDLE: Interface Gi1/34 left the port-channel Po42
Oct 30 14:28:54.973: %EC-5-UNBUNDLE: Interface Gi1/38 left the port-channel Po42
Highlighted

the switch stack was available via oobm interface. it was not possible to revive the portchannels. no information could be obtained via cdp and lldp from the nighbours, including the ones connected via static port-channel. after a reboot of the sg550x stack, everything works fine again.

Highlighted

After reviewing my logs for the same issue as reported, one thing I noticed while looking at the "optical Module Status" under Diagnostics, the temperature and current of the ports affected in my case seem to have a higher value when compared to others.
See extract below; (Output has been truncated)
Port Temperature Voltage Current OutputPower InputPower Transmitter Fault Loss of Signal Data Ready
te1/0/24 33 3.34 17.75 1.00 1.00 No No Yes
te2/0/24 33 3.34 18.49 1.00 1.00 No No Yes

Not sure if this will have effect on the issue reported just though I should mention it.
One thing for sure is that the Current is way higher than other ports with optical modules by at least 14.
Highlighted

Hello Jane,

What happens if you 'force' the port to join a channel without an LACP operation ? :

 

switchxxxxxx(config-if)# channel-group X mode on

Cheers,

Mike

Highlighted

@mipopo: I have two two port port-channels, each across the stack, in mode "on" running for over 30 days without any problems. Before using LACP I had the above problems. Optical modules weren't changed.

Highlighted

Hi Jane1

 

Is your problem solved permanently ?  

Highlighted

nope, the problem peristed and when having higher traffic load on the switch stack it completely failed (packets dopped, high cpu load, no ssh access to the switch possible anymore).

We switched to static port channels but VLANS were no passed through, although beeing configured on the port channel. We suspect the stacking to be broken but didn't invest any more time in this hardware but removed them completely. SG300s did a real good job, but sg350 and sg550 and stacking seems to be massively broken.

Highlighted

Hi,

Try to disable the LLDP protocol. I faced the same some time ago but not sure, it is same or not. 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted

I have the Same issue, below is my connectivity

 

cisco 9500 stack <-----------> connected to SG350

 

Below are the error messages 

 

Jan 31 15:15:55.616: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:16:13.862: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:16:14.865: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:16:51.847: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:17:01.427: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:20:03.021: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:20:07.957: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:21:42.733: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:21:45.183: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:22:16.182: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:22:26.386: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:22:39.992: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:24:15.500: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:24:22.897: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:24:28.215: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:27:00.052: %LINEPROTO-5-UPDOWN: Line protocol on Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:27:08.744: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:27:29.906: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:27:39.341: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:29:02.363: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:29:28.774: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:29:38.539: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:37:21.670: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:37:32.264: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:37:41.277: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.
*Jan 31 15:40:17.363: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to down
*Jan 31 15:40:27.926: %LINK-3-UPDOWN: Interface TwentyFiveGigE2/0/19, changed state to up
*Jan 31 15:40:36.952: %ETC-5-L3DONTBNDL2: Twe2/0/19 suspended: LACP currently not enabled on the remote port.

 

config on cisco 9500

------

Core#show run int port-channel 7
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel7
switchport mode trunk
end

Core#show run int twe
Core#show run int twentyFiveGigE 1/0/19
Building configuration...

Current configuration : 115 bytes
!
interface TwentyFiveGigE1/0/19
switchport mode trunk
speed 1000
duplex full
channel-group 7 mode active
end

Core#show ru int twe
Core#show ru int twentyFiveGigE 2/0/19
Building configuration...

Current configuration : 115 bytes
!
interface TwentyFiveGigE2/0/19
switchport mode trunk
speed 1000
duplex full
channel-group 7 mode active
end

------------

 

 

config on SG 350

 

Bng#show run int Port-Channel7
interface Port-Channel7
description LAG7
switchport mode trunk
!
Bng#show run int GigabitEthernet3
interface GigabitEthernet3
no negotiation
channel-group 7 mode auto
no lldp transmit
no lldp receive
!

Bng#show run int GigabitEthernet15
interface GigabitEthernet15
no negotiation
channel-group 7 mode auto
no lldp transmit
no lldp receive
!

 

Kindly Advise how can i solve this issue???

Any pointers i did disable LLDP under ports..

 

Regards,

Ranjit

Highlighted
Beginner

Hi there,

 

We have also the same problem, do you guys also have the stack running in Hybrid-Mode?

While on the newest Firmware, we also had unstable LAGs, and also sometimes a reboot of a stackmember.

Also the stack reported high temperature alerts.

 

At the moment we have a workaround which seems to work so far:

Downgrade to 2.3.x Release

https://community.cisco.com/t5/cisco-bug-discussions/cscvo49699-tesla-sg550x-48p-sg350-52-sg350-52mp/td-p/3854159 )

 

Hope this helps, maybe also for Cisco to fix this.

BR

Ben