cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


241
Views
0
Helpful
2
Replies
Highlighted
Beginner

Software Version 1.4.11.5 rn Page 7 says there exist 2 HW revs: HW VID=01 & 02. My SG300-10 reports HW VID=04. ????

Apologies for the long title. This firmware update *just* came out. Usually I wouldn't brave it this soon. But my circumstances are this: I have used gear arriving that I've acquired for a lab setup for a couple of related projects and I have qty 2, SG300-10 's and qty 1, SG500-28P arriving in the next couple days. Typically when I'm first setting up gear & configuring it is when I load the latest firmware. As luck may have it (bad or good I'm not sure yet!) all 3 of these devices will take the same firmware that was just release on 6-18-2020, Software Version 1.4.11.5.

 

So, my best practice is to always read the release notes PRIOR to doing anything. I'm superstitious about the ghosts in the machine of well-worn used gear enough to respect it and ensure I'm making ZERO assumptions before I begin. I haven't been sleeping well and its possible my reading comprehension has suffered for it.

 

The SG500 case seems clear. Release Notes state that the 500s have only 1 hardware version. So, I should be good there. And I'll verify once it arrives. The 300s however supposedly have 2 hardware revs and there are different files for each rev. So I checked one of the two and it shows HW VID=02. Okay. Within bounds, I just select case and follow the instructions. Cool. I check the other one and it shows HW VID=04. Wait, what? in decimal, in case you're not familiar, 04 is a higher value than 02. The rn states there on Page 7 that there are 2 HW revs.

 

Okay, I just checked again and my Spidey Sense is tingling... it says 'This firmware runs on two different versions of hardware for...[edited] ...the 300 Series Managed Switches.' Maybe THAT legalese sounding phrase is the answer. RUNS ON.

 

I wouldn't load firmware that states it runs on HW VID=01 or 02  on a system that reports HW VID=04. I mean that sounds like you're asking for trouble, right? Sometimes I can't see the forest for the trees, so I just wanted to get a 2nd opinion... well as many like 2nd to the 255th opinions.

 

This particular switch has the oldest rev of firmware on it, so I feel like it DOES need to be updated and man, I was hoping to have them all at the same version... just for things to be relatively neat. I mean I have an SG350-10P that uses an entirely different family? I dion't know what the term would be but it's firmware is not just a different version, but a different series. So I can live with that.

 

Any evaluation, re-assurances, umm.. verification, name-calling, reprimanding, encouragement, lets see... direction, etc. would be appreciated. Also, I can just find a stable version to update them all to, I suppose that's shy of this release, in case this opens up a larger can of worms and I need to just wait to see what other ppls experiences are... but thanks for taking the time to read if you've gotten this far. Ha! 

 

Oh on a semi-related note, I just discovered the SG250-08HP (& the -10P model). I'd just skipped over 250s because I thougt they were lacking actual managed features, but it appears that they have most of the key stuff in there and >LVL 2. It's getting pretty standard to have the IGMP snooping & querier, QoS with strict priorities, VLANs, etc & PoE+ on all 8 ports. Stuff that I need to do Dante and <10Gb AV-over-IP stuff... multicast video streaming from Crestron NVXs, etc. So I ordered a cheap, 'renewed' refurb SG250-08HP off AMZ for $110 + tax with the idea of keeping it in my backpack if I have the opportunity to test or tinker while away from home. Anyone had experiences worth mentions, good or bad with one of these lil babies??

 

Thanks and stay tuned, same Bat-time, same Bat-channel and I'll update with whatever I learn from this **bleep**uation. =]

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Software Version 1.4.11.5 rn Page 7 says there exist 2 HW revs: HW VID=01 & 02. My SG300-10 reports HW VID=04. ????

Here is the REAL solution:

 

1 ACCEPTED SOLUTION
 
Seb Rupik
 
 VIP Advisor Seb Rupik VIP Advisor
 
VIP Advisor
 
Re: Latest Firmware for SG300 HW V04

I have that version running on my V03 SG300. You will be safe to install it.

 

You will always have two boot images installed anyway, so rolling back is easy to do.

 

cheers,

Seb.

View solution in original post

 
Everyone's tags (0)
 
 
 
 
4 REPLIES

View solution in original post

2 REPLIES 2
Highlighted
Beginner

Re: Software Version 1.4.11.5 rn Page 7 says there exist 2 HW revs: HW VID=01 & 02. My SG300-10 reports HW VID=04. ????

Good news everyone! I found an answer. Apparently this confusing refernce to only HW revs has propogated thru firmware Release Notes for some time. It was just new and confusing to ME! 

 

I found an old post from 2018 that had an almost identical scenario and word for word description. So, I am not clear on the etiquette, but I have copied it to past here as a solution. I also replied to the person who provided the solution in 2018 to thank them. So, it sounds like it is safe to just load one of the versions. I asked the question of which they used and the logic of making that decision, so we'll see if I get a response and what their thought process was. In the meantime, I think I'm confident enough to proceed as I was reminded that if it fails, that I can revert to the alternate version. I may not forge ahead tonite as I'm sleep-deprived still and I know that makes one error-prone. Anyway, here is the 'SOLUTION':

 

Good News Everyone! It's a suppository. - Professor Farnsworth ...

 

OOOpppps!!! Hliraious, I know. But that's NOT the solution. I'll go find it and copy it to the clipboard again...

Highlighted
Beginner

Re: Software Version 1.4.11.5 rn Page 7 says there exist 2 HW revs: HW VID=01 & 02. My SG300-10 reports HW VID=04. ????

Here is the REAL solution:

 

1 ACCEPTED SOLUTION
 
Seb Rupik
 
 VIP Advisor Seb Rupik VIP Advisor
 
VIP Advisor
 
Re: Latest Firmware for SG300 HW V04

I have that version running on my V03 SG300. You will be safe to install it.

 

You will always have two boot images installed anyway, so rolling back is easy to do.

 

cheers,

Seb.

View solution in original post

 
Everyone's tags (0)
 
 
 
 
4 REPLIES

View solution in original post