Showing results for 
Search instead for 
Did you mean: 


Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


SRW2024 no web gui

We have a brand new SRW2024 v1.3. It came with firmware 1.2.2b on it. I can get the login screen, but after authenticating, I don't see any info. I get the html frame information, but the individual frame pages are not displayed. I tried this with Firefox 3.5, IE 8, and Google Chrome, and on 2 different computers. I found a reference to changing the username from "admin," but that didn't help. I tried adding 2 other username, but neither one of those worked either.

The console connection works great. This is what I used to try and re-load the same firmware. I don't believe I can use firmware 1.2.2 and 1.2.2b is the latest available from

I can't figure out why this wouldn't work. We have 3 more of these at another site, but I won't have access to those until next week. Is there anything else I can try?



Accepted Solutions

First... Thank you very much! I'm now able to get in and see it.

The Workaround for anyone having the same issue:

Install IE Tab in Firefox.

Now for my complaint to Cisco/Linksys: Are you serious?

In order to get into this switch, I have to use Internet Explorer INSIDE OF Firefox. Really?! I would have rolled back to another version of firmware, but the SRW2024 v3.0 doesn't have any older firmware. Cisco/Linksys REALLY needs to fix this. These switches were supposed to be used as aggregate switches in the racks of a multi-million dollar operation, but now will probably be rejected because the WEB UI "can't be accessed." And this will probably affect our purchasing and definitely their purchasing of Linksys products in the future. I guarantee that we WILL NOT be ordering this line of switches for any other customers until the WEB UI has been fixed!

Sorry about the rant, but I felt that Cisco and Linksys need to realize the severity of this "bug."

Thank you.

Are you sure that IETab works with it fine even if IE8 is installed on the system?

Yep. I have IE8 and Firefox 3.5 installed on my laptop and desktop. Both of them are able to get into the setup pages when IE Tab is installed.

And I just noticed that the switch is version 1.3, not 3.0. Sorry about that.

Message was edited by: aaron.quinto

Thank you. It's kinda weird, but it really works... but only with Firefox + IETab, not with the "standalone" IE8.

Anyway, it is really strange that no one of the Cisco developers comments on the topics...

Will be waiting (and hoping) for the firmware updrade.

As an engineer at the Small Business Support Center I would like to say that we completely understand your frusrtation with the SRW switches. Calls like this are not rare, and I have also found your work-around to perform very well. We are in the process of changing firmware on many of our switches to make the hardware perform better and also correct this very problem.

Please keep in mind that the SRW line of switches are really meant for a small business not a multi-million dollar enterprise. The SFE, SGE and ESW pro series switches are much better suited for those applications and because they do not rely on ActiveX we do not have such issues.

Again, we are completely aware of this problem and it is being taking seriously. This forum was made to allow our customers to provide feedback concerning their experiences being good or bad. Because you have posted and expressed your honest opinion (albeit, a little too honest :) ) this post has been noticed. Cisco is proud of its reputation and will not let problems like this to continue. I would ask anyone reading this post that is experiencing the same problem to call SBSC and start a case. This will allow us to officially track and document severity to assist in expiditng a fix.

SBSC: 1.866.606.1866

Thank you, but I do not live in the USA,

     and all the problems are explained in the mentioned forum threads lots of times by many people.

Why one should call some phone number?

Why do not you, Cisco workers, "start the case"  just relying on the posted information?

Isn't it enough for you to start correcting the problems?

Best regards, Leonid.

The problem is known to us and we are working on a fix. I would love to start a case, but the cases created are based on customer's names and serial numbers of the devices. I understand the frustration, and all I can say is that we are working on resolution. Like most companies, trouble tickets cannot be created just by word of mouth. Like I stated earlier, this post has been noticed and resolution is in the works. As am sure you are aware we have call centers throughout the world. If you would like a number for your region just let us know.

Thank you.

When I called Russian Cisco support they gave me the contact for Russian Linksys/Cisco support.

The contact told me, he doesn't know anything about Linksys switches (=)) and can't help, so I was just unable to open the ticket.

It's all really strange... hmmmm... it was about a month ago.

Try calling the appropriate phone number for the Small Business Support Center.  I hope the number you called is not the one listed in the following URL.

I am sad to hear that your call was not handled properly.  But the comments from that technician is inconsistent, they should understand very well SRW series products. .

regards Dave


Thanks to aaron.quinto for the good catch - great work-around, dude!

I find that it makes perfect sense why this works:

IE8 does not work because it uses (abuses?) the TCP/IP stack of the PC on which it runs to opens lots of simultaneous
parallel connections to the SRW. Since SRW was not written to handle so many parallel connections, some or all of these
connections fail to retrieve the piece of the page they are trying to, and we get whatever remains.

This many-connections-at-once thing by IE8 is a gamble - when it works (i.e. you connect to a web-site running on a TCP/IP

stack that CANhandle this) gets you  a faster-seeimng IE8, but when it doesn't - well, you know...

When we use IEtab all the getting-of-objects is done the FF way, and only the rendering is done by IE - so if FF does

not overwhelm the SRW's TCP/IP, everything works.

Incidentally, The IE8 change is not just not backward compatible, it actually violates the HTTP standard, but hey, we're
Microsoft, we don't care. and to prove it, things will get even more "interesting" in IE9. Here's a quote from

" ... However, the specification that has left by far the most users disappointed with the current build of the browser
     its is Web standards compatibility. Acid3 is a well-recognized test suite for Internet browser encompassing many
    aspects of the Document Object Model and JavaScript language in one hundred small but comprehensive tests.
   With Safari, Opera and (in its latest build) Chrome all scoring a full 100/100 on the test, IE9 scored a very unimpressive 32/100."

In other words, we ain't seen nothing yet ...

(full article at : )


Sure, it explains the reason of the "bug". Hope, the new firmware works with Firefox/Safari/Lynx/etc and CLI interface gets extended functionality for the switch to be deservedly called "managed".

Since Miscrosoft is WELL known for its' immutable adherence to the standards =)) , it is not its' fault to write yet another incompatible browser (anybody expected anything else?...), but the fault of Linksys to make a web-applience working only on this platform. Hard to understand, why it was made this way...


It doesn't look like it's the "max connections." I lowered my Firefox to 2 (since 2 is the maximum for IE7) and it still did the same thing. I think it's more that whoever wrote the HTML, ASP, CGI, or whichever language the web pages are in, ONLY tested it with IE7. That's one of the biggest gripes I had for years with web developers. They were only testing their webpages with IE, since 80% or more of the population was using it. I believe that's what's happened here. I think Linksys' developers had only built the webpages and tested them with IE7.

The reason I'm pointing this out is because if Linksys/Cisco is still reading this, it shouldn't be that much development work to fix it. You just have to figure out what's missing in the HTML files that get sent to the browser and add a little bit of code to finish building the web pages. I used to build web pages, and I found that IE was great for developers, because it didn't adhere to the letter. It filled in items that were missing (such as a command to close a table).

It looks like Microsoft now has tried to become more Web-compliant, and in turn, broken the old web sites. That's why IE8 has it's "backward-compatibility" mode. Although, even the backward-compatibility still doesn't work with the Linksys switches, so I'm not positive of what's missing.

I just took a look at the source of the web page (using IETab) and it looks like they rely heavily on Javascript. So now I'm thinking there's an issue with the Javascript not being compatible with something. Maybe there's some VBscript in there and that's why Firefox won't work. I'm not sure, but from what I've seen, I think it's something in the web page design.

Not arguing for or against anything or anyone. I'm just trying to add information to help Cisco/Linksys to fix the issue.



Here is a document that I downloaded from the community recently downloaded. It was titled browserfix IE6 IE7 I am going to paste it here with the additions/changes i a) feel it needs to clearly convey the changes and b) have tested personally.

Procedure for Internet Explorer 8


The maximum number of connection per server should be limited to 1 The only problem is that MSIE 8 stores that setting on a different location compared to MSIE 7 and older versions.

According to this MS article:

You have to follow procedure with version 8:


   1. Start Registry Editor.

   2. Locate the following key in the registry:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InternetExplorer\MAIN\FeatureControl\FEATURE_MAXCONNECTIONSPERSERVER (this key had to be created)

   3. On the Edit menu, point to New, click DWORD Value, and then add the following registry values:

      Value name: iexplore.exe

      Value data: 10 (i tested the value decimal 2, though in hex it would be input the same :))

      Base: Decimal

      Note set this value to the connection limit that you want for HTTP 1.1 connections. By setting the value to 10, you increase the connection limit to 10. (again, i tested the value 2)

   4. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InternetExplorer\MAIN\FeatureControl\FEATURE_MAXCONNECTIONSPER1_0SERVER (this key had to be created)

   5. On the Edit menu, point to New, click DWORD Value, and then add the following registry values:

     Value name: iexplore.exe

      Value data: 10 (i tested the value 2)

      Base: Decimal

      Note set this value to the connection limit that you want for HTTP 1.1 connections. By setting the value to 10, you increase the connection limit to 10. (i tested the value 2)

   6. Exit Registry Editor.


It solves the web interface problem on this switch, obviously set the connections to 1 and not to 10.

I also had to restart my IE8 browser. Also note, this was tested on an SLM2048 however, I believe this will work on all the small business products.

Please let me know weather or not this works for you and/or if you test the connections when set for 10.

Thank you,