cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1911
Views
0
Helpful
5
Replies

Switch Cisco SF300 lose configurations after unexpected power cut

rtyack2000
Beginner
Beginner

Hi there,

we recently upgraded our network in our company. We added something like 20 Cisco Switch (mostly SF300, SG300, SF200) in order to be able to manage our dozen of VLANS (mostly data, video, server, printers, voice, etc..)

Although all the switches are on UPS, it appears that they all lose there configurations when the power cuts unexpectedly and the UPS drains out.

Some extra details:

1. All configured switches are on a different subnet that the default one (i.e. not on 192.168.1.0) 

2. All VLANS work perfectly.

3. When I finish configuring the Switched from telnet, I do apply the 'wr' followed by 'Y'

4. Telephones detects the VLAN by default (Alcatel-Lucent devices)

5. Our Core Switch is a Cisco C3850 and we also have 3 Stacked Catalyst Cisco 2960 X-Series for the distribution in our Server Room.

6. Most of the Switches are connected via Optical Fiber and terminates via SFP (GBIC GLC-SX-MMD)

7. We manage the switches on a Management VLAN

8. Most firmware are versions 1.2.9.44 but I also tried to update up to 1.4.2.04, but the issue remains.

So basically, every time we have a power failure, we have to manually reset the switch (by pushing the reset button with a pin), connect on VLAN 1, connect to 192.168.1.254 via a browser (the switch's default IP) and start the configs again -> and do a 'wr' at the end.

My concern is that when I configure a switch at my desk, then disconnect the cables (both RJ45 and the power cable), then reconnect it on the remote site, it does NOT lose the configuration!!! Why?

Has anyone experienced the same thing?

5 REPLIES 5

jonathanlunt
Beginner
Beginner

do a 'copy run start' after the 'wr mem', saves the config to the flash and boots it on loading.

Hi Jonathan.

thanks for your suggestion. I applied it to 'some' of my switch and I'm waiting for another power-cut to see if the problem persist. I will keep you informed once I have more info.

Regards,

Jonathan,

I applied the 'copy run start' on a few switch but this didn' t help, I'm still losing the configs after a power cut. This is very irritating.

Thanks for helping anyway.

Rodolphe

Brandon Svec
Rising star
Rising star

Are you sure they are losing configurations?  Or do you just lose access to them somehow? 

If you are not sure you could try connecting via console cable to verify.

I also strongly recommend to apply the global command macro auto disabled

I have been bit a few times by these switches automagically doing things I didn't want related to macros or auto smartports or some such nonsense.

-- please remember to rate and mark answered helpful posts --

Hi Brandon,

accessing those switch once in production are not easy. I will try to isolate one that messed up after a power-cut and check via console if the configs are lost or not. 

I tried the global command 'macro auto disabled' on one switch and lost control on it after that (no more ping etc... although communication was still working)

Had to reset and reconfigure it though. I surely did something wrong there.

Thanks anyway.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: