cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


4154
Views
0
Helpful
5
Replies
Beginner

Trunk SF300 switch with a 3750

Is it possible to trunk a SF300 switch with a 3750 switch?  If so how?  Whenever I turn trunking on the 3750 port I lose connection to the SF300.

I would appreciate any assistance, thanks

Larnel

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Trunk SF300 switch with a 3750

Hi Larnel,

     You can do this by setting the 3750 for 802.1Q ecapsulation on the trunk port, set the native vlan, and allow VLAN's accross. On the SF300 you would perform the same process create the trunk port, allow the VLAN's, and set the PVID to match the native VLAN on the Trunk interface of the 3750. In order to do this you will need your VLAN's pre-configured on both switches. Hope this helps you out.

Kevin

View solution in original post

5 REPLIES 5

Re: Trunk SF300 switch with a 3750

Hi Larnel,

     You can do this by setting the 3750 for 802.1Q ecapsulation on the trunk port, set the native vlan, and allow VLAN's accross. On the SF300 you would perform the same process create the trunk port, allow the VLAN's, and set the PVID to match the native VLAN on the Trunk interface of the 3750. In order to do this you will need your VLAN's pre-configured on both switches. Hope this helps you out.

Kevin

View solution in original post

Beginner

Re: Trunk SF300 switch with a 3750

Resolved, must have been the native vlan setting.   Thanks

Highlighted
Beginner

Re: Trunk SF300 switch with a 3750

Here's some sample config that I've got.  In the version of OS on the SF 300 right now, you can't acces the LCLI, but you can tftp backup/restore it;

! On the SF 300;

! Note that VLAN 111 is my native/untagged VLAN and the management VLAN here

! The 20x VLANs are 802.1q trunk/tagged

! Remember that there is no VTP here, so you must manually create the VLANs first

interface range ethernet g(1-4)

description "Uplink trunk"
exit
interface range ethernet g(1-4)
switchport default-vlan tagged
exit
vlan database
vlan 111,200,201,202
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 200
exit
interface range ethernet e(21-24)
switchport access vlan 201
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 201
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 202
exit
interface range ethernet g(1-4)
switchport trunk native vlan 111
exit
interface vlan 111
ip address 10.111.0.5 255.255.255.0
exit
interface vlan 1
no ip address dhcp
exit

! On the Cisco IOS switch;

Switch1#sh run int Gi2/0/19
Building configuration...

Current configuration : 334 bytes
!
interface GigabitEthernet2/0/19
description whatever-bla-bla-bla
switchport trunk encapsulation dot1q
switchport trunk native vlan 111
switchport trunk allowed vlan 111,200,201,202
switchport mode trunk
switchport nonegotiate
end

Beginner

Re: Trunk SF300 switch with a 3750

All I want to do is allow all 802.1Q tagged traffic to pass through intact between a 3750 and 3650 in this arrangement...

3750 --- SF300 --- SF300 --- 3560

For some reason it looks like the SF300 with their default configurations are stopping tagged traffic going between the 3750 and 3560 - can you help?

Beginner

Re: Trunk SF300 switch with a 3750

Don't thread-jack.  Start a new subject in the main forum.