cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


2426
Views
12
Helpful
13
Replies
Highlighted
Beginner

Trunking between 2960 and SG300-20, Error: %CDP-W-NATIVE_VLAN_MISMATCH

Hello experts,

I have create trunking between 2 switches 2960 and an SG300-20 but only on SG300 appear an error: "%CDP-W-NATIVE_VLAN_MISMATCH: Native VLAN mismatch detected"

I attached the configuration file here for easy analysis,

Any help is appreciate

Best regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Why assign ip address on vlan

Why assign ip address on vlan 97 (native) on SG300-20? Native doesn't need ip address or SVI (L3) see attached for sample configuration based on your attachments. Note: represent XXX with any number of your choice.

View solution in original post

13 REPLIES 13
Enthusiast

Hi, 

Hi, 

Mismatch native vlan detected on which port ? Also could you upload the resulte from ( show cdp neighbors detail ) from any of the 2 switches. It will helps identify the mismatch occurance. 

Regards

Beginner

Hello,

Hello,

Mismatch native vlan happened on gi19 &20 on SG300.

Here is the show cdp on switche SG300:

SG300-20#sho cdp nei detai
---------------------------------------------
Device-ID: 2960_1
Advertisement version: 2
Platform: cisco WS-C2960-48TC-L
Capabilities: Switch IGMP
Interface: gi19, Port ID (outgoing port): FastEthernet0/37
Holdtime: 131
Version: Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(55
)SE10, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyr
Duplex: full
Native VLAN: 97
SysObjectID: 0.0
Primary Management Address: IP 10.10.123.15,
Addresses:
          IP 10.10.123.15
---------------------------------------------
Device-ID: 2960_1
Advertisement version: 2
Platform: cisco WS-C2960-48TC-L
Capabilities: Switch IGMP
Interface: gi20, Port ID (outgoing port): FastEthernet0/38
Holdtime: 130
Version: Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(55
)SE10, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyr
Duplex: full
Native VLAN: 97
SysObjectID: 0.0
Primary Management Address: IP 10.10.123.15,
Addresses:
          IP 10.10.123.15

On Switch 2960_1

2960_1#sho cdp nei de
-------------------------
Device ID: ****65a2
Entry address(es):
  IP address: 10.10.97.4
Platform: Cisco SG300-20 (PID:SRW2016-K9)-VSD,  Capabilities: Switch IGMP
Interface: FastEthernet0/37,  Port ID (outgoing port): gi19
Holdtime : 173 sec

Version :
1.4.0.88

advertisement version: 2
Native VLAN: 1
Duplex: full
Management address(es):

-------------------------
Device ID: ****65a2
Entry address(es):
  IP address: 10.10.97.4
Platform: Cisco SG300-20 (PID:SRW2016-K9)-VSD,  Capabilities: Switch IGMP
Interface: FastEthernet0/38,  Port ID (outgoing port): gi20
Holdtime : 173 sec

Version :
1.4.0.88

advertisement version: 2
Native VLAN: 1
Duplex: full
Management address(es):

Any help is appreciated,

Best regards,

Beginner

can we use PAgP on your port

can we use PAgP on your port-channel? it is recommended to specify a protocol

on SG300, can we do hardcoding of "switchport mode trunk" on physical interface and on the port-channel?

as much as possible, trunking configuration should be the same at both side..

(including the allowed vlan)

Beginner

Why assign ip address on vlan

Why assign ip address on vlan 97 (native) on SG300-20? Native doesn't need ip address or SVI (L3) see attached for sample configuration based on your attachments. Note: represent XXX with any number of your choice.

View solution in original post

Beginner

Hello osahx1500,

Hello osahx1500,

You are right, you are save my life.

I tried as you recommended and its work perfect.

Basically, native Vlan in our system is Vlan1, so after that i reconfiguration to all interface to native Vlan1 on both of Sw 2960 and SG300 and it fine as expected.

Here is my configured, it may help if anyone have same issue:

Switch 2960:

interface Port-channel1
 switchport trunk allowed vlan 97,123
 switchport mode trunk

!
interface FastEthernet0/37

 description ## To_SG300 ##
 switchport trunk allowed vlan 97,123
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/38
 description ## To_SG300 ##
 switchport trunk allowed vlan 97,123
 switchport mode trunk
 channel-group 1 mode on

On SG 300:

interface gigabitethernet19
 channel-group 1 mode on
!
interface gigabitethernet20
 channel-group 1 mode on
!
interface Port-channel1
 negotiation 100f
 description To-Sw2960
 switchport trunk allowed vlan add 97,123
!

Thank you osahx1500 and everyone.

Best regards,

Beginner

Change native vlan 1 on On

Change native vlan 1 on On Switch 2960_1 to vlan 97 to match other side this should resolve native vlan mismatch

Beginner

Hello,

Hello,

Exactly, i had 1 more Switch L3 connected to 2960_1 and trunking already.

My topology is: Sw_L3 ---- trunking ----> Sw 2960_1 ---- trunking ----> SG300.

Here is the show cdp full on Switch 2960_1:

2960_1#sho cdp nei de
-------------------------
Device ID: Sw_L3_2
Entry address(es):
  IP address: 10.10.97.3
Platform: cisco WS-C4507R-E,  Capabilities: Router Switch IGMP
Interface: GigabitEthernet0/2,  Port ID (outgoing port): GigabitEthernet2/12
Holdtime : 147 sec

advertisement version: 2
VTP Management Domain: ''''
Native VLAN: 1
Duplex: full
Management address(es):
  IP address: 10.10.97.3
-------------------------
Device ID: Sw_L3_1
Entry address(es):
  IP address: 10.10.97.2
Platform: cisco WS-C4507R-E,  Capabilities: Router Switch IGMP
Interface: GigabitEthernet0/1,  Port ID (outgoing port): GigabitEthernet2/12
Holdtime : 173 sec

advertisement version: 2
VTP Management Domain: ''''
Native VLAN: 1
Duplex: full
Management address(es):
  IP address: 10.10.97.2

-------------------------
Device ID: ****65a2
Entry address(es):
  IP address: 10.10.97.4
Platform: Cisco SG300-20 (PID:SRW2016-K9)-VSD,  Capabilities: Switch IGMP
Interface: FastEthernet0/37,  Port ID (outgoing port): gi19
Holdtime : 151 sec

Version :
1.4.0.88

advertisement version: 2
Native VLAN: 1
Duplex: full
Management address(es):
-------------------------
Device ID: ****65a2
Entry address(es):
  IP address: 10.10.97.4
Platform: Cisco SG300-20 (PID:SRW2016-K9)-VSD,  Capabilities: Switch IGMP
Interface: FastEthernet0/38,  Port ID (outgoing port): gi20
Holdtime : 151 sec

Version :
1.4.0.88

advertisement version: 2
Native VLAN: 1
Duplex: full
Management address(es):

Here is the config the interface on L3 that connected to Sw 2960_1:

SW_L3_1#sho run int gi2/12
Building configuration...

Current configuration : 149 bytes
!
interface GigabitEthernet2/12
 description ### To 2960_1_G0/1 ###
 switchport trunk allowed vlan 97,123,
 switchport mode trunk
end

Should i hardcoding assign IP address on Switch 2960_1 and SG300 on the same subnet?

Any help is appreciated,

Best regards,

Beginner

we can try the steps below in

we can try the steps below in order

1. shut down and remove config on port channel interface (if this one does not work, remove port channel interface)

2.shutdown and remove config on physical interface

3. reconfigure physical interface with switchport mode trunk,switchport native vlan, switchport allowed vlan, channel-group <n> mode active.

4.reconfigure or check configuration of port-channel interface. (if port channel interface is removed it is automatically created after specifying channel group under physical interface) 

5. if configuration on port channel interface and on physical interface are the same, issue no shutdown command on port-channel interface.

6. do it on the other switch.

Beginner

Hi Trung,

Hi Trung,

try putting switchport trunk native vlan 97 on the physical interfaces of SG300 too.

Also please give me the result of show interfaces trunk.

Thanks

Beginner

Hello,

Hello,

I also tried the switchport trunk native vlan 97 on SG300 but the packets transfer will be congested because ping is sometime timeout...

Any help is appreciated,

Regards,

Hi,

Hi,

Based on the #show cdp output, I can see that 2960 is not applying the VLAN 97 as native in those ports. But, it helped me before to remove every configuration from ports that belong to a port channel and just configure them in the PortChannel interface. (like you did on the SG)

Regards,

Miguel

Beginner

Hello,

Hello,

I'm unable to delete the Port channel on Sw SG300.

Do i need to press the reset button on the SG300 to delete Port Channel and after that reconfiguration?

Any help is appreciated,

Best regards,

SG is right. I think you can

SG is right. I think you can try changing the 2960 configuration to look like this: 

interface Port-channel1
 switchport trunk native vlan 97
 switchport trunk allowed vlan 97,123
 switchport mode trunk
!
interface FastEthernet0/1
 switchport access vlan 123
 switchport mode access
 spanning-tree portfast
....................................
!
interface FastEthernet0/37
 channel-group 1 mode on
!
interface FastEthernet0/38
 channel-group 1 mode on