cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1800
Views
8
Helpful
12
Replies
Beginner

Trunking between a 3750 and an SG300-10

I'm having a hard time setting up a trunk between a Cisco 3750 running lanbase 12.2(55)SE3 firmware and a Cisco Small Business SG300-10 running v 1.3.5.58 firmware. There are two vlans on both switches, vlan 1 and vlan 200. On the 3750, I already have several ports that are successfully trunking both vlans to other 3750s, 3560s and 2960s. So at the 3750 end, I have configured the intended trunk port to the SG300-10 the same way as the existing trunk ports: dot1q encapsulation; allowed vlan 1,200; mode trunk. On the SG300-10 end, I have tried every suggestion that I can find in various Cisco and non-Cisco support groups, using both the GUI and the CLI with no luck.

The SG300-10 switch is currently a L2 switch. I disabled all the SmartPort features for the intended trunk port and set it as a 'trunk' port. The switch uses vlan 1 as native vlan and administrative vlan. The switch's management IP address is from the site's vlan 1 address range. I can reach the switch from my workstation over the intended 'trunk' (presumably using untagged vlan 1 frames). No problem there.

There are currently two ports on the SG300-10 that are assigned to vlan 200. They are set as 'access' ports. Vlan 200 is site-wide and uses a different IP subnet. If I connect two workstations with vlan 200 IP addresses to those SG300-10 ports, they can ping each other. I cannot ping either one of their vlan 200 addresses from the SG300-10 CLI itself. Since the switch is an L2 switch and vlan 200 on the switch has no IP interface, that's understandable, I guess.

With all that in mind, specifically how do I configure the intended trunk port of the SG300-10 to tag vlan 200 frames and send them over the link back to the dot1q trunk port of the 3750? Do I need to make any changes on the 3750 end to enable trunking with the SG300-10?

Thanks in advance for your help.

12 REPLIES 12
Enthusiast

Hi

Hi

Could you upload running-Config for both 3750 and sg300 switches here, it will be easier to analyze the problem

Beginner

Done.

Done.

Enthusiast

First of all, we will move

First of all, we will move away from choosing vlan1 to pass through trunk port for both switches. So we will do it like the following

 switch sg300

1- Port 1 .... trunk port 》

interface fastethernet 0/1 

switchport mode trunk

switchport trunk allowe all

2- port 2 + port 3... member of vlan 200 》

interface range fastethernet  0/2 - 3

switchport mode access

switchport access vlan 200

3- port 4 +port 5 .... member of vlan 300

interface range fastethernet  0/4 - 5

switchport mode access

switchport access vlan 300

         

Then do ( sh vlan brief ) to verify what we have done with the sg300. After that do the same for 3750 , connect both trunk ports with appropriate utp cable, chick the connectivity locally and then between the switchs. Inform me after finishing. 

Hope that will help

Highlighted
Beginner

Hello experts,

Hello experts,

I has same issue but it is on both of switch 2960. Attached file here for clearly.

Do i missed any configuration?

Any help is appreciated,

Best regards,

Enthusiast

Hi,

Hi,

On both 2960 switches, do ( show vlan brief ). Try to upload the result here please

Beginner

Hello Musa,

Hello Musa,

I uploaded the configured files.

Any help is appreciated,

Best regards,

Beginner

Hi Trung,

Hi Trung,

At which port do you connect the PC1 in SW2?

Can you hard code ip address parameters in PC1 and connect to SW2 see it it can connect to the network.

Kind Regards

Beginner

Hello Chan,

Hello Chan,

I connected PC1 to the SW2 via fa0/2.

I did hard code IP for PC1, but still no luck.

Here is sho int status command of each switches

SW1#sho int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    123        a-full  a-100 10/100BaseTX
Fa0/2                        connected    123        a-full  a-100 10/100BaseTX
Fa0/3                        connected    123        a-full  a-100 10/100BaseTX
Fa0/4                        connected    123        a-full  a-100 10/100BaseTX
Fa0/5                        connected    123        a-full   a-10 10/100BaseTX
Fa0/6                        connected    123        a-full  a-100 10/100BaseTX
Fa0/7                        connected    123        a-full  a-100 10/100BaseTX
Fa0/8                        notconnect   123          auto   auto 10/100BaseTX
Fa0/9                        connected    123        a-full  a-100 10/100BaseTX
Fa0/10                       connected    123        a-full  a-100 10/100BaseTX
Fa0/11                       notconnect   123          auto   auto 10/100BaseTX
Fa0/12                       notconnect   123          auto   auto 10/100BaseTX
Fa0/13                       notconnect   123          auto   auto 10/100BaseTX
Fa0/14                       notconnect   123          auto   auto 10/100BaseTX
Fa0/15                       notconnect   123          auto   auto 10/100BaseTX
Fa0/16                       connected    123        a-full  a-100 10/100BaseTX
Fa0/17                       connected    123        a-full  a-100 10/100BaseTX
Fa0/18                       connected    123        a-full  a-100 10/100BaseTX
Fa0/19                       connected    123        a-full  a-100 10/100BaseTX
Fa0/20                       notconnect   123          auto   auto 10/100BaseTX
Fa0/21                       connected    123        a-full  a-100 10/100BaseTX
Fa0/22                       connected    123        a-full  a-100 10/100BaseTX
Fa0/23                       notconnect   123          auto   auto 10/100BaseTX
Fa0/24                       notconnect   123          auto   auto 10/100BaseTX
Fa0/25                       connected    123        a-full  a-100 10/100BaseTX
Fa0/26                       connected    123        a-full  a-100 10/100BaseTX
Fa0/27                       connected    123        a-full    100 10/100BaseTX
Fa0/28                       notconnect   123          auto   auto 10/100BaseTX
Fa0/29                       connected    123        a-full  a-100 10/100BaseTX
Fa0/30                       notconnect   123          auto   auto 10/100BaseTX
Fa0/31                       notconnect   123          auto   auto 10/100BaseTX
Fa0/32                       notconnect   123          auto   auto 10/100BaseTX
Fa0/33                       notconnect   123          auto   auto 10/100BaseTX
Fa0/34                       notconnect   123          auto   auto 10/100BaseTX
Fa0/35                       connected    123        a-full  a-100 10/100BaseTX
Fa0/36                       connected    123        a-full  a-100 10/100BaseTX
Fa0/37                       notconnect   123          auto   auto 10/100BaseTX
Fa0/38    ## Testing connect connected    trunk      a-full  a-100 10/100BaseTX
Fa0/39                       notconnect   123          auto   auto 10/100BaseTX
Fa0/40                       notconnect   123          auto   auto 10/100BaseTX
Fa0/41                       connected    124        a-full  a-100 10/100BaseTX
Fa0/42                       connected    124        a-full  a-100 10/100BaseTX
Fa0/43                       connected    124        a-full  a-100 10/100BaseTX
Fa0/44                       connected    124        a-full  a-100 10/100BaseTX
          
Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/45                       connected    124        a-full  a-100 10/100BaseTX
Fa0/46                       connected    124        a-full  a-100 10/100BaseTX
Fa0/47                       connected    110          full   a-10 10/100BaseTX
Fa0/48                       connected    110        a-half  a-100 10/100BaseTX
Gi0/1     ### To L3(4500)_G2/ connected    trunk      a-full a-1000 1000BaseSX SFP
Gi0/2     ### To L3(4500)_G2/ connected    trunk      a-full a-1000 1000BaseSX SFP

SW2#sho int status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        notconnect   1            auto   auto 10/100BaseTX
Fa0/2                        connected    97         a-full  a-100 10/100BaseTX
Fa0/3                        notconnect   97           auto   auto 10/100BaseTX
Fa0/4                        notconnect   97           auto   auto 10/100BaseTX
Fa0/5                        notconnect   97           auto   auto 10/100BaseTX
Fa0/6                        notconnect   97           auto   auto 10/100BaseTX
Fa0/7                        notconnect   97           auto   auto 10/100BaseTX
Fa0/8                        notconnect   97           auto   auto 10/100BaseTX
Fa0/9                        notconnect   97           auto   auto 10/100BaseTX
Fa0/10                       notconnect   97           auto   auto 10/100BaseTX
Fa0/11                       notconnect   97           auto   auto 10/100BaseTX
Fa0/12                       notconnect   97           auto   auto 10/100BaseTX
Fa0/13                       notconnect   97           auto   auto 10/100BaseTX
Fa0/14                       notconnect   97           auto   auto 10/100BaseTX
Fa0/15                       notconnect   97           auto   auto 10/100BaseTX
Fa0/16                       notconnect   97           auto   auto 10/100BaseTX
Fa0/17                       notconnect   97           auto   auto 10/100BaseTX
Fa0/18                       notconnect   97           auto   auto 10/100BaseTX
Fa0/19                       notconnect   97           auto   auto 10/100BaseTX
Fa0/20                       notconnect   97           auto   auto 10/100BaseTX
Fa0/21                       notconnect   97           auto   auto 10/100BaseTX
Fa0/22                       notconnect   97           auto   auto 10/100BaseTX
Fa0/23                       notconnect   97           auto   auto 10/100BaseTX
Fa0/24                       notconnect   97           auto   auto 10/100BaseTX
Fa0/25                       notconnect   97           auto   auto 10/100BaseTX
Fa0/26                       notconnect   97           auto   auto 10/100BaseTX
Fa0/27                       notconnect   97           auto   auto 10/100BaseTX
Fa0/28                       notconnect   97           auto   auto 10/100BaseTX
Fa0/29                       notconnect   97           auto   auto 10/100BaseTX
Fa0/30                       notconnect   97           auto   auto 10/100BaseTX
Fa0/31                       notconnect   97           auto   auto 10/100BaseTX
Fa0/32                       notconnect   97           auto   auto 10/100BaseTX
Fa0/33                       notconnect   97           auto   auto 10/100BaseTX
Fa0/34                       notconnect   97           auto   auto 10/100BaseTX
Fa0/35                       notconnect   97           auto   auto 10/100BaseTX
Fa0/36                       notconnect   97           auto   auto 10/100BaseTX
Fa0/37                       notconnect   97           auto   auto 10/100BaseTX
Fa0/38                       notconnect   97           auto   auto 10/100BaseTX
Fa0/39                       notconnect   97           auto   auto 10/100BaseTX
Fa0/40                       notconnect   97           auto   auto 10/100BaseTX
Fa0/41                       notconnect   97           auto   auto 10/100BaseTX
Fa0/42                       notconnect   97           auto   auto 10/100BaseTX
Fa0/43                       notconnect   97           auto   auto 10/100BaseTX
Fa0/44                       notconnect   97           auto   auto 10/100BaseTX
          
Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/45                       notconnect   97           auto   auto 10/100BaseTX
Fa0/46                       notconnect   97           auto   auto 10/100BaseTX
Fa0/47                       notconnect   97           auto   auto 10/100BaseTX
Fa0/48    ## Testing connect connected    trunk      a-full  a-100 10/100BaseTX
Gi0/1                          notconnect   1            auto   auto 1000BaseSX SFP
Gi0/2                          notconnect   1            auto   auto Not Present

Any help is appreciated,

Best regard,

Beginner

Hi Trung,

Hi Trung,

Please hard code this on the trunk ports between SW1 and SW2 and SW1 and 4500.

switchport trunk encapsulation dot1q

Kind Regards

Beginner

Hello Chan,

Hello Chan,

I can not used switchport trunk encapsulation dot1q command. It may switch not support or it default encapsulation dot1q already for trunk ports.

Sw1(config-if)#switchport trunk ?
  allowed  Set allowed VLAN characteristics when interface is in trunking mode
  native   Set trunking native characteristics when interface is in trunking mode
  pruning  Set pruning VLAN characteristics when interface is in trunking mode

On both of switches layer 2 is using version:
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(55)SE10, RELEASE SOFTWARE (fc2)

Any help is appreciated,

Best regards,

Beginner

Hi Trung,

Hi Trung,

Please confirm if you have configured ip default gateway on both switches?

If yes, can you try assigning an interface to VLAN 97 in SW1 and connect PC1, let us check if we can get a DHCP IP in SW1.

Kind Regards

Beginner

Hello Chezter,

Hello Chezter,

You are safe my life!!!.

I forgot configuration allow vlan97 to trunk port between L3(4500) and Sw1.

Resolution: Add vlan97 to the trunk port on L3(4500)

interface GigabitEthernet2/12
 description ### To Sw1 ###
 switchport trunk allowed vlan 97,110,123,124,126
 switchport mode trunk
end

Thank you so much.

Best regards,