Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Air-LAP521G-A-K9 coverted to standalone; express config page broken & cannot acess via CCA

I have a TAC case opened and they have been looking at this for a few days with no resolution so I thought I would post here.  I converted a 521 LWAP to standalone due to a design change (no controller and smaller office space).  I loaded the latest code and also tried 1 rev back (yes, I re-downloaded image to check for corruption. Also, the image appears to save and decompress to flash with no obvious errors). It is running default configuration.   I have used multiple browsers to try to access the web GUI to configure via express service page and when clicking the apply button, the page doesn't update and "error page page" appears in lower left of browser window.  Nothing can be configured via express service page.  There are also other pages where settings cannot be configured, but I assume they are all related and I won't detail here.  Additionally, I have tried to access via CCA with credentials admin and Cisco and authentication always fails.  Also tried Cisco Cisco and cisco Cisco, etc.  I can log in the web gui with <blank> username and Cisco password.  I tried adding a username admin and Cisco for CCA, but authentication still fails.

I used the following command to load the software: archive download-sw /overwrite tftp://x.x.x.x/new-image.tar

I'm using code: c520-k9w7-tar.124-10b.JX.tar

and tried c520-k9w7-tar.124-3g.JX1.tar

Has anyone seen this behavior before?

Any ideas?

Thanks in advance.

David Hornstein
Rising star

Hi Cndpope,

According to the wireless AP Q&A section from

The hardware for the standalone and controller based products is the same.

• AIR-AP521G-x-K9 (standalone access point)

• AIR-LAP521G-x-K9 (controller-based access point)

The products have different software, but the access points can be converted from standalone mode to the controller-based mode with a simple software upgrade.

But no where have i seen it could be converted from controller based to standalone.

If i am wrong I'm sure a colleague will correct me, but I think once converted to controller based, you cannot convert back to Standalone mode. I beleive that is why you are having difficulty.

Good luck


Thanks for the input.  It's just different operating systems on the same hardware (like ios on a router), so I can't see why you wouldn't be able to convert controller-based to autonomous (stand-alone) and vice versa as many times as you want to load it.  I do appreciate your time & I'll look forward to some more input (hopefully!).




I am also trying to convert two AIR-LAP521G to Standalones because the incorrect models were accidentally ordered.  I am curious as to where you found the firmware to convert to Standalone; on the website I can only find the software to convert a Standalone to Lightweight mode.

If you can point me to the correct firmware, I will convert and confirm if it works...




     The firmware you want is under that link you sent, but follow the link for IOS. Then click latest version and on the right, the two IOS's will standalone and the lwap recovery files.  ----SEE COMMENT BELOW BEFORE PROCEEDING----

      HOWEVER, please let me save you some time.  I have worked with 2 different TAC teams and finally have Cisco's position on this:   The Lightweight to Standalone conversion is considered a "back-door hack" and will not be supported as of my case at end of September '09 (things could change if the programmers decide to fix, but see below!).  This is unlike the enterprise versions of APs which can be converted as many times as you want to load the OS (so I've heard).


      After loading the new OS, it breaks the web gui pages as well as shows up as unsupported in CCA.  The reason it shows up as unsupported in CCA is because CCA is looking for part number AP521 instead of LAP521 - therefore it doesn't know what to do with it.  So once you convert, you will not have access to web gui or CCA to configure.  You may, however, still be able to configure via CLI, but I didn't want to chance that there would be anomalies with configurations in the future.  Plus, my client is expecting to be able to see and configure via CCA in the future.  TAC and marketing say they are building this for SMB and CCA will be the main interface to configure the APs.

      I had been told by my distributor's Cisco person that as long as smartnet was on the device, they would support converting standalone to lightweight and lightweight to standalone.  TAC says this is not the case.  Perhaps disti is just used to enterprise grade.  I was able to get mine RMA'd because of this situation, but I don't know they will be doing that for everyone.  I recommend sending back to Disti first.  If you can't do that, then try to convince TAC to swap out.  It's apparently an issue for TAC to be able to RMA a different part number (AP521 vs LAP521) since an RMA will obviously normally be the same part.

      By the way, I tried the most recent version and one rev back.  Both tftp without errors, but the newest will show a very short "input error" of some sort at boot.  The older rev didn't do that, but regardless of that error on boot - neither was configurable via web gui or CCA.  Oh, and I tried this on 2 brand new LAP's, so it wasn't just my one AP that had the issues.

      Good luck.


Thanks for all the info, I guess I will not put any more work into it.  I'll try to get them back to my distributor.