cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this December issue of the Cisco Small Business Monthly Newsletter

2116
Views
0
Helpful
2
Replies
Highlighted
Beginner

AP541N - Computer not switching between AP's

The issue I am having is this when moving throughout our building my laptop will not switch between AP’s unless it loses its connection with its existing AP then it will see the other AP that is closer and connect to it.

For example, I start at one end of the building where it connects to AP#1 at 270Mbps, if I then slowly go to another section of the building, the speed will drop all the way down to 24Mbps, but it will not switch over to AP#2 unless I turn off AP#1 then the laptop instantly switches to AP#2 at 160Mbps. Again the same behavior if I start walking back the other direction. The laptop will not disconnect from AP#2 until the signal is lost.

With my 2.4GHz wireless 802.11g AP’s (WAP200) I can roam around the building and the laptop will happily jump between AP’s always staying with the faster of the two available.

Settings are all pretty basic.

  • Mode is set to 5GHz 802.11n
  • Channel is set to Auto
  • A single SSID is running WPA Personal using wpa2, CCMP (AES)
  • Channel is set to Auto
  • Channel Bandwidth is set to 40MHz
  • Clustering is enabled and the AP’s see each other just fine.

Any ideas why they are behaving like this?

-Nathan

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: AP541N - Computer not switching between AP's

Check the "Roaming Agressiveness" setting for your wireless NIC settings. For my setup, I run it at 4 ("Medium-High"). I quite frankly don't remember the default setting, but I remember that until I tweaked it (some two laptops ago), windows had the habit of clinging to an access point until the connection was dropped totally, before it looked for another one.

//Svein

View solution in original post

2 REPLIES 2
Beginner

Re: AP541N - Computer not switching between AP's

Check the "Roaming Agressiveness" setting for your wireless NIC settings. For my setup, I run it at 4 ("Medium-High"). I quite frankly don't remember the default setting, but I remember that until I tweaked it (some two laptops ago), windows had the habit of clinging to an access point until the connection was dropped totally, before it looked for another one.

//Svein

View solution in original post

Beginner

Re: AP541N - Computer not switching between AP's

Svein's answer is what fixed this for me. I had to switch to a different WLAN card though to have these options. Bought a few Intel 6300 series wireless cards. I turned up the agressiveness a little and have had no issues since. Thanks for pointing me in the right direction!