cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
7149
Views
0
Helpful
20
Replies
Highlighted

AP541N drops all clients

As I posted about in the other AP541N thread about degraded performance, mine did a strange client disconnect last week. It dropped all authenticated clients, but they all thought they were still connected. A quick disable/enable of the wireless card on the laptop would get the computer back on the AP.

This same thing happened again today.

Device information and configuration:

Device: AP541N

H/W: V01

S/W: 1.9.1

Wireless: Channel 11, Key Refresh: 0, WPA Personal, TKIP

Log shows all the clients authenticating earlier in the day.

Hours later, I get a rash of:

Jun 21 10:30:43     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:xx had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:cc had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:bb had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:aa had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:zz had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:yy had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:xx had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:cc had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:bb had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:aa had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:zz had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:yy had an authentication failure.
Jun 21 10:30:13     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:xx had an authentication failure.

Followed by:

Jun 21 10:30:43     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:cc IEEE 802.11: deauthenticated due to inactivity
Jun 21 10:30:43     info     hostapd     The wireless client with MAC address 00:1b:77:94:dd:89 had an authentication failure.
Jun 21 10:30:43     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:bb IEEE 802.11: deauthenticated due to inactivity
Jun 21 10:30:43     info     hostapd     The wireless client with MAC address 00:18:de:4c:fd:26 had an authentication failure.
Jun 21 10:30:43     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:aa IEEE 802.11: deauthenticated due to inactivity
Jun 21 10:30:43     info     hostapd     The wireless client with MAC address 00:13:e8:f9:c9:f5 had an authentication failure.
Jun 21 10:30:43     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:zz IEEE 802.11: deauthenticated due to inactivity
Jun 21 10:30:43     info     hostapd     The wireless client with MAC address 00:21:5d:36:3e:c4 had an authentication failure.
Jun 21 10:30:43     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:yy IEEE 802.11: deauthenticated due to inactivity
Jun 21 10:30:43     info     hostapd     The wireless client with MAC address 00:16:6f:10:fb:9f had an authentication failure.
Jun 21 10:30:43     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: deauthenticated due to inactivity

Cycling the wireless switch on my laptop yields:

Jun 21 10:33:41       info       hostapd       wlan0: STA xx:xx:xx:xx:xx:xx WPA: group key exchange completed
Jun 21 10:33:41     info     hostapd     The wireless client with MAC address xx:xx:xx:xx:xx:xx has been successfully authenticated.
Jun 21 10:33:41     info     hostapd     wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key exchange completed (WPAv1)
Jun 21 10:33:41     info     hostapd     wlan0: IEEE 802.11 STA xx:xx:xx:xx:xx:xx associated with BSSID xx:xx:xx:xx:xx:dd
Jun 21 10:33:41     info     hostapd     wlan0: IEEE 802.11 Assoc request from xx:xx:xx:xx:xx:xx BSSID xx:xx:xx:xx:xx:dd SSID MYAPSSID
Jun 21 10:33:39     info     hostapd     wlan0: IEEE 802.11 STA xx:xx:xx:xx:xx:xx deauthed from BSSID xx:xx:xx:xx:xx:dd reason 4

I changed the channel from 11 to 9, and started having this occur like mad. I've got it at 3 now. It was odd, as last week, this only happened once early in the week, and was fine for the rest. Same thing this week as far as it happening early in the week.....

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: AP541N drops all clients

Thank you, Chris. I have notified the engineering teams. Your feedback will deifinitely help

us with a permanent solution.

Stephanie

20 REPLIES 20
Beginner

Re: AP541N drops all clients

Thanks for your e-mail. I am on vacation and will respond on my return. If you need help in my absence, please call the office at 215-968-7577. Peter.

Re: AP541N drops all clients

Just to update this. Since changing the channel, this has yet to happen again. So perhaps that was the fix. Quite bizarre.

Re: AP541N drops all clients

Well, this has just happened again this morning. Same experience. Cycling the wireless switch on the notebooks reconnected them.

Cisco Employee

Re: AP541N drops all clients

Re: AP541N drops all clients

Thank you. I am putting this on my personal AP541N now to test.

-Chris

Re: AP541N drops all clients

Had it happen again.

After a discussion with Cisco, I changed the config from WPA/TKIP to WPA2/AES to match my personal AP541 and have yet to have it repeat. This may have fixed it. Of course this would then also point to a software issue.

I'll be giving it a few weeks of testing to make sure.

-Chris

Cisco Employee

Re: AP541N drops all clients

Thanks, Chris. Please keep us informed on the results.

Stephanie

Re: AP541N drops all clients

Two weeks and not a single drop.......

I'm going to say the change from WPA/TKIP to WPA2/AES fixed it.

So this would definitely be a software bug then.

-Chris

Re: AP541N drops all clients

Stephanie:

We are now into September. Not a single disconnect since the security settings change. Can we flag this as some sort of software bug you guys can follow-up on? Since there was, and is obviously nothing wrong with the hardware. It works perfect with WPA2/AES.

-Chris

Cisco Employee

Re: AP541N drops all clients

Thank you, Chris. I have notified the engineering teams. Your feedback will deifinitely help

us with a permanent solution.

Stephanie

Cisco Employee

Re: AP541N drops all clients

Hi Chris -- Our engineering team would like to get some more information from you on this issue and your experience. If you're willing to share, would you please send me email 'streavesatciscodotcom' and include your contact information?

Thanks,

Stephanie

Beginner

Re: AP541N drops all clients

Hi there,

Switching to WPA2/AES only didn't help me. Any other thoughts?

Re: AP541N drops all clients

I would say your issue is different than mine then. This AP is used in a business environment and has ~20 PC's connected to it. Since the change to WPA2/AES, it hasn't dropped a single client and has been rock-solid.

Product Identifier:AP541N-A-K9
Hardware Version:V01
Software Version:AP541N-K9-1.9(2)
Serial Number:
Device Name:AP541N-A-K9
Device Description:802.11n Dual Band Access Point - Single Radio
System Uptime:139 days, 22 hours, 40 minutes
System Time:Thu Jan 6 2011 22:05:55 EST

Beginner

Re: AP541N drops all clients

FWIW I made two changes - either of which may have resolved the issue. So far no drops after about a day of limited usage.

The changes I made are:

-- disabled 802.11d regulatory support

-- switched from b/g/n to only b/g

I'm guessing it's moving away from N that fixed it but don't understand why that would matter.