cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

19474
Views
0
Helpful
67
Replies
cascoli_2008
Beginner

AP541N wireless clients sporadically not acquiring dhcps

I was having this issue with my Dell Precision M70 laptop until I made this tweak to the Intel Pro Wireless 2200BG card that is built-in and so far its seems to be making a difference with it connecting to our Cisco 541L APs and acquiring a DHCP from our network.  However, the only thing different I noticed after making this change is that it is initially a bit slow at connecting to the Cisco APs.

http://www.intel.com/support/wireless/wlan/sb/cs-006205.htmUse Intel® PROSet/Wireless WiFi Connection Utility to Set CAM1.     Click Advanced > Adapter Settings > Advanced tab. 2.     Select Power Management and uncheck Default / Auto and move the slider to Highest / Maximum Performance.If the slider is already at Highest / Maximum Performance, move the slider to another setting and then back to Highest / Maximum Performance.


We are still experiencing this issue with our Dell Latitude E4200 laptops but need to verify that they are using the latest wireless network adapter drivers.  In addition, I am planning to tweak the PSP as I did with the Intel Pro Wireless 2200 BG.

F.Y.I. Our PDC and Primary DNS server is a Windows Server 2000

         Our BDC, Secondary DNS and DHCP server is a Windows Server 2003

Any help or suggestions would be greatly appreciated!

Sincerely,

Carmine

67 REPLIES 67

Hi Christopher:

We can I download version 1.9.1

Thanks,

Carmine

Hi Christopher,

I know that this is an old thread but I was wondering if you have found any more issues with your AP's.  The reason I ask is that we bought 6 of these with firmware version 1.9.0 already installed on it and have since upgraded two times to the current firmware (and performed factory reset) and we are still having issues.  At first, after speaking with support for the fifth time I thought it may be the switch.  I have since replaced the ESW-540 switch with an SG-300 (for free) and am still having the same issues where the clients will all of a sudden not be able to pull DHCP.  It's driving me crazy and the clients are beyond pissed.  Funny though, Cisco Small Business support had never even mentioned that they'd heard of this before and I've created so many cases about it.

Since I found your thread I have disabled the key refreshing on the VAP's, and disabled the Broadcast/Multicast Limit Rating.  I hope that works but I just wanted to see if you or anyone else was still experiencing issues with this.

Please let me know.  Thanks!

DHCP server is from a SonicWALL NSA 240.

Hi Christopher:

This sounds like an issue with the DHCP server on the SonicWall.  I would contact those folks.

Best Regards,

Carmine

Nope....the SonicWALL has no problems passing DHCP to the LAN.  It's only through the AP's where the problem comes in.  Also, we had a Cisco 1241 on the same network and have no issues with that.  I had the same issue in another location with the AP541n and a Cisco 871 router.  Finally got rid of that AP but in this location I can't get rid of all the AP's without losing a lot of money. :(

I was having an issue with them dropping clients (different issue) but that was with WPA/TKIP. Moving to WPA2/AES fixed that one (yes, that's a bug for sure!).

I have a few of these in the field with a number of different devices providing DHCP:

1. Cisco 1841

2. IPCop Linux box

3. Cisco 871 (two AP541's behind this one)

And I have not encountered any issues with DHCP. Just the wireless client disconnect issue I mentioned above.

If you set the clients to a static IP when DHCP stops working, can the client function normally?

Thanks for the reply Christopher.  Yes, when I set a static IP the clients perform as expected.  It is only after some time that they will stop getting IP's from DHCP.  Wired clients are completely unaffected.  I have yet another case going with Cisco right now on this one.  Hopefully once and for all we can come up with a solution to this issue.  It has gone on for far too long.  Thanks again!

Hi all,

What I'm affraid of is that the lastest firmware (1.9.2) seems to be compliant with V2 hardware only...

And wheareas the release notes for 1.9.1 firmware annonce the problem about broadcast/multicast frames as solved (the one that avoids DHCP from working properly), It has not solved anything for me !

So... will there be some more firmwares for V1 hardware or must we just get rid of those unreliable APs ?

Can we change for free our V1 for V2 harware platforms ?

And first... does V2 hardware works properly ?

To be clear, I've switched my APs from another brand to cisco thinking this would be the end of all my harware problems... but it is worth !

My company will be relocated soon, I'm in charge of choosing the network hardware... I was about to invest in a full cisco solution but what I've experienced with theese test materials really makes me wonder if this is a good choice...

Hi Steve.

You are welcome.  I believe Vincent already tried to disbabling the Broadcast/Multicast Rate Limiting and it only worked for certain clients for him.  However, you could try it as an experiment.

Best Regards,

Carmine

AP541N version 1 hardware is the only available hardware and is compatible with all firmware versions up to and including 1.9.2. I've checked with product engineering and there are no reported reliability issues with version 1 hardware. Please stay tuned for version 2.0 firmware to be released in the coming months.

Download firmware version 1.9.2

Release Notes for firmware version 1.9.2

Please contact the Small Business Support Center for persistant issues and thank you for participating in the Community.

Stephanie Reaves

Cisco Small Business Technology Group

Hi Stephanie,

Thanks for your response but...

- the link you provide for 1.9.2 firmare release notes seems broken... I got the following message :

"The file or application you are trying to access may require additional entitlement or you are trying to access a file with an invalid name. Additional entitlement levels are granted based on a users relationship with Cisco on a per-application basis."

- the release notes I could find by myself ( http://www.cisco.com/en/US/docs/wireless/access_point/csbap/AP541N/release_notes/78-19182.pdf ) says :

"Devices with hardware version ID (VID) V02 only support firmware version 1.9.2"

I agree to say that this doesn't mean that V01 platforms does not support 1.9.2 firmware (as this point was not really clear I didn't take risks... furthermore, release notes says that this version doesn't close any additional caveats as compared to the 1.9.1...) but to my mind it tends to proof the existence of V02 platform... so where is the truth ?

I've recently invested in a Cisco Small Business RVS 4000 router thinking it would be fully compatible with my four AP541N (all under 1.9.1 firmware) witch would at last relay DHCP frames as required but I still got the problem... So be sure I'll stay tuned for version 2.0 firmware !

Regards

Vincent

Hi Vincent --

Couple of different things here:

AP541N firmware does not require any kind of login. Likely a cookie issue. Clear your cache and cookies, open a new browser and try download again, please.

V2 hardware is not available but can definitely see how the Release Notes are misleading. Product Management is taking steps to clarify the Release Notes now. Sincere thanks for pointing this out to us.

Please send me email (streaves at cisco dot com) so I can share a couple of other options.

Thanks,

Stephanie Reaves

Cisco Small Business

Hi Vincent and Stephanie

     I can confirm that my site is seeing this issue as well.  We have tested with Dell Notebooks, Apple iPhones (3GS and 4), Apple iPad, and BlackBerry devices.  Network caputure traces show that the DHCP Client never recieves the DHCP ACK from the server and thus does not acquire an IP address.

The only resolution for this at the moment is to restart the AP541N.  This issue has been verified under firmwares 1.8.0, 1.9.1 and 1.9.2. 

Reguards

Shaun

Currently the DHCP ACK issue was resolved with firmware 1.9.2. If you are still having a similar issue please call in to Cisco Small Business Support so we can properly troubleshoot the issue. Please have a detailed Network topology, including Channels used Number of AP's, What is giving DHCP out, number of SSID's and Vlans. If you have traffic monitoring tools this will also help the TAC engineer in finding the root cause, or being able to diagnose a bug. Currently though no bug for DHCP is known by Cisco for the AP541N running firmware 1.9.2.

Thanks,

Randy Manthey

Cisco Small Business Support

We have 17 AP541N (FW 1.9.2) and we have the same problems. Sometimes - after 3 hours to a day - some of the AP stop working properly. The WLAN-clients are connected to the AP but they get no IP from the MS DHCP server. We have no issues on clients which are connected via wired LAN. Only a reboot of the AP solves the problem and then the WLAN-clients get an IP. We decided to buy Cisco-APs because we thought Cisco products do not perform such issues...

Regards, Mario