cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

2603
Views
5
Helpful
15
Replies
Highlighted
Beginner

WAP121 40MHz Operation

Hello all,

A while ago I purchased a Cisco WAP121 for dedicated use by my two 802.11n laptops only, hoping to enjoy maximum speed for transferring files etc. All other devices use an older 802.11b/g access point. I live in a remote area so there are no other wireless access points active on the 2.4GHz band.

My laptop has an Intel Centrino Advanced-N 6230 network adapter, with the channel bandwidth for 2.4GHz set to "Auto" and fat channel intolerant set to "Disabled". I have verified 300Mbps operation on other access points without any issue.

The 802.11b/g access point is fixed on channel 3 and the WAP121 is fixed on channel 13. The WAP121 is set to channel bandwidth "20/40 MHz" and mode "2.4 GHz 802.11n". As far as I know, the theory is that the WAP121 should operate in 40MHz mode provided there is no other access point active near the primary WAP121 frequency. Indeed, when I boot up the WAP121 it operates in 40MHz mode, however, shortly afterwards it falls back to 20MHz, as verified on the WAP121 "Network Interfaces" page and with inSSIDer software on my laptop. As I type this message, channels 6 to 10 are all free... When the WAP121 does operate in 40MHz mode the secondary channel is channel 9 (as expected).

Is this normal behaviour or is it an issue with the WAP121? Is there a fix?

Thansk in advance

Everyone's tags (1)
15 REPLIES 15
Hall of Fame Master

Re: WAP121 40MHz Operation

What I would do is set your b/g AP to channel 1, set your WAP121 to channel 6 using the Upper Channel (11 would be primary). I would also make sure that you either use open authentication or WPA2/AES and make sure WMM is enabled.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Beginner

Re: WAP121 40MHz Operation

Hi "Scott Fella",

Followed your advice and set the 802.11b/g AP (Cisco 1130AG) to channel 1 and WAP121 to "upper channel", with 11 as the primary channel. Encryption was already set to WPA2/AES and WMM was also already enabled. Again, after a reboot, the WAP121 operates in 40MHz mode for a while, and then falls back to 20MHZ. New channels confirmed with inSSIDer. What I also found is that the link speed drops dramatically for a few minutes (we're talking 1-2Mbps) after the WAP121 switches from 40MHz to 20MHz. Setting the WAP121 channel bandwidth to "20MHz" fixes that problem, but that's not why I bought Cisco 802.11n AP... I'm on my second WAP121 and the behaviour is identical, so I'm wondering if somebody else is experiencing the same issue?

Beginner

Re: WAP121 40MHz Operation

Hello Aber,

     I've always heard other users reporting that there mbps would randomly drop to 1-2mbps but as for the 40mhz switching randomly to 20mhz, that I'm not too sure about. Is there an option to always leave it on 40mhz? Can't remember on this one. I'm not sure if Cisco ever reported this as a bug or not though with the 1-2mbps but I know the last time I checked (which was a couple months ago), they stated they couldn't replicate the issue through escalations but to me it looked like a bug.

I would check the release notes and be on the latest firmware if you aren't already and see if they may have gotten a fix for it. I've always saw it as a bug even though escalation never saw it this way and this always seemed to happen only with the WAP121 and not the WAP321.

Hope that helps you out,

Thanks,

Clayton Sill

Rising star

Re: WAP121 40MHz Operation

Hi, My name is Eric Moyers. I am a Network Support Engineer in the Cisco Small Business Support Center. Thank you for using the Cisco Community Post Forums.

Unfortunately that is normal behavior. As a condensed explanation - When running in 40Mhz mode, if another signal is detected within either channel that the 40 Mhz is operating in the router will drop down to 20 Mhz. It is sometimes referred to as a good neighbor policy.

If anyone would like a can provide a more detailed answer.

Thanks

Eric Moyers    .:|:.:|:.

Cisco Small Business US STAC Advanced Support Engineer

CCNA, CCNA-Wireless

866-606-1866 ext 601027

Mon - Fri 09:00 - 18:00 (UTC - 05:00)

*Please rate the Post so other will know when an answer has been found.

Beginner

Re: WAP121 40MHz Operation

Hi Eric,

Thanks for your reply. I am aware of the "good neighbour" policy and am in support of that behaviour, However, as you can read in my earlier posts, there is no other AP active in the WAP121 40MHz range (verified with inSSIDer), so it shouldn't be falling back to 20MHz. My other AP is a Cisco 1130AG which is fixed to channel 1 and the WAP121's primary channel is fixed to 11 (so second channel should be 7). It would be good if the WAP121 could log why it decides to switch back to 20MHz. I have enabled various logging options but am not able to achieve this. Hopefully you can help.

Thanks,

Pieter

Beginner

Re: WAP121 40MHz Operation

Hi Clayton,

Thanks for your reply. First of all, there is no option to force the WAP121 to use 40MHz, as this wouldn't be compliant with the 802.11n specification (the "good neighbour" policy Eric is referring to). With regards to the severe drop in speed, the WAP121 has done this randomly since I bought it back July next year (or at least, it seemd that way!), but it is only recently, when I started to look into the 40MHz issue, that I found it happens when the WAP121 switches back from 40Mhz to 20MHz. If somebody else could replicate it then hopefully Cisco will be able to fix this bug. As stated in my orginal message, the workaround for me is to keep the WAP121 in 20MHz mode only.

Cheers,

Pieter

Rising star

Re: WAP121 40MHz Operation

I agree, would be good to have the device log why it is backing down to 20 Mhz. I also found it interesting on your observation about the speed reduction happening when the device drops from 40 to 20. I will be bringing that up at the next Level 2 meeting when we meet.

In the mean time, as far as why it drops. There are more things than just APs that broadcast a 2.4 signal. What kind of environment is your device in? (Phones, Microwave ovens, Video Devices(Video senders typically operate using an FM carrier to carry a video signal from one room to another (for example, satellite TV or closed-circuit television). This is just a small list but some of the highest offenders. Not saying this is the reason, but something to look for.

Eric

Beginner

Re: WAP121 40MHz Operation

Hi Eric,

Like most other households we do have DECT phones and a microwave at home, but the DECT phones operate in the ~1.9GHz range and the microwave is only used a couple of times a day. We also have a baby monitor which operates in DECT-mode at 1.9GHz, so again shouldn't be a problem. Anyway, I suppose the best way to determine whether it is a WAP121 issue or an issue caused by he environment the WAP121 operates in, is to try a 802.11n AP from a different vendor, set it up the same as the WAP121 and then see what happens. I obviously don't want to buy another AP so I'll see if I can borrow one from somebody and get back to you.

Thanks,

Pieter

Beginner

Re: WAP121 40MHz Operation

Hi Eric,

I've not had a chance yet to try a different 802.11n access point in my environment, however, what I did do as a test is disable the 802.11g radio in my other 1130AG access point to see if it makes any difference. Interestingly, the WAP121 does NOT fall back to 20MHz mode, i.e. it remains in 40MHz mode. When I switch the 1130AG 802.11g radio back on, the WAP121 falls back to 20MHz soon after. As stated above, the 1130AG 802.11g radio is set to channel 1 and the WAP121 to channel 11, so there is no overlap in 20MHz and 40MHz mode. There are no other APs active (verified with inSSIDer), so this definitely seems a bug to me. What are your thoughts?

Regards,

Pieter

Rising star

WAP121 40MHz Operation

I noticed you mentioned channel 13 at one point. Whee are you located?

Eric

Beginner

WAP121 40MHz Operation

Hi Eric,

I'm in the UK, so channel 13 can be used here. However, based on the advice from "Scott Fella" I put it back to 11. Not that it matters because there is nothing else operating near that frequency.

Pieter

Beginner

WAP121 40MHz Operation

Hi Eric,

I was just having a look at the latest firmware release notes and as a resolved issue for the 1.0.3.4 firmware it states:

"CSCub46649—While operating WDS Bridging using a 2.4 GHz band with a 20/40 MHz channel bandwidth, the WDS links may disconnect. The radio can change from 40 MHz to 20 MHz if any 20 MHz devices are detected in the area, resulting in a mismatch of channel bandwidths throughout the WDS devices."

I note the bit any 20 MHz devices. Could this be related?

Rising star

WAP121 40MHz Operation

It is my understanding that any signal in the correct bandwidth and frequency could cause this.

Not as an endorsement, but tools such as Wi-Spy, a sprectrum Analysis tool, could help find any of the non-wifi interference problems.

Eric

Beginner

WAP121 40MHz Operation

Hi Eric,

Just had a look at Wi-Spy and although it looks interesting, as a home user I'm not planning on spending that amount to do a test. Also, I really don't think interference is the issue because when I switch the 1130AG 802.11g radio off, the WAP121 remains in 40 MHz mode.

So... what do we need to do for Cisco to recognise this as an issue which needs to be addressed? Can you try and replicate the same setup at your end (same equipment/firmware etc)? Is there any point in me trying an AP from a different vendor in the same location to see how it behaves? Can you have a chat with the relevant engineers about the 40 Mhz WDS brdige issue which was resolved with the 1.0.3.4 firmware update, just to check whether this issue could be related?