cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

4042
Views
0
Helpful
14
Replies
stephenott
Beginner

WAP321 Captive Portal and iOS 6

Our iOS6 devices cannot connect to our Cisco Wi-Fi access points using our guest network settings, which involves a captive portal where they must enter their email address. When they select the guest network, they get the screen shown at the bottom of the screen. Prior to iOS6, they'd get the web page where they enter their email address and accept our terms of use. This is happening both on upgraded devices and iPhone 5 devices. We haven't changed anything with the access points.

photo.PNG

14 REPLIES 14
masterjsm
Beginner

Same problem happening to me. just did a new installation with 10 access points and this is what happened. Posted in other discussions and no fix has been given as of yet.

Jeff

jkarsten4
Beginner

I have the same Problem with iOS 6. Windows 7 works fine with IE. Android too.

Only iOS 6 brings the 404 after i tried to connect to the wlan.

Its a new wap321 with 1.0.1.10

Jörg

We tested with iOS6 and it works here. We just have to make a new web request. Just opening safari doesn't do anything, it just sits there.

When we opened a new tab or page, then tried going somewhere, it worked.

It doesn't however, as the image shows, do the auto popup of the logon. If I was trying to get on wifi and use an app, this would be a huge thing. Still needs some work.

When i connect to the wlan with the cp then a popup comes on top.

I click the Homebutton and change to safari but the wlan was changed to a second one or will disconnect.

jkarsten4
Beginner

I have now the update for ios 6.0.1 installed.

When i connect to the WLAN the 404 page comes again.

Gaillard
Beginner

Exactly same problem! Somebody try to open a case on cisco? Its a very important issue!!

I have opened a case with Cisco and went over all the testing I have done. (

Devices on 5.1.1 or under work, IOS 6 and above do not.)

Here is their response:

"We were able to replicate the issue reported in our labs and our software developers are working towards a resolution"

I have also called Apple and they suggest having all the clients restore their devices to factory defaults and trying again haha.

I will keep you posted when I hear back from the Cisco Engineers.

For sure the problem is on Apple side.. But! Maybe cisco can add a function  to grant some URL bypassing the catpive portal. So we can add somes URL like intranet http://sharepoint.myserver.local or www.apple.com/library/test/success.html

It will be a good function...

FYI i try to connect with some Samsung Galaxy device! SAME PROBLEM !!! BUT on samsung device we can go to the portal page connecting on the local AP adress then we can access internet...

Andy Kinnard
Beginner

This issue has persisted for far too long without redress.

To anyone experiencing this issue: there is no fix.  Please establish a Cisco ID, call Cisco and get a ticket #.  Report it here or on the other two related threads at
https://supportforums.cisco.com/thread/2163439 and

https://supportforums.cisco.com/message/3836229

It seems that they are only going to fix this issue if the number of support tickets reaches a sufficient number...apparently long-standing, well-supported outcry on the forums is wholy insufficient to inspire actual resolution.

New Firmware fixes this issue.

It will be released soon. I have just tested it with iphone 4s & ipad on ios 6.1.

flallart1
Beginner

I have this problem too, it redirects to the admin web interface, no one can log into guest network. Using firmware 1.0.5.3 and windows/IE/firefox or linux/opera/firefox.
flallart1
Beginner

I opened a ticket (633806647, french language) with Yordan Strahinov, he told me the captive portal will only work in the same vlan as the management vlan ... that's kind of a nonsense, but it works.

My name Eric Moyers. I am an Engineer in the Small Business Support Center.

I am sorry to hear that you are experiencing this issue. 

While what I am fixing to share is not in any way a great solution, It can be utilized as a workaround.

With the WAP321, after trying a few different scenarios that didn’t work. I simply created two vlans, leave the Untagged vlan as main vlan and changed the Management vlan to the second. I then attached the guest SSID to the Management VLAN. This allowed me to authenticate to my guest captive portal and get an IP and get out to the internet. The Main SSID still worked normally.

Now for some caveats:

Problem: If a wireless client knows the IP of the WAP and the username and password they could get into the WAP.

Solution: Setup Management Access Control to an IP outside the DHCP scope for that VLAN and have a Strong Password.

Problem: Management of the WAP321 can only be from an IP on the Management VLAN. (In my case 2)

Solution: Setup Management Access Control to an IP outside the DHCP scope for that VLAN and have a Strong Password.

Not the very best solution, but the only workaround I can come up with for now.

Eric Moyers
.:|:.:|:. CISCO | Cisco Presales Technical Support | Wireless Subject Matter Expert

Please rate helpful Posts and Let others know when your Question has been answered.