cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3849
Views
5
Helpful
9
Replies

Smart Call Home Transport Gateway Java requirements

kstolle
Cisco Employee
Cisco Employee

The Transport Gateway user guide indicates Java version 6 is required, "Java 6 to be installed before starting TG installation." Will it also work with later versions?

9 Replies 9

Kelsey Loftin
Level 1
Level 1

Hey kstolle,

Thanks for asking. You can try Java 7, but if you face any issues, we suggest you revert to Java 6. We are planning to support Java 8 in coming releases.

Cheers,

Kelsey

I am facing issue while installing transport gateway on windows 2012 server it shows executing installation script but never ends.

Hello, and thanks for your question.

This might be due to the fact that the Transport Gateway does not have the privileges to create a temporary folder as Temp. We have given the resolution in our troubleshooting section of user guide (pages 4-27), and it is copied below:

The Fix

  1.  Kill the installation on wizard using Windows Task Manager.
  2. Create a folder with name ‘Temp’ in the path: C:\Windows\system32\config\systemprofile\AppData\Local\
  3. Install TG again. On the Installation wizard, click Re-install

Let us know if you have any additional questions,

Kelsey

Hi,

Thanks for your solution. I tried this when I had this issue for the first time but still it is stopping at executing installation script.

Thank you. At this point, this issue would be better handled by your account team. They have more experience with your network configuration, and any questions we ask to further diagnose the problem would require you to share sensitive data.

Please escalate to your Cisco Account team so that we can provide you the proper level of support.

Thanks again,

Kelsey

Hello,

Any news on this please?

I see the requirements say Java 8 - but which update release?

Also, as Java has as many if not more security issues than flash (holes in sieve) will there be a time when java is not required?

Neil

Kelsey,

Thanks for the reply. Java 6 has a major security vulnerability that was announced in 2013. Oracle stopped updating Java 6 in February of 2013. The lack of certification for later releases is a show stopper for installation of the Transport Gateway software.

Thank you. We are aware of this, and we are currently working on a Transport Gateway release that supports Java 8. The Support Forum and this thread will be updated when the release is available.

Thanks again,

Kelsey

Roberto Rizo
Cisco Employee
Cisco Employee

Hello

I have a problem when registering the TG in a windows 10 home single language it gives me the following error "some error occured while sevicing the request", I uninstalled the windwos defender and also the antivirus, the users are correct. Any recommendation?