Showing results for 
Search instead for 
Did you mean: 

Upgrade to (Yes, again)

Beginner to latest upgrade ( currently) just not happening. I've read a couple dozen or more articles on it being stuck in Downloading status in the GUI, and showing downloading in the CLI. I cannot seem to get it to work.  I've cleared the /opt/LCM/tmp/downloads of files, and re-downloaded successfully (and watched the file sizes stop growing in the CLI). restarted the services, access CLI with collectorlogin (changing to root)..even tried the manual deployment doc (but cannot get ./ to work from anywhere).


What in the world am I missing? This cannot be this ridiculous to upgrade every time can it?

8 Replies 8

Supriya Patel
Cisco Employee
Cisco Employee

Hi Adam,


I believe you must be using below document on manual upgrade.


Let's find out where you are stuck. You mentioned that you were able to download successfully. Could you please provide me below from user 'root'?


if you are on step 4 (pg 7) from guide and able to unzip successfully, then you will see, and To check this, please do below and share output


Once you are in root, type

# cd /opt

# ls -l


As well, please do let me know, what do you see when you run below command from guide. Please share output for further analysis.


[root@localhost opt]# ./ JeOS





So several things here - and not sure how I could have done it incorrectly, but...


1) The .zip file is in /opt/LCM/tmp/downloads - not in /opt

2) Copying the .zip file to /opt as suggested is done.

3) Extracting the .zip file in /opt is done.

4) ./ JeOS doesn't work until you drill down into the unzipped directories into 'Preinstall'.

5) Running ./ JeOS from here produces:


[root@ofgciscocollector Preinstall]# ./ JeOS
hostname already present
Checking CSPC server status
CSPC server started
Please update to latest jeos patch first and then install this patch.



More information:

admin# show version -d
Build-name : Collection Platform Software

Package-type : ServicePack
Version : sp-30.0.3-2-0-lnx64
Component : CSPC Base
Version :
Package-type : JeOS
Version : jeos-30.0.3-2-lnx64
Component : ConcsoTgw
Version : 1.7.0
Component : AdminShell
Version : 1.6
Component : Hardened CentOS
Version : 6.8 patch#0
Component : LCM
Version : 1.6
Component : CASP
Version :



admin# check update

Patch versions
Version Number: sp-30.0.4-2-0-lnx64
Description: Collector patch to upgrade to CSPC
Required Versions: sp-30.0.4-0-0-lnx64
Optimal JeOS: jeos-30.0.4-2-lnx64
Reboot Needed: Yes
Restart Needed: Yes
Package Size: 108932255 bytes
Component Name: Rules Pack
Version: 4.6
Description: 4.6
Component Name: CSPC Base
Description: CSPC
Installable: Yes


Running the same ./ JeOS the CSPC directory produces a ton more action, clipping for brevity:


add-ons/agent/lib/pari_api-2.7.jar .. unpacked
add-ons/agent/lib/schema-2.7.jar .. unpacked
add-ons/agent/module-registry.xml .. unpacked
PASSED BASE DIR = /opt/cisco/ss/adminshell/applications/CSPC/ppm/bin/../patches/cspc_cp_2.7.4
BASE DIR = /opt/cisco/ss/adminshell/applications/CSPC/ppm/patches/cspc_cp_2.7.4
----End of init----
----Begining of setProperties----
----End of setProperties----
----Begining of runTarget----
----log file location :/opt/cisco/ss/adminshell/applications/CSPC/logs/ppm_logging_cspc_cp_274_1531147257676.log
----Please wait for few mins for installation to complete......
Getting process exit code


Tried again...looks more promising:


Getting process exit code
Getting process exit code
INFO | Cspc Helper Server : Waiting to make sure that main process is started.............
INFO | Cspc Helper Server : Connection to main server established.
INFO | Cspc Helper Server : Waiting to make sure that main process is started.............
INFO | Cspc Helper Server : Tomcat port 8001 is established.
INFO | Cspc Helper Server : Tomcat port 8001 established.
----End of runTarget----
Number of JVM Arguments 2:RETURN VALUE IS : 0
CSPC is upgraded to 2.7.4 return successfully
Checking CSPC status......CSPC server started
Adding remotelogin user for RMC
remotelogin exists!
[root@ofgciscocollector CSPC]#

No idea what to do with it now.  Both manual upgrade items said they updated successfully...but nothing has changed. I *really* don't want to start all over, deploying a new system because this won't update properly. 

Hi Adam,


Following will help to check upgrade progress. Complete upgrade, apply JeOS and SP ,can take more than 1 hr. Once JeOS is completed, we need to follow SP from same document. Please give me output of following from user root, so I have more idea where we are.


# tail -f /opt/LCM/logs/apply



This is where it is:


[root@ofgciscocollector ~]# tail -f /opt/LCM/logs/apply
[Wed Mar 7 19:40:32 EST 2018] --SP--SP--SP |SP | |sp-30.0.3-0-0-lnx64 |Service Pack maintenance update |1520468855--sp-30.0.3-0-0-lnx64--
[Wed Mar 7 19:40:32 EST 2018] else block of status update
[Wed Mar 7 19:40:32 EST 2018] update version--sp-30.0.3-2-0-lnx64--
[Wed Mar 7 19:40:32 EST 2018] status db updation completed
inside while loop
Inside status_update script
Status of package : Applied
Timestamp : 1520462997004
Updating updates db
Deleting entry from orderedList db

Hi Adam,


./ JeOS - even thought it started installing JeOS for 2.7.4 but  tail output shows successful running and completed so it seems confusing. For more clear understanding, I have requested more outputs via private message, please send over for further analysis.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers