cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.

653
Views
19
Helpful
53
Replies

CSPC losing connectivity

Hello,

I installed a CSPC Virtual appliance last week, and now that I am setting it up and running discoveries and collections, I am running into an issue.  After a few hours, something happens on the server, and I am unable to run jobs, or configure anything in the web interface.  An error box pops up, and it is just a red X with OK.  When I go to server properties, all the IP information is gone, but if I ssh to the appliance and do a show ipconfig, it shows everything is connected.  It's as if the connectivity between the web interface and the server is disconnecting.  Is there anything I can run on the server to troubleshoot this?  We built the server from an OVA downloaded from Cisco's website, and it automatically setup all the vmware settings.

Thanks,

Mike

53 REPLIES 53
Cisco Employee

Hi Mike,

Hi Mike,

When the error box pops up, you are correct in saying that the web interface is no longer able to communicate with the server. This usually happens when the CSPC services stop or restart, or if there is an issue with Tomcat.

If you SSH into the server and run the command:

sudo service cspc restart

it will stop and start the CSPC service.

As for why it's shutting down in the first place, I'd recommend running a continuous ping on the collector to determine the circumstances where it fails. There could be an IP conflict with another server that is being powered on and off.

Thanks,

Lynden

Whenever it happens, I still

Whenever it happens, I still can ssh to the server, and the web interface is still accessible, just that I can't really do anything.  Our vmware person noticed that the network adapter on the virtual machine is setup as flexible, as opposed to E1000 or VMXNET.  What is the recommendation from Cisco about changing vmware settings, or installing vmware tools?

Cisco Employee

I see. The reason you can

I see. The reason you can seem to still use the web interface is because it is cached, the connection has actually been severed. It sounds like Tomcat is going down for some reason. The network adapter shouldn't matter, especially if you can still SSH in. You can play around with the settings if you think that will help.

If you SSH into the Linux side of the server (using the "collectorlogin" username) then you can tcpdump and listen on port 8001 to see if the web service is going down.

Can you provide me with the

Can you provide me with the syntax to perform a tcpdump?  I'm not a linux person, and am unsure the command to do this.  The collector continues to drop multiple times a day.  Resetting the tomcat service using the command you provided fixes it, but I shouldn't have to go in multiple times a day and reset it.  Thanks.

Cisco Employee

tcpdump port 8001

tcpdump port 8001

should show you what you need. Just leave it up for a while and try to catch it when it goes down.

Thanks,

Lynden

It returns no suitable device

It returns no suitable device found.

Any other suggestions how to

Any other suggestions how to get this command to work, or how to fix this issue?  When I am using the collector, I have to reset this service multiple times in order to get discoveries and inventory collections to work.  Thank you.

Cisco Employee

Hi Michael,

Hi Michael,

try:

netstat -tulpn

It should display the processes and ports.

You can post a screenshot of what you see here once it goes down.

Thanks,

Lynden

Having connectivity issues

Having connectivity issues and this is the output.

Cisco Employee

Hi Michael,

Hi Michael,

If you run the service cspc restart command, does the output look differently? I can see there at the server on 8001 but I don't see the program listed in the pid column.

Thanks,

Lynden

Looks the same.

Looks the same.

Cisco Employee

Could you send me a

Could you send me a screenshot or some more details about how the VM was set up? Is it possible you used the ISO instead of the OVA? The only other thing that comes to mind is that the server is shutting down Tomcat silently because it is running out of memory.

We used the OVA.  This is the

We used the OVA.  This is the one we downloaded from Cisco - SNTC-CSPC2.5.2.1-OVF10.ova.  Attached is a screenshot on how it setup the virtual machine.

Cisco Employee

Is there anything in

Is there anything in particular you're doing when it goes down? Do you have any recurring discoveries or inventories scheduled, and what are the intervals of those?

CreatePlease to create content
Right-rail
Navigation
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links