cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.

1172
Views
0
Helpful
12
Replies
cpadiak10
Beginner

CSPC VM upgrade 2.5.2.1 to 2.7.4

I want to upgrade our CSCP from 2.5.2.1 running on a VM to 2.7.4.   The CSPC Collector Platform Software Upgrade User Manual shows the upgrade path as: 2.5.x > JeOS (jeos-30.0.0-0) > SP 2.7 > JeOS (jeos-30.0.4-0) >  SP 2.7.4.  Looking in the Downloads I only see jeos-20.1.2-0-lnx64.zip.  Is the file mentioned in the User Manual (jeos-30.0.0-0) not publicly available?  Or do I upgrade from 2.5.2.1 directly to jeos-20.1.2-0 and then apply the SP?  One caveat I have is that I am not able to access the GUI, although I do have access to collectorlogin and root on  the CLI.

1 ACCEPTED SOLUTION

Accepted Solutions

Hello,

Can you please try to manually download and apply the 2.7 and 2.7.4 patches?  We have recently released a document which helps cover the steps needed.

 

https://www.cisco.com/c/dam/en/us/support/docs/cloud-systems-management/common-services-platform-collector-cspc/CSPC-Manual-Upgrade-Guide.pdf

 

2.7 Patch

2.7.4 Patch

 

Thank you,
Jarrett

 

View solution in original post

12 REPLIES 12

Hello,



If you have access to the CLI "admin" username, you can run the command "check update" to see the latest 2.7.4 patches are available. It will also automatically take care of any patches that are required for download/install between the releases when applying.



Thank you,

Jarrett


Jarrett,

   I do have access to admin although when I try the check update command and enter my CCO credentials it returns "Validation of credentials failed. Please try again."  I have ensured that I am entering my CCO username and password correctly.

   Is there another method to download/install the required releases?

 

Thank you, CJ

 

 

Hello,

I believe that may occur due to the older images making use of www.cisco.com through 72.163.4.161.   Since this hostname/IP was statically added to /etc/hosts for CSPC, it has to be removed manually to resolve the issues.  The steps for removal were added to 2.7.3.2 release notes here.   Can you please try these steps and see if it helps to resolve your issues?

Thank you,

Jarrett

Jarrett,

   I have removed the 72.163.4.161 entry and I added our conf dns -a x.x.x.x to the hosts file. Check update now succeeds:

admin# check update
Update level: All
===================

Major Versions :
----------------------

    Version Number:         sp-30.0.0-0-0-lnx64
        Description:        Collector patch to upgrade to CSPC 2.7
        Required Versions:  -
        Optimal JeOS:       jeos-30.0.0-0-lnx64
        Reboot Needed:      Yes
        Restart Needed:     Yes
        Package Size:       698705919 bytes
        Contents:
          Component Name:   CSPC Base
            Version:        2.7
            Description:    CSPC Base 2.7  

admin#

 

   Also, isn't sp-30.0.4-0-0-lnx64 the 2.7.4 version?  Because the upgrade path says that if I am running 2.5.x I first need to go to 2.7.  Wouldn't 2.7 be 'sp-30.0.0-0-0-lnx64' and not 'sp-30.0.4-0-0-lnx64'?

   I am confused because now the guide now tells me to 'download sp-30.0.4-0-0-lnx64' from root but it returns 'bash: download: command not found'.  Even if the download command did work, shouldn't I download and apply sp-30.0.0-0-0-lnx64 prior to sp-30.0.4-0-0-lnx64?

 

   Thank you, CJ

 

Jarrett,

  I see that there is a 'download' command in the admin login whereas the guide says:

Step 1 Login to collector appliance as collectorlogin
Step 2 Switch to root using su - command
Step 3 To download the patch execute the command #download sp-30.0.4-0-0-lnx64

 Just for giggles I tried it from the admin login and it is downloading sp-30.0.0-0-0-lnx64 now.

 

Thank you, CJ

 

Jarrett,

   It appears that the download failed:

admin# sho download
        Version             : sp-30.0.0-0-0-lnx64
        Downloaded File     :
        Status              : Downloading
        Start Time          : May/01/2018 21:15:02
        End Time            : -
% Error occured while executing command null
admin#

   Looking at the firewall I am seeing port 80 being allowed to 72.163.7.60 (as stated in the Guide) but our firewall it is application aware and is allowing port 80 for web-browsing but denying port 80 for flash.  I will need to open 72.163.7.60:80/flash and retry the 'download sp-30.0.0-0-0-lnx64'.

  

   Thanks, CJ

Jarrett,

   I have not gotten the firewall open yet for the flash application but I tried rebooting the device with the reload command from admin to see if I could get the GUI back at least and after it came back up I am now unable to log back into admin:

 

java.net.ConnectException: Connection refused
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
        at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
        at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
        at java.net.SocksSocketImpl.connect(Unknown Source)
        at java.net.Socket.connect(Unknown Source)
        at java.net.Socket.connect(Unknown Source)
        at java.net.Socket.<init>(Unknown Source)
        at java.net.Socket.<init>(Unknown Source)
        at com.cisco.ca.ss.adminshell.client.ShellClient.main(ShellClient.java:63)
Error occured: could not connect to the command server

 

   I am still able to login as collectorlogin and root.  I've been busy :(

 

   Thanks, CJ

Jarrett,

   I see your post to demiller from last September 5th (https://supportforums.cisco.com/t5/smart-net-total-care-portal-and/cspc-login-error/td-p/3175979) and looks like the adminshell may be corrupted.  Considering I am still able to login to collectorlogin root is there any way to recover the adminshell without deploying a new OVA?

 

   Thank you, CJ

I am still receiving and error while performing the download -

 

admin# download sp-30.0.0-0-0-lnx64
Connecting to Software Download Server using User Id 'cpadiak10' ...

In order to download software, please indicate that you have read and agree
to be bound by the Cisco End User License Agreement which can be viewed at
http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html

Accept License Agreement (y|n)? y

The requested package sp-30.0.0-0-0-lnx64 is already downloading...
Please press Enter key to continue...

admin# show download
Version : sp-30.0.0-0-0-lnx64
Downloaded File :
Status : Downloading
Start Time : May/01/2018 21:15:02
End Time : -
% Error occured while executing command null
admin#

 

I did find the below article in the forum and I tried installing the LCM-fix-jan2015.zip but that put me back to being unable to login to admin with the Java exception errors.

 

https://supportforums.cisco.com/t5/smart-net-total-care-portal-and/check-update-d-and-download-command-errors/td-p/2779575

 

I then re-installed the CASP1.6.0.4_SecurityPatch and am able to login to admin once again but the download is still failing.

 

Thanks, CJ

 

Hello,

Can you please try to manually download and apply the 2.7 and 2.7.4 patches?  We have recently released a document which helps cover the steps needed.

 

https://www.cisco.com/c/dam/en/us/support/docs/cloud-systems-management/common-services-platform-collector-cspc/CSPC-Manual-Upgrade-Guide.pdf

 

2.7 Patch

2.7.4 Patch

 

Thank you,
Jarrett

 

View solution in original post

Jarrett,

   The patches have been applied successfully and we are now running 2.7.4.   Thanks again for your assistance.

Right-rail
Navigation
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links