cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.

455
Views
0
Helpful
8
Replies
Highlighted
Beginner

GUI not working after upgrade to 2.7.4.1

We upgraded our  CSPC collector to Version 2.7.4.1 today and CLI Access is working fine.

When trying to connect to the Web GUI, I get an "internal Server error" (see attachment).

 

Any idea on how to fix this issue?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: GUI not working after upgrade to 2.7.4.1

Short summary of the solution:

I found the script "cleanImproperPatch.sh" and run it as root.

After that I was able to start the update again and now it worked.

 

Script can be found via the link in this document:

https://www.cisco.com/c/dam/en/us/support/docs/cloud-systems-management/common-services-platform-collector-cspc/CSPC_Troubleshooting_Guide.pdf

 

 

View solution in original post

8 REPLIES 8
Highlighted
Cisco Employee

Re: GUI not working after upgrade to 2.7.4.1

Hi User,

 

From which version did you upgrade to 2.7.4.1? Please try below from CLI user root and let me know if issue persist.

 

# service cspc restart

 

Please allow time to restart service and log back in to GUI and update the result.

 

Thanks,

Supriya

Beginner

Re: GUI not working after upgrade to 2.7.4.1

Hi Supriya,

 

The GUI is now working and upgrade to Version 2.7.4.2 is available.

I tried to install it but it only  starts the download and then suddently stops without any error message.

 

During the download we get the following Status:

admin# show download

        Version             : sp-30.0.4-1-0-lnx64

        Download Location   : /opt/LCM/tmp/sp-30.0.4-1-0-lnx64-package.zip

        Status              : Downloaded

        Start Time          : Jun/11/2018 11:14:05

        End Time            : Jun/11/2018 12:01:49

        Reason For Failure  : -

 

        Version             : sp-30.0.4-2-0-lnx64

        Download Location   : -

        Status              : Downloading

        Start Time          : May/10/50481 01:42:09

        End Time            : -

        Reason For Failure  : -

 

Any idea what the Problem might be?

 

Best regards,

 

Michaela

Highlighted
Cisco Employee

Re: GUI not working after upgrade to 2.7.4.1

Hi Michaela,

 

It is hard to tell when did you start downloading. If it is done or not, it can be confirmed using user 'collectorlogin' or 'root' login to collector as well. Please login to collectorlogin and try 'ls -l /opt/LCM/tmp'. Please provide me this output for more idea on download status.

 

Thanks,

Supriya

Highlighted
Beginner

Re: GUI not working after upgrade to 2.7.4.1

Hi Supriya,

 

Now it states Status "downloaded" for sp-30.0.4-2-0-lnx64, but the upgrade hasn't been completed, as the current Version is still 2.7.4.1:

Version             : sp-30.0.4-2-0-lnx64
        Download Location   : /opt/LCM/tmp/sp-30.0.4-2-0-lnx64-package.zip
        Status              : Downloaded
        Start Time          : May/10/50481 01:42:09
        End Time            : Jul/06/2018 12:53:56
        Reason For Failure  : -

 

Here is the requested Output:

[collectorlogin@demchdc924x ~]$ ls -l /opt/LCM/tmp
total 1726544
drwxr-xr-x. 2 root    root           4096 Jul  9 13:58 downloads
-rw-r--r--. 1 casuser casusers 1222460079 Jun 11 12:01 sp-30.0.4-1-0-lnx64-package.zip
-rw-r--r--. 1 root    root      543776273 Jul  6 12:49 sp-30.0.4-2-0-lnx64-package.zip

 

The file size is much smaller than for Version 4.1. Is this normal?

 

I am currently trying the update again.

 

Best regards,

 

Michaela

Highlighted
Cisco Employee

Re: GUI not working after upgrade to 2.7.4.1

Hi Michaela,

 

Please check private message and update me.

 

Thanks,
Supriya

Highlighted
Cisco Employee

Re: GUI not working after upgrade to 2.7.4.1

Hi Michaela,

 

Beside my PM message, did you check file size after download is completed. could you please check again to confirm on file size.

 

This is what I have in my lab box.

 

[root@localhost collectorlogin]# cd /opt/LCM/tmp
[root@localhost tmp]# ls -l
total 1605424
-rw-r--r--. 1 root root 767504861 Jun 20 18:46 jeos-30.0.4-2-lnx64-package.zip
-rw-r--r--. 1 root root 876437290 Jun 20 19:25 sp-30.0.4-2-0-lnx64-package.zip

 

Thanks,

Supriya

Highlighted
Beginner

Re: GUI not working after upgrade to 2.7.4.1

Short summary of the solution:

I found the script "cleanImproperPatch.sh" and run it as root.

After that I was able to start the update again and now it worked.

 

Script can be found via the link in this document:

https://www.cisco.com/c/dam/en/us/support/docs/cloud-systems-management/common-services-platform-collector-cspc/CSPC_Troubleshooting_Guide.pdf

 

 

View solution in original post

Highlighted
Cisco Employee

Re: GUI not working after upgrade to 2.7.4.1

Hi Michaela,

 

Thanks for your update.

 

Thanks,

Supriya

CreatePlease to create content
Right-rail
Navigation
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links