Showing results for 
Search instead for 
Did you mean: 

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.


Inquiry of SNMP v3 for Discovery

My collector stopped loading


We are using multiple SNMP v3 passwords does the collector have the intelligence to go through each one during discovery or does it stop at the first one?


We are seeing NA mode for the devices. It was corrected by going under management - device access verification and find NA and moving order SNMPv3 string.

Does the SNMP v3 discovery go in order if there is multiple SNMP v3 strings/passwords?

Cisco Employee



Thank you for your question.  Would you be able to give us some more information on what has stopped loading on your CSPC?  Are you not able to log into the appliance anymore?

The CSPC is able to handle multiple community strings during discovery, these will run in priority based on the order that you view them in your device credential page.  The order can be changed using the up and down arrows on the right side of that window.

If possible, could you please also capture a screenshot of your issue?

Thank you,



Hi Jarrett,

Hi Jarrett,

I can login the collector without issue, but my issue is that I'm running multiple SNMP v3 usernames/passwords (5 in total) to collect the inventory on my network, but it seems to be a limitation on the first two SNMP v3 usernames and not the total of all 5. The devices that are using the last three SNMP v3 usernames go into NA name status. Is there a limitation with CSP 2.4 on the SNMP v3 usernames used?




I have SNMP v3 setup on

Cisco Employee

Hi Derrick!

Hi Derrick!

When you first discover a device, the collector will go through every credential and try to use it on the device. So if you have 3 snmpv3 strings and 3 snmpv2 strings and 3 ssh credentials, then collector will try a total of 9 credentials.

It will then "remember" which credentials worked on the device.

When the inventory runs, it will then use the credentials that worked during the discovery to do the device polling. If the credentials changed between the time the device was discovered and the time time the inventory runs, then it is possible that the inventory will not complete successfully on the device.

This should be easily fixed by going to Settings > Manage Data Collection Profiles and modifying the profile details so that the box "Run Discovery before Inventory" is selected. 

If that doesn't work, sometimes you have to "unhook" the old credential with the new one by un-managing the device and re-discovering it. You do this by going to Management > Unmanage Devices and then selecting the device(s) that are giving you issues. Then re-run the discovery by going to Management > Discover and Manage Device and add them back in by IP.



Hi Lynden,

Hi Lynden,

This is Derrick from NASDAQ, and I will try your suggested/recommended fix and get back to you shortly.


Derrick Cassidy

CreatePlease to create content
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links