cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.

472
Views
0
Helpful
6
Replies
Highlighted
Beginner

unable to collect or upload

Hello,

 

we are trying to install and configure the CSPC, we are able to entitle the server but the automatic upload fails with a generic internal server error, and in there's no menu or view to manual upload the collection via web.

I suppose something wrong with the configuration or on the association of the SNTC with our account.

Can someone explain where start to check?

The server is registered and I can see the version on the portal services.cisco.com, version 2.8.1.6.

 

Thanks,

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Thank you in looking at the logs the more specific error found is -->

[className=com.cisco.ca.csp.conn.gateway.tailend.core.command.SendFileCommandHTTPS][methodName=uploadFileILB][lineNumber=625][isRemote=false]: message: Send File failed,http status code:404

Please at the root Prompt do the following and let me know

Via SSH Login to collector as user collectorlogin and then use command below to connect as root (cannot connect directly)

# su root

and then the following commands :

# sed -i ':a;N;$!ba;s/file/#file/1' /opt/ConcsoTgw/tail-end-gateway-decoupled/bin/run.sh

# sed -i 's/nettools-upload.cisco.com/72.163.7.113/g' /opt/ConcsoTgw/tail-end-gateway-decoupled/conf/csof_config.xml

# service concsotgw restart

# service cspc restart  

Once they are done try the collection profile/upload again

 

REF : https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvo43779

View solution in original post

6 REPLIES 6
Highlighted
Cisco Employee

 

You mentioned you are unable to "collect" did the collection profile failed or just the upload module of it?

 

Re: Unable to upload Inventory - Internet Server Error

OK for troubleshooting please do the following :

 

We will need to connect via ssh to the user collectorlogin and then su to root

if you only have access to the admin cli user you can activate and generate the passwords with the commands below

If you do have have that access connect via SSH using the admin user and its passwords ad do the following :

admin#  pwdreset collectorlogin 90

and

admin# pwdreset root 90

 

If you already have access to collectorlogin and root access do the following

Connect to the user via ssh collectorlogin then su to root as shown below

$ su root

and then send me the output of the following commands on a private message.

 

# tail -100 /opt/ConcsoTgw/tail-end-gateway-decoupled/bin/CONN_TEG_LOGS/tail-end-gateway.log

# openssl s_client -showcerts -connect concsoweb-prd.cisco.com:443

# tail -100 /opt/ConcsoTgw/tail-end-gateway-decoupled/bin/nohup.out

# wget https://72.163.7.113/HeadEndWebAppServlet/ --no-check-certificate

Highlighted

Thanks for your support.

From my understanding, the issue could be on the upload module.

I'm sending the log by private message.

 

 

Thanks

Highlighted

Thank you in looking at the logs the more specific error found is -->

[className=com.cisco.ca.csp.conn.gateway.tailend.core.command.SendFileCommandHTTPS][methodName=uploadFileILB][lineNumber=625][isRemote=false]: message: Send File failed,http status code:404

Please at the root Prompt do the following and let me know

Via SSH Login to collector as user collectorlogin and then use command below to connect as root (cannot connect directly)

# su root

and then the following commands :

# sed -i ':a;N;$!ba;s/file/#file/1' /opt/ConcsoTgw/tail-end-gateway-decoupled/bin/run.sh

# sed -i 's/nettools-upload.cisco.com/72.163.7.113/g' /opt/ConcsoTgw/tail-end-gateway-decoupled/conf/csof_config.xml

# service concsotgw restart

# service cspc restart  

Once they are done try the collection profile/upload again

 

REF : https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvo43779

View solution in original post

Highlighted

Hi,

Thank you!
Seems it worked, the job on the server was completed without any fail, but I'm not able to see the data on the cisco portal.
Where I should find the information?
I tried to open the service.cisco.com but after the collection, I see a blank page and nothing else I tried to change pc, internet line and browser without success, always a blank page


Thanks
Highlighted

Hello,
The initial upload to Cisco takes a bit longer to process, please check again and let us know if the issue has been resolved from your view as we can confirm your upload has completed end-to-end processing.
Thank you
Highlighted

Its working, thanks for your support!
CreatePlease to create content
Right-rail
Navigation
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links