cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.

86
Views
0
Helpful
3
Replies
AC4 Beginner
Beginner

Update to 2.8.1.5 failed

Hola:

 

Estoy tratando de actualizar el collector de versión 2.8.1.4 a versión 2.8.1.5 pero el sistema se quedó en un estado de " Apply-in-progress" y no sale de ahí.

 

Qué se puede hacer?

 

Anexo foto del estado de la actualización.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Update to 2.8.1.5 failed

AC4

 

En este caso tendras que desplegar una nueva instancia del Colector - puedes exportar lo siguiente del WebUI del Colector como respalde(s) - Managed Device List, Device Crendentials, Managed Users, Collection Profile y cualquier otra configuracion del Colector dado que lo usas (como Remote Authentication por ejemplo). Siempre recuerde que es buena practica tener aceso por CLI con esos usarios, tambien tener por lo menos un usario demas por el lado del WebUI y hacer snapshots del VM por si acaso es necesario. Espero que esto sea algo de ayuda.

Saludos

-AC

3 REPLIES 3
Cisco Employee

Re: Update to 2.8.1.5 failed

Buenas tardes AC4,

 

Si tienes aceso al CLI del colector, ingresa como 'collectorlogin' -> cambia de usuario a 'root' y cambias el directorio a /opt/LCM/tmp - revisa alli para ver si el parche esta presente. Tambien haga un cambio de usuario a 'admin' y corre lo siguiente:

 

#show download

#show download progress

#show apply

#show apply progress

 

Dependiendo si el parche se descargo con exito, osea 100%, podras proceder con la instalacion manual por medio del usuario 'root'. Llega nuevamente a /opt/LCM/tmp y descomprime el archivo .zip. Esta parte es importante dado que hay un orden especifico con respecto a la instalacion del parche.. el contenido del .zip debe tener dos parches - JeOS y SP. Hay que instalar el JeOS primero y despues el SP.

 

Corre lo siguiente para arrancar la instalacion en este orden:

#nohup /opt/LCM/bin/lcmagent-apply.tcl JeOS <parche del JeOS>

El script de instalcion se toma cargo de todo - es decir no tienes que hacer mas nada - incluso no reinices el servidor para nada - cuando llega a terminar, el servidor se reinicia. Puedes ver el progreso en tiempo real con correr:

#tail -f /opt/LCM/logs/*

 

Verifica por el 'adminshell' la version instalado - #sh ver -d 


Continua con la segunda porcion del parche - el SP

#nohup /opt/LCM/bin/lcmagent-apply.tcl SP <parche del SP>

 

Cuando termina revisa nuevamente por el adminshell - #sh ver -d

 

Espero que sea algo de ayuda.

-AC

AC4 Beginner
Beginner

Re: Update to 2.8.1.5 failed

Hola Antchris:

 

Gracias por su pronta respuesta, le comento que no tengo acceso al colector por CLI, no se tiene la contraseña de collectorlogin y root .

 

Que puedo hacer al respecto?

 

AC4

Highlighted
Cisco Employee

Re: Update to 2.8.1.5 failed

AC4

 

En este caso tendras que desplegar una nueva instancia del Colector - puedes exportar lo siguiente del WebUI del Colector como respalde(s) - Managed Device List, Device Crendentials, Managed Users, Collection Profile y cualquier otra configuracion del Colector dado que lo usas (como Remote Authentication por ejemplo). Siempre recuerde que es buena practica tener aceso por CLI con esos usarios, tambien tener por lo menos un usario demas por el lado del WebUI y hacer snapshots del VM por si acaso es necesario. Espero que esto sea algo de ayuda.

Saludos

-AC

CreatePlease to create content
Right-rail
Navigation
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links