cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Smart Net Total Care Community!

Our community includes Cisco experts to answer your questions about the Smart Net Total Care (SNTC) portal and CSP-Collector.
Click the navigation links below to access materials for using our service and supported collectors.

3718
Views
31
Helpful
44
Replies
Highlighted
Beginner

Where is my CSPC upload ?

I just had my CSPC server rebuilt,,I had been having problems uploading my inventory.

I have followed the quick start instructions.

I have followed instructions posted on this link

https://supportforums.cisco.com/blog/12987426/self-service-onboarding-where-my-upload-cspc-collector-troubleshooting

(The internal firewall is enabled & I can see the output of iptables,, but wondering if I have to open ports on the CSPC firewall, my external firewall will permit CSPC to open ports 80 & 443 with any internet host... )

I have created an upload profile. When I run the upload profile I see 
Initialize_files                         Successful
Dumping_Upload_Data         Successful
Zip_File_Creation                  Successful
Upload_to_Backend              Successful

My CSPC server is registered to my SNTC portal.

When I check "Upload Processing" on my SNTC portal,, I do not see my inventory is being uploaded.

What can I do to troubleshoot this issue ?
I do not see my inventory being uploaded.

44 REPLIES 44
Highlighted

Updating again today.
I have installed a fresh copy of CSPC 2.6 onto a new VM using the proper OVAfor SNTC.
The new CSPC server has received a new entitlement & the CSPC server is registered on my SNTC console.
I have followed the instructions from the Quickstart guide.
Discovery & Inventory ran "successfully",, but did not appear on my SNTC console.

For diagnostic purposes,, I created & ran an upload profile.
The first 3 steps of the "upload profile" are successful,, but the last step gets an ERROR which says "http status 503 - AuthzFilter Exception">

Is there any step I can take to resolve this problem ?

Highlighted

Hey thomas gilmore,

Were you able to try running the command "timesync"?  Once ran, it will prompt you to enter a server for the time.  Enter the pool.NTP sever and confirm this selection.  Once the new time server is set, can you try processing another upload?

Thanks,

Justin

Highlighted

justin,

I have been following & applying recommendations made in this thread.
Earlier,, I ran "timesync" on my CSPC server & it did help. I am now able to run 'upload processing' without any error.

The problem is that My discovery, Inventory & upload processing jobs all run successfully,, but apparently not uploading to my SNTC portal.
When I check "upload processing" on SNTC.. it only indicates my manual uploads & nothing is being uploaded from my CSPC to SNTC.

What other steps can I take  ?

Highlighted

Hi Tom,

Was this a newly deployed 2.6 image, or was this an upgrade? What was the original version of the collector, and what was the file name of the OVA you deployed.

Your collection profile looks a bit odd. Did you create the collection profile yourself or are you using the default sntc1x_min_cp? The file name prefix at the bottom should be "Min_VSEM".

Also, select NetAuth-SSL for your upload mechanism. It should have been selected automatically in the image, which is why I think something might be off.

Thanks,

Lynden

Highlighted

Lynden,

We were unable to log on to the original CSPC server (creds changed & the former admin left the company), so I had the OS replaced. Our CSPC install was a fresh OVA & had no inventory when we first began.

I did not create the collection profile myself,, There are 2 collection profiles.
Min_collection_profile and Default_CP. ( I have run both profiles,, but still unable to see the upload)

I changed the collection profile to  NetAuth_SSL  (Settings/Application Settings/Export Settings/Upload via NetAuth_SSL) & then tested the upload collection profile (It had been always successful when the export method was set to connectivity). The upload profile failed "upload to backend" while the "export method" is set to NetAuth_SSL

Highlighted

What is the name of the OVA you deployed? I think you may have deployed the wrong image.

This is the link to the SNTC OVA:

https://software.cisco.com/download/type.html?mdfid=283107976&catid=null

Highlighted

The customer deployed the OVA so I am waiting to hear back from them to confirm it was the correct OVA. is there a way I can tell from the CLI or GUI? If I show version from the CLI I see the following:


admin# show version
        Build-name   : PSS CSPC 2.6.0.1

        Version      : sp-3.0.7-0-0-lnx64

Highlighted

It should be:

admin# show version
Build-name : SNTC CSPC 2.6.1

Version : sp-2.0.5-0-0-lnx64

Your customer deployed the PSS image, which is a different service with a different portal.

You can download the SNTC OVA here:

https://software.cisco.com/download/type.html?mdfid=283107976&catid=null

With instructions for deployment here:

https://supportforums.cisco.com/blog/12696871/self-service-onboarding-setting-cspc-25-collector

Thanks,

Lynden

Highlighted

Lynden,
I just got back to this discussion.
My OVF was a  2.6 install.

*******************

To see the list of all the commands press '?'
admin#
admin# sh ver
Build-name : PSS CSPC 2.6.0.1

Version : sp-3.0.7-0-0-lnx64
admin#
****************
I have attached a clip of the file -- PSS_CSPCServer -2.6.0.1-OVF10

Highlighted

Hi Thomas,

You have deployed the PSS OVA. You should deploy the SNTC OVA:

https://supportforums.cisco.com/blog/12696871/self-service-onboarding-setting-cspc-25-collector

Thanks,

Lynden

Highlighted

Thank you Lyden,,, I have downloaded the SNTC-CSPC.ova file & requested a new VM.
My next update may take one or two weeks.. 
Just waiting on the new VM.

Highlighted

my data collection profile is good but when i check my export settings in the first part of your response I do not have HTTP as an option. see my screenshot..

Nevermind I see I was not the first to notice this

Highlighted

I completed this step weeks ago,, but still do not see my inventory being uploaded to SNTC.
 Setting -> Manage data collection profiles - > Then select Sntc1x_min_cp -> Then go to Modify collection profile -> Then go to Profile details -> Drag down at last you get the option - > Export options check that box then check Upload to remote server

Highlighted

Yep, same issue here.

Deployed a new collector instance (rebuild of existing collector - same entitlement used) - initiated the upload - collector logs show upload completed OK but... no inventory ever seen in SNTC - so I've no idea where it went.

Several existing inventories are OK.

Highlighted
Beginner

Jumin,

I finally do have inventory on SNTC. I had to click the pencil icon at the very top left of the SNTC console. My "older inventory" from a previous CSPC build was checked, but I needed to "check" a box that indicated my current CSPC server .

Yes,, I do see the inventory.

Thank you !!

Right-rail
Navigation
Be sure to bookmark these support pages and use them in the future to find all the self-help information.
Helpful Links