cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1426
Views
0
Helpful
8
Replies
ali ezzat1
Beginner

PXE didn't get IP through SDA fabric.

Dears,

 

Any help as the PXE working fine in traditional network and after upgrade to SDA fabric (DNA) it is not working and can't get IP from DHCP server and the scope is configured the same like traditional scope with all options, is there is any additional info must added to DNA?

 

Note that:

- DHCP is working fine with users so the network and the firewall is passing the traffic

- PXE working in traditional on the same DHCP server

- MAC added to the ISE 

- when make the port no authentication and assign the VLAN manually on the fabric Edge still the same problem 

 

any suggestion as TAC team can't solve it from month ago.

 

Thanks,

Ali Ezzat

8 REPLIES 8
jedolphi
Cisco Employee

Hello Ali, There is a slide on SDA + PXE boot in BRKCRS-3493 on www.ciscolive.com , can you please review? Sound like maybe your PXE implementation is dropping option 82. Here's the URL, https://www.ciscolive.com/global/on-demand-library.html?search=brkcrs-3493#/session/1571888607137001yDeW , best regard, Jerome

Thanks Jedolphi for your support but the Device didn't take ip from the DHCP before connecting to PXE server

 

so i need any help to make the PXE device take ip then communicate to sccm server to download the windows.

 

Thanks,

 

Hi Ali,

I'm having trouble understanding the issue. When you say the device does not take an IP address, are you saying that the PXE client requests an IP over DHCP, but it does not receive a DHCP response? Have you done a packet capture on the DHCP server to confirm the DHCP request/response is happening on the DHCP server? If you have done the packet capture, and if the DHCP server is replying, but the response never gets to the DHCP client, then this could be an issue with option 82 or your border configuration. TAC can definitely help with this. Also you could review BRKCRS-3810 to see how option 82 is used on the border to direct DHCP responses correctly within SD-Access fabric.

Best regards, Jerome

WhatsApp Image 2020-06-08 at 1.31.04 PM (1).jpeg

WhatsApp Image 2020-06-08 at 1.31.04 PM.jpegnow PC can get IP from DHCP after adding PXE server to subnets pool as a DHCP server so IP helper added to the interface VLAN but this error appeared , any one can help , 

 

note that PXE working fine with traditional solution 

- when make the port no authentication and assign the VLAN manually on the fabric Edge still the same problem
Is this still the same case when you configure the host onboarding with no auth? I have had issues with the pxe process due to default closed auth timers and overall configuration. Tweaking the order, priority, and timers with templates in DNAC helped fix our issue.

I had the same issue. This has to do with the SCCM PXE responder. Option 82 was introduced in version 1906.

“Our 1906 release is now available and has added support for option 82. Please note this only applies to the new PXE responder.“

This was from our SCCM guy "PXE used to rely on a Windows Server OS with the Windows Deployment Server role installed, but they’ve recently re-designed the PXE responder, and now it can run on any Windows OS (Server or Workstation) and no longer relies on the WDS role. Our services are still using the WDS functionality, just because we hadn’t had a reason to change them up until now."

Also this. https://configurationmanager.uservoice.com/forums/300492-ideas/suggestions/32370460-need-support-for-option-82-in-pxe-dhcp-handshake-a

 

 

Not sure if this helps, but he made the changes and it worked for us.

 

 

Cheers,

 

Thanks Mike and Brock for your contributions! Also I see in the photo the error messages "NBP is too big to fit in free base memory". Not a PXE expert, but, maybe this is relevant too? Google searching that message shows some problems and suggested solutions. Jerome

We were using an additional IP helper to point at the pxe server and ISE to recognise the device was a machine to be built.  During the troubleshooting I could get any normal client to operate fine, but a pxe client never accepted the ip address it was assigned, nor did the sccm build server understand where the client was.  This was only a problem in a fabric network. In the end to get pxe running I had to create a vendor class for the AFI object and send options 66 and 67 in response on the dhcp server and remove the third helper. All of a sudden everything is fine and working.

Content for Community-Ad
This widget could not be displayed.